php56-php-interbase-5.6.40-12.el7.remi.x86_64.rpm


Advertisement

Description

php56-php-interbase - A module for PHP applications that use Interbase/Firebird databases

Property Value
Distribution CentOS 7
Repository Les RPM de Remi x86_64
Package filename php56-php-interbase-5.6.40-12.el7.remi.x86_64.rpm
Package name php56-php-interbase
Package version 5.6.40
Package release 12.el7.remi
Package architecture x86_64
Package type rpm
Category Development/Languages
Homepage http://www.php.net/
License PHP
Maintainer -
Download size 83.74 KB
Installed size 121.79 KB
The php56-php-interbase package contains a dynamic shared object that will add
database support through Interbase/Firebird to PHP.
InterBase is the name of the closed-source variant of this RDBMS that was
developed by Borland/Inprise.
Firebird is a commercially independent project of C and C++ programmers,
technical advisors and supporters developing and enhancing a multi-platform
relational database management system based on the source code released by
Inprise Corp (now known as Borland Software Corp) under the InterBase Public
License.

Alternatives

Package Version Architecture Repository
php56-php-interbase-5.6.40-13.el7.remi.x86_64.rpm 5.6.40 x86_64 Les RPM de Remi
php56-php-interbase-5.6.40-6.el7.remi.x86_64.rpm 5.6.40 x86_64 Les RPM de Remi Testing
php56-php-interbase-5.6.30-2.el7.remi.x86_64.rpm 5.6.30 x86_64 Les RPM de Remi Testing
php56-php-interbase - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libfbclient.so.2()(64bit) -
php56-php-pdo(x86-64) = 5.6.40-12.el7.remi
rtld(GNU_HASH) -

Provides

Name Value
php56-php-firebird -
php56-php-firebird(x86-64) -
php56-php-interbase = 5.6.40-12.el7.remi
php56-php-interbase(x86-64) = 5.6.40-12.el7.remi
php56-php-pdo_firebird -
php56-php-pdo_firebird(x86-64) -
php56-php_database -

Download

Type URL
Mirror rpms.remirepo.net
Binary Package php56-php-interbase-5.6.40-12.el7.remi.x86_64.rpm
Source Package php56-php-5.6.40-12.el7.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/enterprise/7/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php56-php-interbase rpm package:
    # yum --enablerepo=remi install php56-php-interbase

Files

Path
/opt/remi/php56/root/etc/php.d/20-interbase.ini
/opt/remi/php56/root/etc/php.d/30-pdo_firebird.ini
/opt/remi/php56/root/usr/lib64/php/modules/interbase.so
/opt/remi/php56/root/usr/lib64/php/modules/pdo_firebird.so

Changelog

2019-07-30 - Remi Collet <remi@remirepo.net> - 5.6.40-12
- exif:
Fix #78256 heap-buffer-overflow on exif_process_user_comment
CVE-2019-11042
Fix #78222 heap-buffer-overflow on exif_scan_thumbnail
CVE-2019-11041
- phar:
Fix #77919 Potential UAF in Phar RSHUTDOWN
2019-07-02 - Remi Collet <remi@remirepo.net> - 5.6.40-11
- use oracle client library version 19.3
2019-05-28 - Remi Collet <remi@remirepo.net> - 5.6.40-9
- iconv:
Fix #78069 Out-of-bounds read in iconv.c:_php_iconv_mime_decode()
CVE-2019-11039
- exif:
Fix #77988 Heap-buffer-overflow on php_jpg_get16
CVE-2019-11040
- sqlite3:
Fix #77967 Bypassing open_basedir restrictions via file uris

See Also

Package Description
php56-php-intl-5.6.40-12.el7.remi.x86_64.rpm Internationalization extension for PHP applications
php56-php-intl-5.6.40-13.el7.remi.x86_64.rpm Internationalization extension for PHP applications
php56-php-ioncube-loader-10.3.8-1.el7.remi.x86_64.rpm Loader for ionCube Encoded Files with ionCube 24 support
php56-php-ioncube-loader-10.3.9-1.el7.remi.x86_64.rpm Loader for ionCube Encoded Files with ionCube 24 support
php56-php-ldap-5.6.40-12.el7.remi.x86_64.rpm A module for PHP applications that use LDAP
php56-php-ldap-5.6.40-13.el7.remi.x86_64.rpm A module for PHP applications that use LDAP
php56-php-libvirt-0.5.3-2.el7.remi.x86_64.rpm PHP language binding for Libvirt
php56-php-libvirt-0.5.4-1.el7.remi.x86_64.rpm PHP language binding for Libvirt
php56-php-libvirt-doc-0.5.3-2.el7.remi.noarch.rpm Document of php-libvirt
php56-php-libvirt-doc-0.5.4-1.el7.remi.noarch.rpm Document of php-libvirt
php56-php-litespeed-5.6.40-12.el7.remi.x86_64.rpm LiteSpeed Web Server PHP support
php56-php-litespeed-5.6.40-13.el7.remi.x86_64.rpm LiteSpeed Web Server PHP support
php56-php-lz4-0.3.4-1.el7.remi.x86_64.rpm LZ4 Extension for PHP
php56-php-lz4-0.3.6-1.el7.remi.x86_64.rpm LZ4 Extension for PHP
php56-php-magickwand-1.0.9.2-12.el7.remi.x86_64.rpm PHP API for ImageMagick
Advertisement
Advertisement