php-zendframework-zend-stratigility-1.3.2-1.el7.remi.noarch.rpm


Advertisement

Description

php-zendframework-zend-stratigility - Middleware for PHP

Property Value
Distribution CentOS 7
Repository Les RPM de Remi x86_64
Package filename php-zendframework-zend-stratigility-1.3.2-1.el7.remi.noarch.rpm
Package name php-zendframework-zend-stratigility
Package version 1.3.2
Package release 1.el7.remi
Package architecture noarch
Package type rpm
Category Development/Libraries
Homepage https://zendframework.github.io/zend-stratigility/
License BSD
Maintainer -
Download size 33.79 KB
Installed size 123.41 KB
From "Strata", Latin for "layer", and "agility".
This package supercedes and replaces phly/conduit.
Stratigility is a port of Sencha Connect to PHP.
It allows you to create and dispatch middleware pipelines.
* File issues at https://github.com/zendframework/zend-stratigility/issues
* Issue patches to https://github.com/zendframework/zend-stratigility/pulls
* Documentation is at https://zendframework.github.io/zend-stratigility/

Alternatives

Package Version Architecture Repository
php-zendframework-zend-stratigility-1.3.3-1.el7.remi.noarch.rpm 1.3.3 noarch Les RPM de Remi
php-zendframework-zend-stratigility-1.2.1-2.el7.remi.noarch.rpm 1.2.1 noarch Les RPM de Remi Testing
php-zendframework-zend-stratigility - - -

Requires

Name Value
php(language) >= 5.6
php-composer(http-interop/http-middleware) >= 0.2
php-composer(psr/http-message) >= 1.0
php-composer(psr/http-message) < 2
php-composer(zendframework/zend-escaper) < 3
php-composer(zendframework/zend-escaper) >= 2.3
php-composer(zendframework/zend-loader) >= 2.5
php-pcre -
php-reflection -
php-spl -
php-zendframework-zend-loader >= 2.5.1-4

Provides

Name Value
php-composer(zendframework/zend-stratigility) = 1.3.2
php-zendframework-zend-stratigility = 1.3.2-1.el7.remi

Download

Type URL
Mirror rpms.remirepo.net
Binary Package php-zendframework-zend-stratigility-1.3.2-1.el7.remi.noarch.rpm
Source Package php-zendframework-zend-stratigility-1.3.2-1.el7.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/enterprise/7/remi/x86_64/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-zendframework-zend-stratigility rpm package:
    # yum --enablerepo=remi install php-zendframework-zend-stratigility

Files

Path
/usr/share/doc/php-zendframework-zend-stratigility-1.3.2/CHANGELOG.md
/usr/share/doc/php-zendframework-zend-stratigility-1.3.2/CONDUCT.md
/usr/share/doc/php-zendframework-zend-stratigility-1.3.2/CONTRIBUTING.md
/usr/share/doc/php-zendframework-zend-stratigility-1.3.2/README.md
/usr/share/doc/php-zendframework-zend-stratigility-1.3.2/composer.json
/usr/share/licenses/php-zendframework-zend-stratigility-1.3.2/LICENSE
/usr/share/php/Zend/Stratigility-autoload.php
/usr/share/php/Zend/Stratigility/Dispatch.php
/usr/share/php/Zend/Stratigility/ErrorMiddlewareInterface.php
/usr/share/php/Zend/Stratigility/FinalHandler.php
/usr/share/php/Zend/Stratigility/MiddlewareInterface.php
/usr/share/php/Zend/Stratigility/MiddlewarePipe.php
/usr/share/php/Zend/Stratigility/Next.php
/usr/share/php/Zend/Stratigility/NoopFinalHandler.php
/usr/share/php/Zend/Stratigility/Route.php
/usr/share/php/Zend/Stratigility/Utils.php
/usr/share/php/Zend/Stratigility/Delegate/CallableDelegateDecorator.php
/usr/share/php/Zend/Stratigility/Exception/InvalidMiddlewareException.php
/usr/share/php/Zend/Stratigility/Exception/InvalidRequestTypeException.php
/usr/share/php/Zend/Stratigility/Exception/MiddlewareException.php
/usr/share/php/Zend/Stratigility/Exception/MissingDelegateException.php
/usr/share/php/Zend/Stratigility/Exception/MissingResponseException.php
/usr/share/php/Zend/Stratigility/Exception/MissingResponsePrototypeException.php
/usr/share/php/Zend/Stratigility/Http/Request.php
/usr/share/php/Zend/Stratigility/Http/Response.php
/usr/share/php/Zend/Stratigility/Http/ResponseInterface.php
/usr/share/php/Zend/Stratigility/Middleware/CallableInteropMiddlewareWrapper.php
/usr/share/php/Zend/Stratigility/Middleware/CallableMiddlewareWrapper.php
/usr/share/php/Zend/Stratigility/Middleware/ErrorHandler.php
/usr/share/php/Zend/Stratigility/Middleware/ErrorResponseGenerator.php
/usr/share/php/Zend/Stratigility/Middleware/NotFoundHandler.php
/usr/share/php/Zend/Stratigility/Middleware/OriginalMessages.php

Changelog

2017-01-06 - Remi Collet <remi@fedoraproject.org> - 1.3.2-1
- update to 1.3.2
2016-11-11 - Remi Collet <remi@fedoraproject.org> - 1.3.1-1
- update to 1.3.1
2016-11-10 - Remi Collet <remi@fedoraproject.org> - 1.3.0-1
- update to 1.3.0
- raise dependency on PHP 5.6
- add dependency on http-interop/http-middleware

See Also

Package Description
php-zendframework-zend-tag-2.6.1-1.el7.remi.noarch.rpm Zend Framework Tag component
php-zendframework-zend-tag-2.7.0-1.el7.remi.noarch.rpm Zend Framework Tag component
php-zendframework-zend-test-2.6.1-1.el7.remi.noarch.rpm Zend Framework Test component
php-zendframework-zend-test-2.6.1-2.el7.remi.noarch.rpm Zend Framework Test component
php-zendframework-zend-text-2.6.0-1.el7.remi.noarch.rpm Zend Framework Text component
php-zendframework-zend-text-2.7.0-1.el7.remi.noarch.rpm Zend Framework Text component
php-zendframework-zend-uri-2.6.2-1.el7.remi.noarch.rpm Zend Framework Uri component
php-zendframework-zend-uri-2.7.0-1.el7.remi.noarch.rpm Zend Framework Uri component
php-zendframework-zend-validator-2.11.0-1.el7.remi.noarch.rpm Zend Framework Validator component
php-zendframework-zend-validator-2.11.1-1.el7.remi.noarch.rpm Zend Framework Validator component
php-zendframework-zend-version-2.5.1-1.el7.remi.noarch.rpm Zend Framework Version component
php-zendframework-zend-view-2.9.0-1.el7.remi.noarch.rpm Zend Framework View component
php-zendframework-zend-view-2.9.1-1.el7.remi.noarch.rpm Zend Framework View component
php-zendframework-zend-xml2json-3.1.0-1.el7.remi.noarch.rpm Provides functionality for converting XML to JSON
php-zendframework-zend-xmlrpc-2.6.2-1.el7.remi.noarch.rpm Zend Framework XmlRpc component
Advertisement
Advertisement