python36-neovim-0.3.2-1.el7.noarch.rpm


Advertisement

Description

python36-neovim - Python client to Neovim

Property Value
Distribution CentOS 7
Repository EPEL x86_64
Package filename python36-neovim-0.3.2-1.el7.noarch.rpm
Package name python36-neovim
Package version 0.3.2
Package release 1.el7
Package architecture noarch
Package type rpm
Homepage https://github.com/neovim/pynvim
License ASL 2.0
Maintainer -
Download size 78.33 KB
Installed size 324.14 KB
Implements support for python plugins in Nvim. Also works as a library for
connecting to and scripting Nvim processes through its msgpack-rpc API.

Alternatives

Package Version Architecture Repository
python36-neovim - - -

Requires

Name Value
neovim -
python(abi) = 3.6
python36-greenlet -
python36-msgpack -

Provides

Name Value
python36-neovim = 0.3.2-1.el7

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package python36-neovim-0.3.2-1.el7.noarch.rpm
Source Package python-neovim-0.3.2-1.el7.src.rpm

Install Howto

  1. Download latest epel-release rpm from
    http://download-ib01.fedoraproject.org/pub/epel/7/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install python36-neovim rpm package:
    # yum install python36-neovim

Files

Path
/usr/lib/python3.6/site-packages/neovim/__init__.py
/usr/lib/python3.6/site-packages/neovim/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/neovim/api/__init__.py
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/neovim/api/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/__init__.py
/usr/lib/python3.6/site-packages/pynvim/compat.py
/usr/lib/python3.6/site-packages/pynvim/util.py
/usr/lib/python3.6/site-packages/pynvim-0.3.2-py3.6.egg-info/PKG-INFO
/usr/lib/python3.6/site-packages/pynvim-0.3.2-py3.6.egg-info/SOURCES.txt
/usr/lib/python3.6/site-packages/pynvim-0.3.2-py3.6.egg-info/dependency_links.txt
/usr/lib/python3.6/site-packages/pynvim-0.3.2-py3.6.egg-info/not-zip-safe
/usr/lib/python3.6/site-packages/pynvim-0.3.2-py3.6.egg-info/requires.txt
/usr/lib/python3.6/site-packages/pynvim-0.3.2-py3.6.egg-info/top_level.txt
/usr/lib/python3.6/site-packages/pynvim/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/__pycache__/compat.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/__pycache__/compat.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/__pycache__/util.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/__pycache__/util.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__init__.py
/usr/lib/python3.6/site-packages/pynvim/api/buffer.py
/usr/lib/python3.6/site-packages/pynvim/api/common.py
/usr/lib/python3.6/site-packages/pynvim/api/nvim.py
/usr/lib/python3.6/site-packages/pynvim/api/tabpage.py
/usr/lib/python3.6/site-packages/pynvim/api/window.py
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/buffer.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/buffer.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/common.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/common.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/nvim.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/nvim.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/tabpage.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/tabpage.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/window.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/api/__pycache__/window.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/__init__.py
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/async_session.py
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/msgpack_stream.py
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/session.py
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/__pycache__/async_session.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/__pycache__/async_session.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/__pycache__/msgpack_stream.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/__pycache__/msgpack_stream.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/__pycache__/session.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/__pycache__/session.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/__init__.py
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/asyncio.py
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/base.py
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/uv.py
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/__pycache__/asyncio.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/__pycache__/asyncio.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/__pycache__/base.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/__pycache__/base.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/__pycache__/uv.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/msgpack_rpc/event_loop/__pycache__/uv.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/plugin/__init__.py
/usr/lib/python3.6/site-packages/pynvim/plugin/decorators.py
/usr/lib/python3.6/site-packages/pynvim/plugin/host.py
/usr/lib/python3.6/site-packages/pynvim/plugin/script_host.py
/usr/lib/python3.6/site-packages/pynvim/plugin/__pycache__/__init__.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/plugin/__pycache__/__init__.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/plugin/__pycache__/decorators.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/plugin/__pycache__/decorators.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/plugin/__pycache__/host.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/plugin/__pycache__/host.cpython-36.pyc
/usr/lib/python3.6/site-packages/pynvim/plugin/__pycache__/script_host.cpython-36.opt-1.pyc
/usr/lib/python3.6/site-packages/pynvim/plugin/__pycache__/script_host.cpython-36.pyc
/usr/share/doc/python36-neovim-0.3.2/README.md
/usr/share/licenses/python36-neovim-0.3.2/LICENSE

Changelog

2019-06-20 - Michel Alexandre Salim <salimma@fedoraproject.org> - 0.3.2-1
- Update to version 0.3.2
- Properly build the python2 subpackage
2019-03-08 - Troy Dawson <tdawson@redhat.com> - 0.3.1-3
- Rebuilt to change main python from 3.4 to 3.6
2019-01-31 - Matěj Cepl <mcepl@cepl.eu> - 0.3.1-2
- Make python2 subpackage working.
2019-01-02 - Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.3.1-2
- Enable python dependency generator
2019-01-02 - Andreas Schneider <asn@redhat.com> - 0.3.1-1
- Update to version 0.3.1
2018-09-26 - Andreas Schneider <asn@redhat.com> - 0.2.6-4
- resolves: #1632298 - Remove python2 sub-packages
2018-07-14 - Fedora Release Engineering <releng@fedoraproject.org> - 0.2.6-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-06-19 - Miro Hrončok <mhroncok@redhat.com> - 0.2.6-2
- Rebuilt for Python 3.7
2018-05-03 - Andreas Schneider <asn@redhat.com> - 0.2.6-1
- resolves: #1574026 - Update to 0.2.6
2018-03-12 - Filip Szymański <fszymanski@fedoraproject.org> - 0.2.4-1
- resolves: #1541621 - Update to 0.2.4
- Add -doc subpackage

See Also

Package Description
python36-netaddr-0.7.18-3.el7.noarch.rpm A pure Python network address representation and manipulation library
python36-netcdf4-1.2.7-4.el7.x86_64.rpm Python/numpy interface to netCDF
python36-netifaces-0.10.9-1.el7.x86_64.rpm Python 36 library to retrieve information about network interfaces
python36-nitrate-1.5-4.el7.noarch.rpm Python API for the Nitrate test case management system
python36-nordugrid-arc-5.4.4-2.el7.x86_64.rpm ARC Python 3 wrapper
python36-nordugrid-arc6-6.4.1-1.el7.x86_64.rpm ARC Python 3 wrapper
python36-nose-1.3.7-4.el7.noarch.rpm Discovery-based unittest extension for Python 3.6
python36-nose2-0.6.5-6.el7.noarch.rpm Next generation of nicer testing for Python
python36-notify2-0.3.1-3.el7.noarch.rpm Python interface to DBus notifications
python36-ns1-python-0.12.0-1.el7.noarch.rpm Python SDK for the NS1 DNS platform
python36-numexpr-2.7.0-1.el7.x86_64.rpm Fast numerical array expression evaluator for Python and NumPy
python36-numpy-1.12.1-3.el7.x86_64.rpm A fast multidimensional array facility for Python 3.6
python36-numpy-f2py-1.12.1-3.el7.x86_64.rpm f2py for numpy
python36-olefile-0.46-2.el7.noarch.rpm Python package to parse, read and write Microsoft OLE2 files
python36-oletools-0.54.2-2.el7.noarch.rpm Tools to analyze Microsoft OLE2 files
Advertisement
Advertisement