kyotocabinet-devel-1.2.77-1.el7.x86_64.rpm


Advertisement

Description

kyotocabinet-devel - Development files for Kyoto Cabinet

Property Value
Distribution CentOS 7
Repository EPEL x86_64
Package filename kyotocabinet-devel-1.2.77-1.el7.x86_64.rpm
Package name kyotocabinet-devel
Package version 1.2.77
Package release 1.el7
Package architecture x86_64
Package type rpm
Homepage https://fallabs.com/kyotocabinet/
License GPLv3
Maintainer -
Download size 114.36 KB
Installed size 984.78 KB
The kyotocabinet-devel package contains libraries and header files for
developing applications that use Kyoto Cabinet.

Alternatives

Package Version Architecture Repository
kyotocabinet-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
kyotocabinet-libs(x86-64) = 1.2.77-1.el7
libkyotocabinet.so.16()(64bit) -
pkgconfig -

Provides

Name Value
kyotocabinet-devel = 1.2.77-1.el7
kyotocabinet-devel(x86-64) = 1.2.77-1.el7
pkgconfig(kyotocabinet) = 1.2.77

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package kyotocabinet-devel-1.2.77-1.el7.x86_64.rpm
Source Package kyotocabinet-1.2.77-1.el7.src.rpm

Install Howto

  1. Download latest epel-release rpm from
    http://download-ib01.fedoraproject.org/pub/epel/7/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install kyotocabinet-devel rpm package:
    # yum install kyotocabinet-devel

Files

Path
/usr/include/kccachedb.h
/usr/include/kccommon.h
/usr/include/kccompare.h
/usr/include/kccompress.h
/usr/include/kcdb.h
/usr/include/kcdbext.h
/usr/include/kcdirdb.h
/usr/include/kcfile.h
/usr/include/kchashdb.h
/usr/include/kclangc.h
/usr/include/kcmap.h
/usr/include/kcplantdb.h
/usr/include/kcpolydb.h
/usr/include/kcprotodb.h
/usr/include/kcregex.h
/usr/include/kcstashdb.h
/usr/include/kctextdb.h
/usr/include/kcthread.h
/usr/include/kcutil.h
/usr/lib64/libkyotocabinet.so
/usr/lib64/pkgconfig/kyotocabinet.pc

Changelog

2019-03-25 - Robert Scheck <robert@fedoraproject.org> 1.2.77
- Update to 1.2.77
2019-03-01 - Peng Wu <pwu@redhat.com> - 1.2.76-21
- Switch back to use -O2 for s390x
2019-02-27 - Parag Nemade <pnemade AT redhat DOT com> - 1.2.76-20
- Fix s390x compilation issue by changing -O2 to -O1 (rh#1675243)
2019-02-01 - Fedora Release Engineering <releng@fedoraproject.org> - 1.2.76-19
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
2018-07-13 - Fedora Release Engineering <releng@fedoraproject.org> - 1.2.76-18
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
2018-03-07 - Adam Williamson <awilliam@redhat.com> - 1.2.76-17
- Rebuild to fix GCC 8 mis-compilation
See https://da.gd/YJVwk ("GCC 8 ABI change on x86_64")
2018-02-07 - Fedora Release Engineering <releng@fedoraproject.org> - 1.2.76-16
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
2017-08-03 - Fedora Release Engineering <releng@fedoraproject.org> - 1.2.76-15
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
2017-07-26 - Fedora Release Engineering <releng@fedoraproject.org> - 1.2.76-14
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-02-12 - Robert Scheck <robert@fedoraproject.org> 1.2.76-13
- Replace patch from openSUSE by the Debian one to not only build
kyotocabinet with GCC >= 6 but also with GCC >= 7 (#1307706 #c15)

See Also

Package Description
kyotocabinet-libs-1.2.77-1.el7.x86_64.rpm Libraries for applications using Kyoto Cabinet
ladspa-swh-plugins-0.4.15-20.el7.x86_64.rpm A set of audio plugins for LADSPA
lame-3.100-1.el7.x86_64.rpm Free MP3 audio compressor
lame-devel-3.100-1.el7.x86_64.rpm Development files for lame
lame-libs-3.100-1.el7.x86_64.rpm LAME MP3 encoding library
lame-mp3x-3.100-1.el7.x86_64.rpm MP3 frame analyzer
lammps-20190605-4.el7.x86_64.rpm Molecular Dynamics Simulator
lammps-data-20190605-4.el7.noarch.rpm Data files for LAMMPS
lammps-devel-20190605-4.el7.x86_64.rpm Development libraries for LAMMPS
lammps-headers-20190605-4.el7.x86_64.rpm Development headers for LAMMPS
lammps-mpich-20190605-4.el7.x86_64.rpm LAMMPS MPICH binaries and libraries
lammps-mpich-devel-20190605-4.el7.x86_64.rpm Development libraries for MPICH LAMMPS
lammps-openmpi-20190605-4.el7.x86_64.rpm LAMMPS Open MPI binaries and libraries
lammps-openmpi-devel-20190605-4.el7.x86_64.rpm Development libraries for Open MPI LAMMPS
lash-0.5.4-26.el7.x86_64.rpm LASH Audio Session Handler
Advertisement
Advertisement