volume_key-libs-0.3.9-8.el7.i686.rpm


Advertisement

Description

volume_key-libs - A library for manipulating storage encryption keys and passphrases

Property Value
Distribution CentOS 7
Repository CentOS x86_64
Package name volume_key-libs
Package version 0.3.9
Package release 8.el7
Package architecture i686
Package type rpm
Installed size 685.13 KB
Download size 139.19 KB
Official Mirror mirror.centos.org
This package provides libvolume_key, a library for manipulating storage volume
encryption keys and storing them separately from volumes.
The main goal of the software is to allow restoring access to an encrypted
hard drive if the primary user forgets the passphrase.  The encryption key
back up can also be useful for extracting data after a hardware or software
failure that corrupts the header of the encrypted volume, or to access the
company data after an employee leaves abruptly.

Alternatives

Package Version Architecture Repository
volume_key-libs-0.3.9-8.el7.x86_64.rpm 0.3.9 x86_64 CentOS
volume_key-libs - - -

Requires

Name Value
/sbin/ldconfig -
/usr/bin/gpg -
libblkid.so.1 -
libblkid.so.1(BLKID_1.0) -
libc.so.6(GLIBC_2.4) -
libcryptsetup.so.4 -
libcryptsetup.so.4(CRYPTSETUP_1.0) -
libdl.so.2 -
libglib-2.0.so.0 -
libgpgme.so.11 -
libgpgme.so.11(GPGME_1.0) -
libgpgme.so.11(GPGME_1.1) -
libnspr4.so -
libnss3.so -
libnss3.so(NSS_3.2) -
libnss3.so(NSS_3.3) -
libnssutil3.so -
libplc4.so -
libplds4.so -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libsmime3.so -
libsmime3.so(NSS_3.2) -
libssl3.so -
rtld(GNU_HASH) -

Provides

Name Value
libvolume_key.so.1 -
volume_key-libs = 0.3.9-8.el7
volume_key-libs(x86-32) = 0.3.9-8.el7

Download

Type URL
Binary Package volume_key-libs-0.3.9-8.el7.i686.rpm
Source Package volume_key-0.3.9-8.el7.src.rpm

Install Howto

Install volume_key-libs rpm package:

# yum install volume_key-libs

Files

Path
/usr/lib/libvolume_key.so.1
/usr/lib/libvolume_key.so.1.2.2
/usr/share/doc/volume_key-libs-0.3.9/AUTHORS
/usr/share/doc/volume_key-libs-0.3.9/COPYING
/usr/share/doc/volume_key-libs-0.3.9/ChangeLog
/usr/share/doc/volume_key-libs-0.3.9/NEWS
/usr/share/locale/as/LC_MESSAGES/volume_key.mo
/usr/share/locale/bg/LC_MESSAGES/volume_key.mo
/usr/share/locale/bn/LC_MESSAGES/volume_key.mo
/usr/share/locale/bn_IN/LC_MESSAGES/volume_key.mo
/usr/share/locale/ca/LC_MESSAGES/volume_key.mo
/usr/share/locale/cs/LC_MESSAGES/volume_key.mo
/usr/share/locale/de/LC_MESSAGES/volume_key.mo
/usr/share/locale/de_CH/LC_MESSAGES/volume_key.mo
/usr/share/locale/en_GB/LC_MESSAGES/volume_key.mo
/usr/share/locale/es/LC_MESSAGES/volume_key.mo
/usr/share/locale/eu/LC_MESSAGES/volume_key.mo
/usr/share/locale/fr/LC_MESSAGES/volume_key.mo
/usr/share/locale/gu/LC_MESSAGES/volume_key.mo
/usr/share/locale/hi/LC_MESSAGES/volume_key.mo
/usr/share/locale/hu/LC_MESSAGES/volume_key.mo
/usr/share/locale/id/LC_MESSAGES/volume_key.mo
/usr/share/locale/it/LC_MESSAGES/volume_key.mo
/usr/share/locale/ja/LC_MESSAGES/volume_key.mo
/usr/share/locale/kn/LC_MESSAGES/volume_key.mo
/usr/share/locale/ko/LC_MESSAGES/volume_key.mo
/usr/share/locale/ml/LC_MESSAGES/volume_key.mo
/usr/share/locale/mr/LC_MESSAGES/volume_key.mo
/usr/share/locale/nl/LC_MESSAGES/volume_key.mo
/usr/share/locale/or/LC_MESSAGES/volume_key.mo
/usr/share/locale/pa/LC_MESSAGES/volume_key.mo
/usr/share/locale/pl/LC_MESSAGES/volume_key.mo
/usr/share/locale/pt/LC_MESSAGES/volume_key.mo
/usr/share/locale/pt_BR/LC_MESSAGES/volume_key.mo
/usr/share/locale/ru/LC_MESSAGES/volume_key.mo
/usr/share/locale/sk/LC_MESSAGES/volume_key.mo
/usr/share/locale/sv/LC_MESSAGES/volume_key.mo
/usr/share/locale/ta/LC_MESSAGES/volume_key.mo
/usr/share/locale/te/LC_MESSAGES/volume_key.mo
/usr/share/locale/tr/LC_MESSAGES/volume_key.mo
/usr/share/locale/uk/LC_MESSAGES/volume_key.mo
/usr/share/locale/zh_CN/LC_MESSAGES/volume_key.mo
/usr/share/locale/zh_TW/LC_MESSAGES/volume_key.mo

Changelog

2017-10-09 - skisela@redhat.com - 0.3.9-8
- Don't #include <config.h> in libvolume_key.h
Resolves: #1498783
2014-01-24 - Daniel Mach <dmach@redhat.com> - 0.3.9-7
- Mass rebuild 2014-01-24
2013-12-27 - Daniel Mach <dmach@redhat.com> - 0.3.9-6
- Mass rebuild 2013-12-27
2013-12-02 - Miloslav Trmač <mitr@redhat.com> - 0.3.9-5
- Avoid multilib confilicts introduced by applying the previous patch
Related: #1030387
2013-11-29 - Miloslav Trmač <mitr@redhat.com> - 0.3.9-4
- Include updated translations
Resolves: #1030387
2013-02-15 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.9-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
2012-11-22 - Miloslav Trmač <mitr@redhat.com> - 0.3.9-2
- Fix a crash when trying to use passphrase encryption in FIPS mode
2012-09-22 - Miloslav Trmač <mitr@redhat.com> - 0.3.9-1
- Update to volume_key-0.3.9
2012-08-06 - Miloslav Trmač <mitr@redhat.com> - 0.3.8-4
- Use BuildRequires: /usr/bin/gpg instead of gnupg, for compatibility with RHEL
2012-07-23 - Miloslav Trmač <mitr@redhat.com> - 0.3.8-3
- Add Requires: /usr/bin/gpg
Resolves: #842074

See Also

Package Description
vorbis-tools-1.4.0-13.el7.x86_64.rpm The Vorbis General Audio Compression Codec tools
vsftpd-3.0.2-25.el7.x86_64.rpm Very Secure Ftp Daemon
vsftpd-sysvinit-3.0.2-25.el7.x86_64.rpm SysV initscript for vsftpd daemon
vte-profile-0.52.2-2.el7.x86_64.rpm Profile script for VTE terminal emulator library
vte291-0.52.2-2.el7.i686.rpm Terminal emulator library
vte291-0.52.2-2.el7.x86_64.rpm Terminal emulator library
vte291-devel-0.52.2-2.el7.i686.rpm Development files for vte291
vte291-devel-0.52.2-2.el7.x86_64.rpm Development files for vte291
vte3-0.36.5-1.el7.i686.rpm Terminal emulator library
vte3-0.36.5-1.el7.x86_64.rpm Terminal emulator library
vte3-devel-0.36.5-1.el7.i686.rpm Development files for vte3
vte3-devel-0.36.5-1.el7.x86_64.rpm Development files for vte3
vulkan-1.1.73.0-1.el7.i686.rpm Vulkan loader and validation layers
vulkan-1.1.73.0-1.el7.x86_64.rpm Vulkan loader and validation layers
vulkan-devel-1.1.73.0-1.el7.i686.rpm Vulkan development package
Advertisement
Advertisement