subscription-manager-rhsm-1.21.10-2.el7.centos.x86_64.rpm


Advertisement

Description

subscription-manager-rhsm - A Python library to communicate with a Red Hat Unified Entitlement Platform

Property Value
Distribution CentOS 7
Repository CentOS x86_64
Package filename subscription-manager-rhsm-1.21.10-2.el7.centos.x86_64.rpm
Package name subscription-manager-rhsm
Package version 1.21.10
Package release 2.el7.centos
Package architecture x86_64
Package type rpm
Category Development/Libraries
Homepage http://www.candlepinproject.org/
License GPLv2
Maintainer -
Download size 296.79 KB
Installed size 380.46 KB
A small library for communicating with the REST interface of a Red Hat Unified
Entitlement Platform. This interface is used for the management of system
entitlements, certificates, and access to content.

Alternatives

Package Version Architecture Repository
subscription-manager-rhsm-1.21.10-3.el7.centos.x86_64.rpm 1.21.10 x86_64 CentOS Updates
subscription-manager-rhsm - - -

Requires

Name Value
libc.so.6(GLIBC_2.14)(64bit) -
libcrypto.so.10()(64bit) -
libcrypto.so.10(libcrypto.so.10)(64bit) -
libpthread.so.0()(64bit) -
libpython2.7.so.1.0()(64bit) -
libssl.so.10()(64bit) -
python(abi) = 2.7
python-dateutil -
python-iniparse -
python-six -
rpm-python -
rtld(GNU_HASH) -
subscription-manager-rhsm-certificates = 1.21.10-2.el7.centos

Provides

Name Value
python-rhsm = 1.21.10-2.el7.centos
python2-rhsm = 1.21.10-2.el7.centos
subscription-manager-rhsm = 1.21.10-2.el7.centos
subscription-manager-rhsm(x86-64) = 1.21.10-2.el7.centos

Obsoletes

Name Value
python-rhsm <= 1.20.3-1

Download

Type URL
Mirror mirror.centos.org
Binary Package subscription-manager-rhsm-1.21.10-2.el7.centos.x86_64.rpm
Source Package subscription-manager-1.21.10-2.el7.centos.src.rpm

Install Howto

Install subscription-manager-rhsm rpm package:

# yum install subscription-manager-rhsm

Files

Path
/usr/lib64/python2.7/site-packages/rhsm/__init__.py
/usr/lib64/python2.7/site-packages/rhsm/__init__.pyc
/usr/lib64/python2.7/site-packages/rhsm/__init__.pyo
/usr/lib64/python2.7/site-packages/rhsm/_certificate.so
/usr/lib64/python2.7/site-packages/rhsm/bitstream.py
/usr/lib64/python2.7/site-packages/rhsm/bitstream.pyc
/usr/lib64/python2.7/site-packages/rhsm/bitstream.pyo
/usr/lib64/python2.7/site-packages/rhsm/certificate.py
/usr/lib64/python2.7/site-packages/rhsm/certificate.pyc
/usr/lib64/python2.7/site-packages/rhsm/certificate.pyo
/usr/lib64/python2.7/site-packages/rhsm/certificate2.py
/usr/lib64/python2.7/site-packages/rhsm/certificate2.pyc
/usr/lib64/python2.7/site-packages/rhsm/certificate2.pyo
/usr/lib64/python2.7/site-packages/rhsm/config.py
/usr/lib64/python2.7/site-packages/rhsm/config.pyc
/usr/lib64/python2.7/site-packages/rhsm/config.pyo
/usr/lib64/python2.7/site-packages/rhsm/connection.py
/usr/lib64/python2.7/site-packages/rhsm/connection.pyc
/usr/lib64/python2.7/site-packages/rhsm/connection.pyo
/usr/lib64/python2.7/site-packages/rhsm/https.py
/usr/lib64/python2.7/site-packages/rhsm/https.pyc
/usr/lib64/python2.7/site-packages/rhsm/https.pyo
/usr/lib64/python2.7/site-packages/rhsm/huffman.py
/usr/lib64/python2.7/site-packages/rhsm/huffman.pyc
/usr/lib64/python2.7/site-packages/rhsm/huffman.pyo
/usr/lib64/python2.7/site-packages/rhsm/m2cryptohttp.py
/usr/lib64/python2.7/site-packages/rhsm/m2cryptohttp.pyc
/usr/lib64/python2.7/site-packages/rhsm/m2cryptohttp.pyo
/usr/lib64/python2.7/site-packages/rhsm/m2cryptossl.py
/usr/lib64/python2.7/site-packages/rhsm/m2cryptossl.pyc
/usr/lib64/python2.7/site-packages/rhsm/m2cryptossl.pyo
/usr/lib64/python2.7/site-packages/rhsm/ourjson.py
/usr/lib64/python2.7/site-packages/rhsm/ourjson.pyc
/usr/lib64/python2.7/site-packages/rhsm/ourjson.pyo
/usr/lib64/python2.7/site-packages/rhsm/pathtree.py
/usr/lib64/python2.7/site-packages/rhsm/pathtree.pyc
/usr/lib64/python2.7/site-packages/rhsm/pathtree.pyo
/usr/lib64/python2.7/site-packages/rhsm/profile.py
/usr/lib64/python2.7/site-packages/rhsm/profile.pyc
/usr/lib64/python2.7/site-packages/rhsm/profile.pyo
/usr/lib64/python2.7/site-packages/rhsm/utils.py
/usr/lib64/python2.7/site-packages/rhsm/utils.pyc
/usr/lib64/python2.7/site-packages/rhsm/utils.pyo

Changelog

2018-11-04 - Johnny Hughes <johnny@centos.org> 1.21.10-2
- Manual CentOS Debrnading
2018-09-05 - Christopher Snyder <csnyder@redhat.com> 1.21.10-2
- Fix up Makefile (csnyder@redhat.com)
2018-09-05 - Christopher Snyder <csnyder@redhat.com> 1.21.10-1
- Updated translations (csnyder@redhat.com)
- 1623262: Make automatic enablement of yum plugins working again; ENT-820
(jhnidek@redhat.com)
2018-08-13 - Christopher Snyder <csnyder@redhat.com> 1.23.3-1
- 1606435: Rename the async module for compatibility with python 3.7; ENT-737
(csnyder@redhat.com)
- Cockpit/Syspurpose service integration fix (aparadka@redhat.com)
- Display both new and old value in syspurpose diff message
(csnyder@redhat.com)
- Fix sending single value of addons. (jhnidek@redhat.com)
- Fix synchronization of usage with candlepin (jhnidek@redhat.com)
- 1596294: Fix displayin RHSM Spoke in Initial Setup (jhnidek@redhat.com)
- Syspurpose field value lists [ENT-766] (wpoteat@redhat.com)
- ENT-717: Syncing of syspurpose store with candlepin (jhnidek@redhat.com)
- 1609048: Replacement of imp module with importlib; ENT-758
(jhnidek@redhat.com)
2018-08-03 - Christopher Snyder <csnyder@redhat.com> 1.23.2-1
- Move "nose" to test requirements for syspurpose (csnyder@redhat.com)

See Also

Package Description
subscription-manager-rhsm-certificates-1.21.10-2.el7.centos.x86_64.rpm Certificates required to communicate with a Red Hat Unified Entitlement Platform
subversion-1.7.14-14.el7.i686.rpm A Modern Concurrent Version Control System
subversion-1.7.14-14.el7.x86_64.rpm A Modern Concurrent Version Control System
subversion-devel-1.7.14-14.el7.i686.rpm Development package for the Subversion libraries
subversion-devel-1.7.14-14.el7.x86_64.rpm Development package for the Subversion libraries
subversion-gnome-1.7.14-14.el7.i686.rpm GNOME Keyring support for Subversion
subversion-gnome-1.7.14-14.el7.x86_64.rpm GNOME Keyring support for Subversion
subversion-javahl-1.7.14-14.el7.i686.rpm JNI bindings to the Subversion libraries
subversion-javahl-1.7.14-14.el7.x86_64.rpm JNI bindings to the Subversion libraries
subversion-kde-1.7.14-14.el7.i686.rpm KDE Wallet support for Subversion
subversion-kde-1.7.14-14.el7.x86_64.rpm KDE Wallet support for Subversion
subversion-libs-1.7.14-14.el7.i686.rpm Libraries for Subversion Version Control system
subversion-libs-1.7.14-14.el7.x86_64.rpm Libraries for Subversion Version Control system
subversion-perl-1.7.14-14.el7.i686.rpm Perl bindings to the Subversion libraries
subversion-perl-1.7.14-14.el7.x86_64.rpm Perl bindings to the Subversion libraries
Advertisement
Advertisement