perl-Params-Validate-1.08-4.el7.x86_64.rpm


Advertisement

Description

perl-Params-Validate - Params-Validate Perl module

Property Value
Distribution CentOS 7
Repository CentOS x86_64
Package name perl-Params-Validate
Package version 1.08
Package release 4.el7
Package architecture x86_64
Package type rpm
Installed size 139.83 KB
Download size 68.96 KB
Official Mirror mirror.centos.org
The Params::Validate module allows you to validate method or function
call parameters to an arbitrary level of specificity. At the simplest
level, it is capable of validating the required parameters were given
and that no unspecified additional parameters were passed in. It is
also capable of determining that a parameter is of a specific type,
that it is an object of a certain class hierarchy, that it possesses
certain methods, or applying validation callbacks to arguments.

Alternatives

Package Version Architecture Repository
perl-Params-Validate - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
perl >= 5.008001
perl(:MODULE_COMPAT_5.16.3) -
perl(Attribute::Handlers) >= 0.79
perl(Exporter) -
perl(Module::Implementation) -
perl(Scalar::Util) >= 1.10
perl(XSLoader) -
perl(attributes) -
perl(strict) -
perl(vars) -
perl(warnings) -
rtld(GNU_HASH) -

Provides

Name Value
perl(Attribute::Params::Validate) = 1.08
perl(Params::Validate) = 1.08
perl(Params::Validate::Constants) = 1.08
perl(Params::Validate::PP) = 1.08
perl(Params::Validate::XS) = 1.08
perl-Params-Validate = 1.08-4.el7
perl-Params-Validate(x86-64) = 1.08-4.el7

Download

Type URL
Binary Package perl-Params-Validate-1.08-4.el7.x86_64.rpm
Source Package perl-Params-Validate-1.08-4.el7.src.rpm

Install Howto

Install perl-Params-Validate rpm package:

# yum install perl-Params-Validate

Files

Path
/usr/lib64/perl5/vendor_perl/Attribute/
/usr/lib64/perl5/vendor_perl/Attribute/Params/Validate.pm
/usr/lib64/perl5/vendor_perl/Params/Validate.pm
/usr/lib64/perl5/vendor_perl/Params/ValidatePP.pm
/usr/lib64/perl5/vendor_perl/Params/ValidateXS.pm
/usr/lib64/perl5/vendor_perl/Params/Validate/Constants.pm
/usr/lib64/perl5/vendor_perl/Params/Validate/PP.pm
/usr/lib64/perl5/vendor_perl/Params/Validate/XS.pm
/usr/lib64/perl5/vendor_perl/auto/Params/
/usr/lib64/perl5/vendor_perl/auto/Params/Validate/
/usr/lib64/perl5/vendor_perl/auto/Params/Validate/XS/XS.bs
/usr/lib64/perl5/vendor_perl/auto/Params/Validate/XS/XS.so
/usr/share/doc/perl-Params-Validate-1.08/Changes
/usr/share/doc/perl-Params-Validate-1.08/LICENSE
/usr/share/doc/perl-Params-Validate-1.08/README
/usr/share/doc/perl-Params-Validate-1.08/TODO
/usr/share/man/man3/Attribute::Params::Validate.3pm.gz
/usr/share/man/man3/Params::Validate.3pm.gz

Changelog

2014-01-24 - Daniel Mach <dmach@redhat.com> - 1.08-4
- Mass rebuild 2014-01-24
2013-12-27 - Daniel Mach <dmach@redhat.com> - 1.08-3
- Mass rebuild 2013-12-27
2013-07-31 - Petr Pisar <ppisar@redhat.com> - 1.08-2.1
- Modernize spec file
2013-07-18 - Ralf Corsépius <corsepiu@fedoraproject.org> - 1.08-2
- Adjust license tag (RHBZ #977787).
2013-06-11 - Ralf Corsépius <corsepiu@fedoraproject.org> - 1.08-1
- Upstream update.
- Update patch.
- Update BRs.
- Add %bcond --with network.
- Fix up %changelog dates.
2013-02-14 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.07-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
2012-10-30 - Ralf Corsépius <corsepiu@fedoraproject.org> - 1.07-1
- Upstream update.
2012-08-14 - Petr Pisar <ppisar@redhat.com> - 1.06-5
- Specify all dependencies
2012-07-20 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.06-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
2012-06-13 - Petr Pisar <ppisar@redhat.com> - 1.06-3
- Perl 5.16 rebuild

See Also

Package Description
perl-Parse-CPAN-Meta-1.4404-5.el7.noarch.rpm Parse META.yml and META.json CPAN meta-data files
perl-Parse-RecDescent-1.967009-5.el7.noarch.rpm Generate Recursive-Descent Parsers
perl-Parse-Yapp-1.05-50.el7.noarch.rpm Perl extension for generating and using LALR parsers
perl-PathTools-3.40-5.el7.x86_64.rpm PathTools Perl module (Cwd, File::Spec)
perl-Perl-Critic-1.118-5.el7.noarch.rpm Critique Perl source code for best-practices
perl-Perl-Critic-More-1.000-9.el7.noarch.rpm Supplemental policies for Perl::Critic
perl-Perl-MinimumVersion-1.32-2.el7.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perl-OSType-1.003-3.el7.noarch.rpm Map Perl operating system names to generic types
perl-Perl4-CoreLibs-0.003-7.el7.noarch.rpm Libraries historically supplied with Perl 4
perl-PlRPC-0.2020-14.el7.noarch.rpm Interface for writing PlRPC clients and servers
perl-Pod-Checker-1.60-2.el7.noarch.rpm Check POD documents for syntax errors
perl-Pod-Coverage-0.23-3.el7.noarch.rpm Checks if the documentation of a module is comprehensive
perl-Pod-Coverage-TrustPod-0.100002-5.el7.noarch.rpm Allow a module's pod to contain Pod::Coverage hints
perl-Pod-Escapes-1.04-292.el7.noarch.rpm Perl module for resolving POD escape sequences
perl-Pod-Eventual-0.093330-12.el7.noarch.rpm Read a POD document as a series of trivial events
Advertisement
Advertisement