perl-Package-Stash-XS-0.26-3.el7.x86_64.rpm


Advertisement

Description

perl-Package-Stash-XS - Faster and more correct implementation of the Package::Stash API

Property Value
Distribution CentOS 7
Repository CentOS x86_64
Package name perl-Package-Stash-XS
Package version 0.26
Package release 3.el7
Package architecture x86_64
Package type rpm
Installed size 57.91 KB
Download size 31.28 KB
Official Mirror mirror.centos.org
This is a back-end for Package::Stash, which provides the functionality in a
way that's less buggy and much faster. It will be used by default if it's
installed, and should be preferred in all environments with a compiler.

Alternatives

Package Version Architecture Repository
perl-Package-Stash-XS - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
perl >= 5.008001
perl(:MODULE_COMPAT_5.16.3) -
perl(XSLoader) -
perl(strict) -
perl(warnings) -
rtld(GNU_HASH) -

Provides

Name Value
perl(Package::Stash::XS) = 0.26
perl-Package-Stash-XS = 0.26-3.el7
perl-Package-Stash-XS(x86-64) = 0.26-3.el7

Download

Type URL
Binary Package perl-Package-Stash-XS-0.26-3.el7.x86_64.rpm
Source Package perl-Package-Stash-XS-0.26-3.el7.src.rpm

Install Howto

Install the perl-Package-Stash-XS rpm package:

# yum install perl-Package-Stash-XS

Files

Path
/usr/lib64/perl5/vendor_perl/Package/
/usr/lib64/perl5/vendor_perl/Package/Stash/XS.pm
/usr/lib64/perl5/vendor_perl/auto/Package/
/usr/lib64/perl5/vendor_perl/auto/Package/Stash/
/usr/lib64/perl5/vendor_perl/auto/Package/Stash/XS/XS.so
/usr/share/doc/perl-Package-Stash-XS-0.26/Changes
/usr/share/doc/perl-Package-Stash-XS-0.26/LICENSE
/usr/share/doc/perl-Package-Stash-XS-0.26/README
/usr/share/man/man3/Package::Stash::XS.3pm.gz

Changelog

2014-01-24 - Daniel Mach <dmach@redhat.com> - 0.26-3
- Mass rebuild 2014-01-24
2013-12-27 - Daniel Mach <dmach@redhat.com> - 0.26-2
- Mass rebuild 2013-12-27
2013-01-04 - Paul Howarth <paul@city-fan.org> - 0.26-1
- Update to 0.26
- Internal refactorings to support Package::Anon stashes
- BR: perl(base) and perl(Test::Requires) for test suite
- Update patch for old distro compatibility
- Explicitly run the release/author tests
2012-08-27 - Petr Pisar <ppisar@redhat.com> - 0.25-7
- Disable author tests on RHEL >= 7
2012-08-25 - Paul Howarth <paul@city-fan.org> - 0.25-6
- Drop EPEL-4 support
- Test::LeakTrace now universally available
- Suitably recent version of ExtUtils::MakeMaker now universally available
- Drop %defattr, redundant since rpm 4.4
- BR: perl(File::Temp)
- Don't need to remove empty directories from the buildroot
2012-08-14 - Petr Pisar <ppisar@redhat.com> - 0.25-5
- Specify all dependencies
2012-07-20 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
2012-06-19 - Petr Pisar <ppisar@redhat.com> - 0.25-3
- Perl 5.16 rebuild
2012-01-12 - Paul Howarth <paul@city-fan.org> - 0.25-2
- Use %{_fixperms} macro instead of our own chmod incantation
2011-09-06 - Paul Howarth <paul@city-fan.org> - 0.25-1
- Update to 0.25
- Invalid package names (for instance, Foo:Bar) are not allowed
- Invalid stash entry names (anything containing ::) are not allowed
- Update patches to apply cleanly

See Also

Package Description
perl-PadWalker-1.96-3.el7.x86_64.rpm Play with other peoples' lexical variables
perl-Parallel-Iterator-1.00-8.el7.noarch.rpm Simple parallel execution
perl-Params-Check-0.38-2.el7.noarch.rpm Generic input parsing/checking mechanism
perl-Params-Util-1.07-6.el7.x86_64.rpm Simple standalone parameter-checking functions
perl-Params-Validate-1.08-4.el7.x86_64.rpm Params-Validate Perl module
perl-Parse-CPAN-Meta-1.4404-5.el7.noarch.rpm Parse META.yml and META.json CPAN meta-data files
perl-Parse-RecDescent-1.967009-5.el7.noarch.rpm Generate Recursive-Descent Parsers
perl-Parse-Yapp-1.05-50.el7.noarch.rpm Perl extension for generating and using LALR parsers
perl-PathTools-3.40-5.el7.x86_64.rpm PathTools Perl module (Cwd, File::Spec)
perl-Perl-Critic-1.118-5.el7.noarch.rpm Critique Perl source code for best-practices
perl-Perl-Critic-More-1.000-9.el7.noarch.rpm Supplemental policies for Perl::Critic
perl-Perl-MinimumVersion-1.32-2.el7.noarch.rpm Find a minimum required version of perl for Perl code
perl-Perl-OSType-1.003-3.el7.noarch.rpm Map Perl operating system names to generic types
perl-Perl4-CoreLibs-0.003-7.el7.noarch.rpm Libraries historically supplied with Perl 4
perl-PlRPC-0.2020-14.el7.noarch.rpm Interface for writing PlRPC clients and servers
Advertisement
Advertisement