libldb-1.2.2-1.el7.i686.rpm


Advertisement

Description

libldb - A schema-less, ldap like, API and database

Property Value
Distribution CentOS 7
Repository CentOS x86_64
Package name libldb
Package version 1.2.2
Package release 1.el7
Package architecture i686
Package type rpm
Installed size 329.94 KB
Download size 131.55 KB
Official Mirror mirror.centos.org
An extensible library that implements an LDAP like API to access remote LDAP
servers, or use local tdb databases.

Alternatives

Package Version Architecture Repository
libldb-1.2.2-1.el7.x86_64.rpm 1.2.2 x86_64 CentOS
libldb-1.1.20-1.gf.el7.x86_64.rpm 1.1.20 x86_64 Ghettoforge Plus
libldb - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4) -
libcrypt.so.1 -
libdl.so.2 -
libdl.so.2(GLIBC_2.0) -
libdl.so.2(GLIBC_2.1) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.2) -
libtalloc(x86-32) >= 2.1.2
libtalloc.so.2 -
libtalloc.so.2(TALLOC_2.0.2) -
libtdb(x86-32) >= 1.3.5
libtdb.so.1 -
libtdb.so.1(TDB_1.2.1) -
libtevent(x86-32) >= 0.9.24
libtevent.so.0 -
libtevent.so.0(TEVENT_0.9.9) -
rtld(GNU_HASH) -

Provides

Name Value
bundled(libreplace) -
bundled(libtdb_compat) -
libldb = 1.2.2-1.el7
libldb(x86-32) = 1.2.2-1.el7
libldb.so.1 -
libldb.so.1(LDB_0.9.10) -
libldb.so.1(LDB_0.9.12) -
libldb.so.1(LDB_0.9.15) -
libldb.so.1(LDB_0.9.16) -
libldb.so.1(LDB_0.9.17) -
libldb.so.1(LDB_0.9.18) -
libldb.so.1(LDB_0.9.19) -
libldb.so.1(LDB_0.9.20) -
libldb.so.1(LDB_0.9.22) -
libldb.so.1(LDB_0.9.23) -
libldb.so.1(LDB_0.9.24) -
libldb.so.1(LDB_1.0.0) -
libldb.so.1(LDB_1.0.1) -
libldb.so.1(LDB_1.0.2) -
libldb.so.1(LDB_1.1.0) -
libldb.so.1(LDB_1.1.1) -
libldb.so.1(LDB_1.1.10) -
libldb.so.1(LDB_1.1.11) -
libldb.so.1(LDB_1.1.12) -
libldb.so.1(LDB_1.1.13) -
libldb.so.1(LDB_1.1.14) -
libldb.so.1(LDB_1.1.15) -
libldb.so.1(LDB_1.1.16) -
libldb.so.1(LDB_1.1.17) -
libldb.so.1(LDB_1.1.18) -
libldb.so.1(LDB_1.1.19) -
libldb.so.1(LDB_1.1.2) -
libldb.so.1(LDB_1.1.20) -
libldb.so.1(LDB_1.1.21) -
libldb.so.1(LDB_1.1.22) -
libldb.so.1(LDB_1.1.23) -
libldb.so.1(LDB_1.1.24) -
libldb.so.1(LDB_1.1.25) -
libldb.so.1(LDB_1.1.26) -
libldb.so.1(LDB_1.1.27) -
libldb.so.1(LDB_1.1.28) -
libldb.so.1(LDB_1.1.29) -
libldb.so.1(LDB_1.1.3) -
libldb.so.1(LDB_1.1.30) -
libldb.so.1(LDB_1.1.31) -
libldb.so.1(LDB_1.1.4) -
libldb.so.1(LDB_1.1.5) -
libldb.so.1(LDB_1.1.6) -
libldb.so.1(LDB_1.1.7) -
libldb.so.1(LDB_1.1.8) -
libldb.so.1(LDB_1.1.9) -
libldb.so.1(LDB_1.2.0) -
libldb.so.1(LDB_1.2.1) -
libldb.so.1(LDB_1.2.2) -

Download

Type URL
Binary Package libldb-1.2.2-1.el7.i686.rpm
Source Package libldb-1.2.2-1.el7.src.rpm

Install Howto

Install the libldb rpm package:

# yum install libldb

Files

Path
/usr/lib/libldb.so.1
/usr/lib/libldb.so.1.2.2
/usr/lib/ldb/
/usr/lib/ldb/modules/
/usr/lib/ldb/modules/ldb/asq.so
/usr/lib/ldb/modules/ldb/paged_results.so
/usr/lib/ldb/modules/ldb/paged_searches.so
/usr/lib/ldb/modules/ldb/rdn_name.so
/usr/lib/ldb/modules/ldb/sample.so
/usr/lib/ldb/modules/ldb/server_sort.so
/usr/lib/ldb/modules/ldb/skel.so
/usr/lib/ldb/modules/ldb/tdb.so

Changelog

2017-10-15 - Jakub Hrozek <jhrozek@redhat.com> - 1.2.2-1
- Resolves: rhbz#1470056 - Rebase libldb to enable samba rebase to
version 4.7.x
2017-02-14 - Jakub Hrozek <jhrozek@redhat.com> - 1.1.29-1
- Resolves: rhbz#1393810 - Rebase libldb to enable samba rebase to
version 4.6.x
2016-06-09 - Jakub Hrozek <jhrozek@redhat.com> - 1.1.26-1
- Resolves: rhbz#1320253 - Rebase libldb to version 1.1.26
2016-04-01 - Jakub Hrozek <jhrozek@redhat.com> - 1.1.25-1
- Rebase libldb to 1.1.25
- Remove upstreamed patches
- Related: rhbz#1322691
2015-12-14 - Jakub Hrozek <jhrozek@redhat.com> - 1.1.20-3
- Resolves: rhbz#1290715 - CVE-2015-5330 libldb: samba: Remote memory read
in Samba LDAP server [rhel-7.3]
- Remove the patch from the previous commit, it doesn't fix a remotely
eploitable issue. Add patches from upstream #11636 instead.
2015-12-14 - Jakub Hrozek <jhrozek@redhat.com> - 1.1.20-2
- Resolves: rhbz#1290715 - CVE-2015-5330 libldb: samba: Remote memory read
in Samba LDAP server [rhel-7.3]
2015-06-03 - Jakub Hrozek <jhrozek@redhat.com> - 1.1.20-1
- Related: rhbz#1226047 - Rebase libldb to at least 1.1.20 in RHEL-7.2
2014-11-24 - Jakub Hrozek <jhrozek@redhat.com> - 1.1.17-2
- Fix the minimal required tdb version
- Related: rhbz#1133914 - Rebase libldb to version 1.1.17 or newer
2014-09-04 - Jakub Hrozek <jhrozek@redhat.com> - 1.1.17-1
- New upstream release 1.1.17
- Resolves: rhbz#1133914 - Rebase libldb to version 1.1.17 or newer
2014-01-24 - Daniel Mach <dmach@redhat.com> - 1.1.16-4
- Mass rebuild 2014-01-24

See Also

Package Description
libldb-devel-1.2.2-1.el7.i686.rpm Developer tools for the LDB library
libldb-devel-1.2.2-1.el7.x86_64.rpm Developer tools for the LDB library
libloader-1.1.3-9.el7.noarch.rpm Resource Loading Framework
libloader-javadoc-1.1.3-9.el7.noarch.rpm Javadoc for libloader
liblockfile-1.08-17.el7.i686.rpm This implements a number of functions found in -lmail on SysV systems
liblockfile-1.08-17.el7.x86_64.rpm This implements a number of functions found in -lmail on SysV systems
liblockfile-devel-1.08-17.el7.i686.rpm Development files for liblockfile
liblockfile-devel-1.08-17.el7.x86_64.rpm Development files for liblockfile
liblognorm-2.0.2-1.el7.i686.rpm Fast samples-based log normalization library
liblognorm-2.0.2-1.el7.x86_64.rpm Fast samples-based log normalization library
liblognorm-devel-2.0.2-1.el7.i686.rpm Development tools for programs using liblognorm library
liblognorm-devel-2.0.2-1.el7.x86_64.rpm Development tools for programs using liblognorm library
liblognorm-doc-2.0.2-1.el7.x86_64.rpm HTML documentation for liblognorm
liblognorm-utils-2.0.2-1.el7.x86_64.rpm Lognormalizer utility for normalizing log files
liblouis-2.5.2-12.el7_4.i686.rpm Braille translation and back-translation library
Advertisement
Advertisement