golang-github-kr-pty-devel-0-0.19.git98c7b80.el7.x86_64.rpm


Advertisement

Description

golang-github-kr-pty-devel - PTY interface for Go

Property Value
Distribution CentOS 7
Repository CentOS x86_64
Package name golang-github-kr-pty-devel
Package version 0
Package release 0.19.git98c7b80.el7
Package architecture x86_64
Package type rpm
Installed size 6.41 KB
Download size 9.44 KB
Official Mirror mirror.centos.org
Pty is a Go package for using UNIX pseudo-terminals.
This package contains library source intended for building other packages
which use kr/pty.

Alternatives

Package Version Architecture Repository
golang-github-kr-pty-devel - - -

Requires

Name Value
golang -

Provides

Name Value
golang(github.com/kr/pty) = 0-0.19.git98c7b80.el7
golang-github-kr-pty-devel = 0-0.19.git98c7b80.el7
golang-github-kr-pty-devel(x86-64) = 0-0.19.git98c7b80.el7

Download

Type URL
Binary Package golang-github-kr-pty-devel-0-0.19.git98c7b80.el7.x86_64.rpm
Source Package golang-github-kr-pty-0-0.19.git98c7b80.el7.src.rpm

Install Howto

Install the golang-github-kr-pty-devel rpm package:

# yum install golang-github-kr-pty-devel

Files

Path
/usr/share/doc/golang-github-kr-pty-devel-0/License
/usr/share/doc/golang-github-kr-pty-devel-0/README.md
/usr/share/gocode/
/usr/share/gocode/src/
/usr/share/gocode/src/github.com/
/usr/share/gocode/src/github.com/kr/
/usr/share/gocode/src/github.com/kr/pty/doc.go
/usr/share/gocode/src/github.com/kr/pty/pty_darwin.go
/usr/share/gocode/src/github.com/kr/pty/pty_freebsd.go
/usr/share/gocode/src/github.com/kr/pty/pty_linux.go
/usr/share/gocode/src/github.com/kr/pty/pty_unsupported.go
/usr/share/gocode/src/github.com/kr/pty/run.go
/usr/share/gocode/src/github.com/kr/pty/util.go

Changelog

2014-03-07 - Lokesh Mandvekar <lsm5@redhat.com> 0-0.19.git98c7b80
-  Add pty_unsupported.go file in order to allow projects to import the
package and still compile on other os/arch
2014-01-15 - Lokesh Mandvekar <lsm5@redhat.com> 0-0.18.git3b1f648
- exclusivearch for el6+
2014-01-15 - Lokesh Mandvekar <lsm5@redhat.com> 0-0.17.git3b1f648
- revert golang >= 1.2 version requirement
2014-01-15 - Lokesh Mandvekar <lsm5@redhat.com> 0-0.16.git3b1f648
- require golang 1.2 and up
2013-10-16 - Lokesh Mandvekar <lsm5@redhat.com> 0-0.15.git3b1f648
- removed double quotes from provides
2013-10-08 - Lokesh Mandvekar <lsm5@redhat.com> 0-0.14.git3b1f648
- noarch for f19+ and rhel7+, exclusivearch otherwise
2013-10-07 - Lokesh Mandvekar <lsm5@redhat.com> 0-0.13.git3b1f648
- exclusivearch as per golang
2013-10-06 - Lokesh Mandvekar <lsm5@redhat.com> 0-0.12.git3b1f648
- excluded for ppc64
- debug_package nil
2013-10-02 - Lokesh Mandvekar <lsm5@fedoraproject.org> 0-0.11.git3b1f648
- docker first run error fix
2013-09-22 - Matthew Miller <mattdm@fedoraproject.org> 0-0.10.git27435c6
- install just the source code for devel package

See Also

Package Description
golang-github-syndtr-gocapability-devel-0-0.5.git3454319.el7.i686.rpm Source for POSIX capability for the Go programming language
golang-github-syndtr-gocapability-devel-0-0.5.git3454319.el7.x86_64.rpm Source for POSIX capability for the Go programming language
golang-googlecode-net-devel-0-0.12.hg84a4013f96e0.el7.noarch.rpm Supplementary Go networking libraries
golang-googlecode-sqlite-devel-0-0.9.hg74691fb6f837.el7.i686.rpm Trivial sqlite3 binding for Go
golang-googlecode-sqlite-devel-0-0.9.hg74691fb6f837.el7.x86_64.rpm Trivial sqlite3 binding for Go
golang-misc-1.9.4-1.el7.noarch.rpm Golang compiler miscellaneous sources
golang-src-1.9.4-1.el7.noarch.rpm Golang compiler source tree
golang-tests-1.9.4-1.el7.noarch.rpm Golang compiler tests for stdlib
gom-0.3.2-1.el7.i686.rpm GObject to SQLite object mapper library
gom-0.3.2-1.el7.x86_64.rpm GObject to SQLite object mapper library
gom-devel-0.3.2-1.el7.i686.rpm Development files for gom
gom-devel-0.3.2-1.el7.x86_64.rpm Development files for gom
google-crosextra-caladea-fonts-1.002-0.4.20130214.el7.noarch.rpm Serif font metric-compatible with Cambria font
google-crosextra-carlito-fonts-1.103-0.2.20130920.el7.noarch.rpm Sans-serif font metric-compatible with Calibri font
google-guice-3.1.3-9.el7.noarch.rpm Lightweight dependency injection framework for Java 5 and above
Advertisement
Advertisement