libgfortran5-8.2.1-1.3.1.el7_5.x86_64.rpm


Advertisement

Description

libgfortran5 - Fortran runtime v5

Property Value
Distribution CentOS 7
Repository CentOS Updates x86_64
Package name libgfortran5
Package version 8.2.1
Package release 1.3.1.el7_5
Package architecture x86_64
Package type rpm
Installed size 2.67 MB
Download size 796.26 KB
Official Mirror mirror.centos.org
This package contains Fortran shared library v5 which is needed to run
Fortran dynamically linked programs.

Alternatives

Package Version Architecture Repository
libgfortran5 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.17)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_3.3)(64bit) -
libgcc_s.so.1(GCC_4.2.0)(64bit) -
libgcc_s.so.1(GCC_4.3.0)(64bit) -
libgcc_s.so.1(GCC_4.8.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libquadmath -
libquadmath.so.0()(64bit) -
libquadmath.so.0(QUADMATH_1.0)(64bit) -
libz.so.1()(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
libgfortran.so.5()(64bit) -
libgfortran.so.5(GFORTRAN_8)(64bit) -
libgfortran.so.5(GFORTRAN_C99_8)(64bit) -
libgfortran.so.5(GFORTRAN_F2C_8)(64bit) -
libgfortran5 = 8.2.1-1.3.1.el7_5
libgfortran5(x86-64) = 8.2.1-1.3.1.el7_5

Download

Type URL
Binary Package libgfortran5-8.2.1-1.3.1.el7_5.x86_64.rpm
Source Package gcc-libraries-8.2.1-1.3.1.el7_5.src.rpm

Install Howto

Install the libgfortran5 rpm package:

# yum install libgfortran5

Files

Path
/usr/lib64/libgfortran.so.5
/usr/lib64/libgfortran.so.5.0.0
/usr/share/doc/libgfortran5-8.2.1/COPYING.RUNTIME
/usr/share/doc/libgfortran5-8.2.1/COPYING3
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2002.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2003.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2004.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2005.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2006.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2007.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2008.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2009.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2010.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2011.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2012.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2013.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2014.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2015.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2016.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog-2017.libgfortran.bz2
/usr/share/doc/libgfortran5-8.2.1/ChangeLog.libgfortran.bz2

Changelog

2018-08-27 - Marek Polacek <polacek@redhat.com> 8.2.1-1.3.1
- update 0022-Default-values-for-certain-field-descriptors-in-form.patch
2018-08-02 - Marek Polacek <polacek@redhat.com> 8.2.1-1.2.1
- update from rhel-7.6 branch
2018-04-05 - Marek Polacek <polacek@redhat.com> 7.2.1-1.2.1
- Add support for DEC formatting extensions (#1564043)
2017-10-19 - Marek Polacek <polacek@redhat.com> 7.2.1-1.1.1
- update from gcc-7.2.1-1 (#1477224)
2017-06-20 - Marek Polacek <polacek@redhat.com> 7.1.1-2.2.1
- don't run make check with -fstack-protector on ppc64le
2017-06-15 - Marek Polacek <polacek@redhat.com> 7.1.1-2.1.1
- bump gcc_release (DTS7 gcc-gfortran requires libgfortran4 >= 7.1.1-2)
2017-06-12 - Marek Polacek <polacek@redhat.com> 7.1.1-1.2.1
- remove libquadmath.so.* so that it doesn't end up in debuginfo
2017-06-05 - Marek Polacek <polacek@redhat.com> 7.1.1-1.1.1
- rename libgfortran2 to libgfortran4
- update from Fedora gcc-7.1.1-2.fc27
2017-05-24 - Marek Polacek <polacek@redhat.com> 7.0.1-4.2.1
- also build on ppc64le
2017-03-20 - Marek Polacek <polacek@redhat.com> 7.0.1-4.1.1
- also build on aarch64
- drop libitm
- only enable libatomic for aarch64

See Also

Package Description
libgnat-4.8.5-28.el7_5.1.i686.rpm GNU Ada 95 runtime shared libraries
libgnat-4.8.5-28.el7_5.1.x86_64.rpm GNU Ada 95 runtime shared libraries
libgnat-devel-4.8.5-28.el7_5.1.i686.rpm GNU Ada 95 libraries
libgnat-devel-4.8.5-28.el7_5.1.x86_64.rpm GNU Ada 95 libraries
libgnat-static-4.8.5-28.el7_5.1.i686.rpm GNU Ada 95 static libraries
libgnat-static-4.8.5-28.el7_5.1.x86_64.rpm GNU Ada 95 static libraries
libgo-4.8.5-28.el7_5.1.i686.rpm Go runtime
libgo-4.8.5-28.el7_5.1.x86_64.rpm Go runtime
libgo-devel-4.8.5-28.el7_5.1.i686.rpm Go development libraries
libgo-devel-4.8.5-28.el7_5.1.x86_64.rpm Go development libraries
libgo-static-4.8.5-28.el7_5.1.i686.rpm Static Go libraries
libgo-static-4.8.5-28.el7_5.1.x86_64.rpm Static Go libraries
libgomp-4.8.5-28.el7_5.1.i686.rpm GCC OpenMP v3.0 shared support library
libgomp-4.8.5-28.el7_5.1.x86_64.rpm GCC OpenMP v3.0 shared support library
libgudev1-219-57.el7_5.1.i686.rpm Libraries for adding libudev support to applications that use glib
Advertisement
Advertisement