ipa-client-4.6.4-10.el7.centos.3.x86_64.rpm


Advertisement

Description

ipa-client - IPA authentication for use on clients

Property Value
Distribution CentOS 7
Repository CentOS Updates x86_64
Package filename ipa-client-4.6.4-10.el7.centos.3.x86_64.rpm
Package name ipa-client
Package version 4.6.4
Package release 10.el7.centos.3
Package architecture x86_64
Package type rpm
Category System Environment/Base
Homepage http://www.freeipa.org/
License GPLv3+
Maintainer -
Download size 268.47 KB
Installed size 253.77 KB
IPA is an integrated solution to provide centrally managed Identity (users,
hosts, services), Authentication (SSO, 2FA), and Authorization
(host access control, SELinux user roles, services). The solution provides
features for further integration with Linux based clients (SUDO, automount)
and integration with Active Directory based infrastructures (Trusts).
If your network uses IPA for authentication, this package should be
installed on every client machine.
This package provides command-line tools for IPA administrators.

Alternatives

Package Version Architecture Repository
ipa-client-4.6.4-10.el7.centos.2.x86_64.rpm 4.6.4 x86_64 CentOS Updates
ipa-client-4.6.4-10.el7.centos.x86_64.rpm 4.6.4 x86_64 CentOS
ipa-client - - -

Requires

Name Value
/usr/bin/python2 -
authconfig -
autofs -
bind-utils -
certmonger >= 0.78.4-10
curl -
cyrus-sasl-gssapi(x86-64) -
initscripts -
ipa-client-common = 4.6.4-10.el7.centos.3
ipa-common = 4.6.4-10.el7.centos.3
krb5-workstation >= 1.15.1-4
libbasicobjects.so.0()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libcollection.so.2()(64bit) -
libcom_err.so.2()(64bit) -
libcrypto.so.10()(64bit) -
libcurl >= 7.21.7-2
libdl.so.2()(64bit) -
libini_config.so.3()(64bit) -
libini_config.so.3(INI_CONFIG_1.1.0)(64bit) -
libk5crypto.so.3()(64bit) -
libk5crypto.so.3(k5crypto_3_MIT)(64bit) -
libkrb5.so.3()(64bit) -
libkrb5.so.3(krb5_3_MIT)(64bit) -
liblber-2.4.so.2()(64bit) -
libldap_r-2.4.so.2()(64bit) -
libnfsidmap -
libnspr4.so()(64bit) -
libnss3.so()(64bit) -
libnssutil3.so()(64bit) -
libplc4.so()(64bit) -
libplds4.so()(64bit) -
libpopt.so.0()(64bit) -
libpopt.so.0(LIBPOPT_0)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libref_array.so.1()(64bit) -
libsasl2.so.3()(64bit) -
libsmime3.so()(64bit) -
libssl3.so()(64bit) -
libsss_autofs -
libxmlrpc.so.3()(64bit) -
libxmlrpc_client.so.3()(64bit) -
libxmlrpc_util.so.3()(64bit) -
nfs-utils -
nss-tools -
ntp -
oddjob-mkhomedir -
policycoreutils -
python-gssapi >= 1.2.0-3
python-ldap >= 2.4.15
python-sssdconfig -
python2-ipaclient = 4.6.4-10.el7.centos.3
rtld(GNU_HASH) -
sssd >= 1.14.0
xmlrpc-c >= 1.27.4

Provides

Name Value
config(ipa-client) = 4.6.4-10.el7.centos.3
freeipa-admintools = 4.6.4
freeipa-client = 4.6.4
ipa-admintools = 4.6.4-10.el7.centos.3
ipa-client = 4.6.4-10.el7.centos.3
ipa-client(x86-64) = 4.6.4-10.el7.centos.3

Conflicts

Name Value
freeipa-admintools -
freeipa-client -

Obsoletes

Name Value
freeipa-admintools < 4.4.1
freeipa-client < 4.6.4
ipa-admintools < 4.4.1

Download

Type URL
Mirror mirror.centos.org
Binary Package ipa-client-4.6.4-10.el7.centos.3.x86_64.rpm
Source Package ipa-4.6.4-10.el7.centos.3.src.rpm

Install Howto

Install ipa-client rpm package:

# yum install ipa-client

Files

Path
/etc/bash_completion.d/ipa
/usr/bin/ipa
/usr/sbin/ipa-certupdate
/usr/sbin/ipa-client-automount
/usr/sbin/ipa-client-install
/usr/sbin/ipa-getkeytab
/usr/sbin/ipa-join
/usr/sbin/ipa-rmkeytab
/usr/share/doc/ipa-client-4.6.4/Contributors.txt
/usr/share/doc/ipa-client-4.6.4/README.md
/usr/share/licenses/ipa-client-4.6.4/COPYING
/usr/share/man/man1/ipa-certupdate.1.gz
/usr/share/man/man1/ipa-client-automount.1.gz
/usr/share/man/man1/ipa-client-install.1.gz
/usr/share/man/man1/ipa-getkeytab.1.gz
/usr/share/man/man1/ipa-join.1.gz
/usr/share/man/man1/ipa-rmkeytab.1.gz
/usr/share/man/man1/ipa.1.gz

Changelog

2019-03-12 - CentOS Sources <bugs@centos.org> - 4.6.4-10.el7.centos.3
- Roll in CentOS Branding
2019-02-04 - Florence Blanc-Renaud <frenaud@redhat.com> - 4.6.4-10.el7_6.3
- Resolves: 1672343 pki spawn fails for IPA replica install from RHEL6 IPA master
- Update mod_nss cipher list so there is overlap with a 4.x master
- Resolves: 1672342 Fix compile issue with new 389-ds
- ipa-sidgen: make internal fetch_attr helper really internal
- Resolves: 1672176 host_del and host_disable fails, ra.find() search for every certificates instead of the host's certificate by subject
- Add workaround for slow host/service del
- Optimize cert remove case
- Resolves: 1672238 The ipa-replica-install command failed, exception: ValidationError: invalid 'dnszoneidnsname': only master zones can contain record
- replica installation: add master record only if in managed zone
- ipatests: add test for replica in forward zone
2018-12-18 - Florence Blanc-Renaud <frenaud@redhat.com> - 4.6.4-10.el7_6.2
- Resolves: 1659492 searching for ipa users by certificate fails
- ipaldap.py: fix method creating a ldap filter for IPACertificate
- ipatests: add xmlrpc test for user|host-find --certificate
- Resolves: 1659509 IPA Upgrade failed with "unable to convert the attribute u'cACertificate;binary'"
- ipa upgrade: handle double-encoded certificates
- ipatests: add upgrade test for double-encoded cacert
- ipatests: fix TestUpgrade::test_double_encoded_cacert
- Resolves: 1659500 'ipa vault-retrieve' is failing with "ipa: ERROR: an internal error has occurred"
- Add a shared-vault-retrieve test
- Add a "Find enabled services" ACI in 20-aci.update so that all users can find IPA servers and services. ACI suggested by Christian Heimes.
- Resolves: 1659511 ipa-pkinit-manage reports a switch from local pkinit to full pkinit configuration was successful although it was not.
- ipatest: add test for ipa-pkinit-manage enable|disable
- PKINIT: fix ipa-pkinit-manage enable|disable
- Resolves: 1659499 automember-rebuild crashes
- Find orphan automember rules
- Resolves: 1660389 ipa-replica-install fails migrating RHEL 6 to 7
- replication: check remote ds version before editing attributes
2018-09-18 - Florence Blanc-Renaud <frenaud@redhat.com> - 4.6.4-10.el7
- Resolves: 1630361 PKINIT fails in FIPS mode
- Ensure that public cert and CA bundle are readable
- Always make ipa.p11-kit world-readable
- Make /etc/httpd/alias world readable & executable
- Fix permission of public files in upgrader
2018-09-10 - Florence Blanc-Renaud <frenaud@redhat.com> - 4.6.4-9.el7
- Resolves: #1624755 Re-installing replica on the same system displays 'WARNING: cannot check if port 443 is already configured'
- ipa-replica-install: properly use the file store
- Resolves: #1623486 PKINIT configuration did not succeed message is received during Replica-install
- ipa-replica-install: fix pkinit setup
- Related: #1624289 AVC denials noticed during test execution for SUB-CA test-suite in FIPS mode
- Update minimum selinux-policy to 3.13.1-224
2018-09-04 - Tibor Dudlák <tdudlak@redhat.com> - 4.6.4-8.el7
- Resolves #1508498 Authn/TOTP defined users periodically prompt for just password credentials to access resources
- Clear next field when returnining list elements in queue.c
- Add cmocka unit tests for ipa otpd queue code
- Resolves #1622168 ipa-otpd: fix potential double-free and infinite loop in queue code
- Clear next field when returnining list elements in queue.c
- Add cmocka unit tests for ipa otpd queue code
- Resolves #1603444 ipa-server-install script is failing when using the "--no-dnssec-validation" parameter combined with the "--forwarder"
- ipa-server-install: do not perform forwarder validation with --no-dnssec-validation

See Also

Package Description
ipa-client-common-4.6.4-10.el7.centos.2.noarch.rpm Common files used by IPA client
ipa-client-common-4.6.4-10.el7.centos.3.noarch.rpm Common files used by IPA client
ipa-common-4.6.4-10.el7.centos.2.noarch.rpm Common files used by IPA
ipa-common-4.6.4-10.el7.centos.3.noarch.rpm Common files used by IPA
ipa-python-compat-4.6.4-10.el7.centos.2.noarch.rpm Compatiblity package for Python libraries used by IPA
ipa-python-compat-4.6.4-10.el7.centos.3.noarch.rpm Compatiblity package for Python libraries used by IPA
ipa-server-4.6.4-10.el7.centos.2.x86_64.rpm The IPA authentication server
ipa-server-4.6.4-10.el7.centos.3.x86_64.rpm The IPA authentication server
ipa-server-common-4.6.4-10.el7.centos.2.noarch.rpm Common files used by IPA server
ipa-server-common-4.6.4-10.el7.centos.3.noarch.rpm Common files used by IPA server
ipa-server-dns-4.6.4-10.el7.centos.2.noarch.rpm IPA integrated DNS server with support for automatic DNSSEC signing
ipa-server-dns-4.6.4-10.el7.centos.3.noarch.rpm IPA integrated DNS server with support for automatic DNSSEC signing
ipa-server-trust-ad-4.6.4-10.el7.centos.2.x86_64.rpm Virtual package to install packages required for Active Directory trusts
ipa-server-trust-ad-4.6.4-10.el7.centos.3.x86_64.rpm Virtual package to install packages required for Active Directory trusts
iproute-4.11.0-14.el7_6.2.x86_64.rpm Advanced IP routing and network device configuration tools
Advertisement
Advertisement