rh-ruby24-rubygems-devel-2.6.14.4-92.el7.noarch.rpm


Advertisement

Description

rh-ruby24-rubygems-devel - Macros and development tools for packaging RubyGems

Property Value
Distribution CentOS 7
Repository CentOS SCLo RH x86_64
Package filename rh-ruby24-rubygems-devel-2.6.14.4-92.el7.noarch.rpm
Package name rh-ruby24-rubygems-devel
Package version 2.6.14.4
Package release 92.el7
Package architecture noarch
Package type rpm
Category Development/Libraries
Homepage http://ruby-lang.org/
License Ruby or MIT
Maintainer -
Download size 49.55 KB
Installed size 4.37 KB
Macros and development tools for packaging RubyGems.

Alternatives

Package Version Architecture Repository
rh-ruby24-rubygems-devel-2.6.14.4-92.el7.noarch.rpm 2.6.14.4 noarch CentOS SCLo RH Testing
rh-ruby24-rubygems-devel-2.6.14.3-91.sc1.el7.noarch.rpm 2.6.14.3 noarch CentOS SCLo RH Testing
rh-ruby24-rubygems-devel-2.6.14.3-91.sc1.el7.noarch.rpm 2.6.14.3 noarch CentOS SCLo RH
rh-ruby24-rubygems-devel-2.6.14-90.el7.noarch.rpm 2.6.14 noarch CentOS SCLo RH Testing
rh-ruby24-rubygems-devel-2.6.14-90.el7.noarch.rpm 2.6.14 noarch CentOS SCLo RH
rh-ruby24-rubygems-devel-2.6.8-75.el7.noarch.rpm 2.6.8 noarch CentOS SCLo RH Testing
rh-ruby24-rubygems-devel-2.6.8-75.el7.noarch.rpm 2.6.8 noarch CentOS SCLo RH
rh-ruby24-rubygems-devel - - -

Requires

Name Value
rh-ruby24-ruby(rubygems) = 2.6.14.4-92.el7
rh-ruby24-rubygem(json) >= 2.0.4
rh-ruby24-rubygem(rdoc) >= 5.0.0

Provides

Name Value
config(rh-ruby24-rubygems-devel) = 2.6.14.4-92.el7
rh-ruby24-rubygems-devel = 2.6.14.4-92.el7

Download

Type URL
Mirror mirror.centos.org
Binary Package rh-ruby24-rubygems-devel-2.6.14.4-92.el7.noarch.rpm
Source Package rh-ruby24-ruby-2.4.6-92.el7.src.rpm

Install Howto

  1. Install CentOS SCLo RH repository:
    yum install centos-release-scl-rh
  2. Install rh-ruby24-rubygems-devel rpm package:
    # yum install rh-ruby24-rubygems-devel

Files

Path
/etc/rpm/macros.rubygems.rh-ruby24

Changelog

2019-04-11 - Jun Aruga <jaruga@redhat.com> - 2.4.6-92
- Upgrade to Ruby 2.4.6.
- Delete directory using symlink when decompressing tar
Resolves: CVE-2019-8320
- Fix escape sequence injection vulnerability in verbose.
Resolves: CVE-2019-8321
- Fix escape sequence injection vulnerability in gem owner.
Resolves: CVE-2019-8322
- Fix escape sequence injection vulnerability in API response handling.
Resolves: CVE-2019-8323
- Prohibit arbitrary code execution when installing a malicious gem.
Resolves: CVE-2019-8324
- Fix escape sequence injection vulnerability in errors.
Resolves: CVE-2019-8325
2018-11-05 - Pavel Valena <pvalena@redhat.com> - 2.4.5-91
- Upgrade to Ruby 2.4.5.
Resolves: CVE-2018-16395
Resolves: rhbz#1563077
Removed Patch10: ruby-2.5.0-Disable-Tokyo-TZ-tests.patch; subsumed
- Properly harden package using -fstack-protector-strong.
- Fix: return default path with nonexistent home dir(rhbz#1602879)
2018-03-12 - Pavel Valena <pvalena@redhat.com> - 2.4.3-90
- Command injection in lib/resolv.rb:lazy_initialize() allows arbitrary code
execution(CVE-2017-17790).
* ruby-2.5.0-Fixed-command-Injection.patch
Related: rhbz#1549651
2018-02-12 - Pavel Valena <pvalena@redhat.com> - 2.4.3-89
- Upgrade to Ruby 2.4.3.
Resolves: rhbz#1549651
Resolves: CVE-2017-17405
* Remove Patch10: ruby-2.4.3-CVE-2017-0903-Fix-unsafe-object-deserialization
-vulnerability.patch
subsumed
2017-10-30 - Vít Ondruch <vondruch@redhat.com> - 2.4.2-86
- Upgrade to Ruby 2.4.2.
* Remove Patch10: ruby-2.4.0-vm_insnhelper.c-block-argument-at-tailcall.patch;
subsumed
Resolves: rhbz#1506785
- Fix unsafe object deserialization in RubyGems (CVE-2017-0903).
* ruby-2.4.3-CVE-2017-0903-Fix-unsafe-object-deserialization
-vulnerability.patch
Resolves: CVE-2017-0903
2017-01-17 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-75
- Apply patch fixing rubygem-mongo build failures.
2017-01-09 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-73
- Reshuffle the %license macro to avoid %postun scriptlet issues.
Resolves: rhbz#1411233
2017-01-09 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-72
- Add rubygem-io-console dependency for rubygem-rdoc.
2017-01-02 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-71
- ruby-libs should not own links to unbundled gems.
2017-01-02 - Vít Ondruch <vondruch@redhat.com> - 2.4.0-70
- Upgrade to Ruby 2.4.0.
- Workaround "an invalid stdio handle" error on PPC (rhbz#1361037).
- Add gemspec_add_dep and gemspec_remove_dep macros.
- Move gemified xmlrpc into subpackage.
- Move gemified openssl into subpackage.
- Make symlinks for json gem.
- Tk is removed from stdlib.
- Harden package.
- Extend 'gem_' macros for pre-release version support.

See Also

Package Description
rh-ruby24-runtime-2.4-2.el7.x86_64.rpm Package that handles rh-ruby24 Software Collection
rh-ruby24-scldevel-2.4-2.el7.x86_64.rpm Package shipping development files for rh-ruby24
rh-ruby25-2.5-2.el7.x86_64.rpm Package that installs rh-ruby25
rh-ruby25-build-2.5-2.el7.x86_64.rpm Package shipping basic build configuration
rh-ruby25-ruby-2.5.0-5.el7.x86_64.rpm An interpreter of object-oriented scripting language
rh-ruby25-ruby-2.5.3-6.el7.x86_64.rpm An interpreter of object-oriented scripting language
rh-ruby25-ruby-2.5.5-7.el7.x86_64.rpm An interpreter of object-oriented scripting language
rh-ruby25-ruby-devel-2.5.0-5.el7.x86_64.rpm A Ruby development environment
rh-ruby25-ruby-devel-2.5.3-6.el7.x86_64.rpm A Ruby development environment
rh-ruby25-ruby-devel-2.5.5-7.el7.x86_64.rpm A Ruby development environment
rh-ruby25-ruby-doc-2.5.0-5.el7.noarch.rpm Documentation for ruby
rh-ruby25-ruby-doc-2.5.3-6.el7.noarch.rpm Documentation for ruby
rh-ruby25-ruby-doc-2.5.5-7.el7.noarch.rpm Documentation for ruby
rh-ruby25-ruby-irb-2.5.0-5.el7.noarch.rpm The Interactive Ruby
rh-ruby25-ruby-irb-2.5.3-6.el7.noarch.rpm The Interactive Ruby
Advertisement
Advertisement