rh-eclipse46-eclipse-dltk-ruby-5.7.0-1.2.el7.noarch.rpm


Advertisement

Description

rh-eclipse46-eclipse-dltk-ruby - Ruby Eclipse plug-in

Property Value
Distribution CentOS 7
Repository CentOS SCLo RH x86_64
Package filename rh-eclipse46-eclipse-dltk-ruby-5.7.0-1.2.el7.noarch.rpm
Package name rh-eclipse46-eclipse-dltk-ruby
Package version 5.7.0
Package release 1.2.el7
Package architecture noarch
Package type rpm
Homepage http://www.eclipse.org/dltk/
License EPL and (CPL or GPLv2+ or LGPLv2+) and Ruby and ASL 2.0
Maintainer -
Download size 1.32 MB
Installed size 1.67 MB
Ruby development environment for Eclipse based on the Eclipse Dynamic
Languages Toolkit (DLTK).

Alternatives

Package Version Architecture Repository
rh-eclipse46-eclipse-dltk-ruby-5.7.1-1.3.el7.noarch.rpm 5.7.1 noarch CentOS SCLo RH Testing
rh-eclipse46-eclipse-dltk-ruby-5.7.1-1.3.el7.noarch.rpm 5.7.1 noarch CentOS SCLo RH
rh-eclipse46-eclipse-dltk-ruby - - -

Requires

Name Value
java -
rh-eclipse46-osgi(org.eclipse.dltk.core) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.debug) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.debug.ui) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.formatter) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.launching) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.testing) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ui) = 5.7.0.201701161407
rh-eclipse46-runtime -
ruby -
ruby-doc -

Provides

Name Value
rh-eclipse46-eclipse-dltk-ruby = 5.7.0-1.2.el7
rh-eclipse46-mvn(org.eclipse.dltk.features:org.eclipse.dltk.ruby) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.abstractdebugger) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.activestatedebugger) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.basicdebugger) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.core) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.debug) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.debug.ui) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.fastdebugger) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.formatter) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.launching) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.testing) = 5.7.0.SNAPSHOT
rh-eclipse46-mvn(org.eclipse.dltk.ruby:org.eclipse.dltk.ruby.ui) = 5.7.0.SNAPSHOT
rh-eclipse46-osgi(org.eclipse.dltk.ruby) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.abstractdebugger) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.activestatedebugger) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.basicdebugger) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.core) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.debug) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.debug.ui) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.fastdebugger) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.formatter) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.launching) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.testing) = 5.7.0.201701161407
rh-eclipse46-osgi(org.eclipse.dltk.ruby.ui) = 5.7.0.201701161407

Download

Type URL
Mirror mirror.centos.org
Binary Package rh-eclipse46-eclipse-dltk-ruby-5.7.0-1.2.el7.noarch.rpm
Source Package rh-eclipse46-eclipse-dltk-5.7.0-1.2.el7.src.rpm

Install Howto

  1. Install CentOS SCLo RH repository:
    yum install centos-release-scl-rh
  2. Install rh-eclipse46-eclipse-dltk-ruby rpm package:
    # yum install rh-eclipse46-eclipse-dltk-ruby

Files

Path
/opt/rh/rh-eclipse46/root/usr/share/doc/rh-eclipse46-eclipse-dltk-ruby-5.7.0/epl-v10.html
/opt/rh/rh-eclipse46/root/usr/share/doc/rh-eclipse46-eclipse-dltk-ruby-5.7.0/notice.html
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/fragment.info
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/features/
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/features/org.eclipse.dltk.ruby_5.7.0.201701161407/eclipse_update_120.jpg
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/features/org.eclipse.dltk.ruby_5.7.0.201701161407/epl-v10.html
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/features/org.eclipse.dltk.ruby_5.7.0.201701161407/feature.properties
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/features/org.eclipse.dltk.ruby_5.7.0.201701161407/feature.xml
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/features/org.eclipse.dltk.ruby_5.7.0.201701161407/license.html
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/features/org.eclipse.dltk.ruby_5.7.0.201701161407/META-INF/MANIFEST.MF
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.abstractdebugger_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.activestatedebugger_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.basicdebugger_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.core_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.debug.ui_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.debug_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.fastdebugger_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.formatter_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.launching_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.testing_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby.ui_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/eclipse/droplets/dltk-ruby/eclipse/plugins/org.eclipse.dltk.ruby_5.7.0.201701161407.jar
/opt/rh/rh-eclipse46/root/usr/share/maven-metadata/eclipse-dltk-ruby.xml

Changelog

2017-01-16 - Mat Booth <mat.booth@redhat.com> - 5.7.0-1.2
- Tweak requires and lucene patch for compatibility with RHEL
2017-01-16 - Mat Booth <mat.booth@redhat.com> - 5.7.0-1.1
- Auto SCL-ise package for rh-eclipse46 collection
2017-01-10 - Mat Booth <mat.booth@redhat.com> - 5.7.0-1
- Update to latest release
- Fix indexing problems caused by split-packages in Lucene libs - rhbz#1397238
- Drop some ancient obsoletes
2016-10-04 - Mat Booth <mat.booth@redhat.com> - 5.6.0-1
- Update to 5.6.0 release
2016-07-14 - Mat Booth <mat.booth@redhat.com> - 5.5.0-3
- Fix restricted API warnings in lucene indexer
2016-07-08 - Mat Booth <mat.booth@redhat.com> - 5.5.0-2
- Require fixed version of lucene-misc
2016-07-04 - Mat Booth <mat.booth@redhat.com> - 5.5.0-1
- Update and port to latest Lucene 5
2016-03-29 - Mat Booth <mat.booth@redhat.com> - 5.4.0-4
- Fix empty Variables view when debugging Ruby script
2016-03-21 - Alexander Kurtakov <akurtako@redhat.com> 5.4.0-3
- Add Rs for better experience - Test:Unit run and stdlib docs.
2016-03-18 - Mat Booth <mat.booth@redhat.com> - 5.4.0-2
- Backport patches for ebz#323736 and ebz#489902

See Also

Package Description
rh-eclipse46-eclipse-dltk-sdk-5.7.0-1.2.el7.noarch.rpm Eclipse DLTK SDK
rh-eclipse46-eclipse-dltk-sdk-5.7.1-1.3.el7.noarch.rpm Eclipse DLTK SDK
rh-eclipse46-eclipse-dltk-sh-5.7.0-1.2.el7.noarch.rpm Shell Script editor support
rh-eclipse46-eclipse-dltk-sh-5.7.1-1.3.el7.noarch.rpm Shell Script editor support
rh-eclipse46-eclipse-dltk-tcl-5.7.0-1.2.el7.noarch.rpm TCL Eclipse plug-in
rh-eclipse46-eclipse-dltk-tcl-5.7.1-1.3.el7.noarch.rpm TCL Eclipse plug-in
rh-eclipse46-eclipse-dltk-tests-5.7.0-1.2.el7.noarch.rpm Eclipse DLTK Tests
rh-eclipse46-eclipse-dltk-tests-5.7.1-1.3.el7.noarch.rpm Eclipse DLTK Tests
rh-eclipse46-eclipse-ecf-core-3.13.3-1.2.el7.x86_64.rpm Eclipse ECF Core
rh-eclipse46-eclipse-ecf-core-3.13.3-1.3.el7.x86_64.rpm Eclipse ECF Core
rh-eclipse46-eclipse-ecf-runtime-3.13.3-1.2.el7.noarch.rpm Eclipse Communication Framework (ECF) Eclipse plug-in
rh-eclipse46-eclipse-ecf-runtime-3.13.3-1.3.el7.noarch.rpm Eclipse Communication Framework (ECF) Eclipse plug-in
rh-eclipse46-eclipse-ecf-sdk-3.13.3-1.2.el7.noarch.rpm Eclipse ECF SDK
rh-eclipse46-eclipse-ecf-sdk-3.13.3-1.3.el7.noarch.rpm Eclipse ECF SDK
rh-eclipse46-eclipse-egit-4.6.0-1.1.el7.noarch.rpm Eclipse Git Integration
Advertisement
Advertisement