rh-varnish6-varnish-modules-0.15.0-4.el7.x86_64.rpm


Advertisement

Description

rh-varnish6-varnish-modules - A collection of modules ("vmods") extending Varnish VCL

Property Value
Distribution CentOS 7
Repository CentOS SCLo RH Testing x86_64
Package filename rh-varnish6-varnish-modules-0.15.0-4.el7.x86_64.rpm
Package name rh-varnish6-varnish-modules
Package version 0.15.0
Package release 4.el7
Package architecture x86_64
Package type rpm
Category System Environment/Daemons
Homepage https://github.com/varnish/varnish-modules
License BSD
Maintainer -
Download size 74.18 KB
Installed size 185.27 KB
This is a collection of modules ("vmods") extending Varnish VCL used
for describing HTTP request/response policies with additional
capabilities. This collection contains the following vmods (previously
kept individually): cookie, vsthrottle, header, saintmode, softpurge,
tcp, var, xkey

Alternatives

Package Version Architecture Repository
rh-varnish6-varnish-modules-0.15.0-4.el7.x86_64.rpm 0.15.0 x86_64 CentOS SCLo RH
rh-varnish6-varnish-modules - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libvarnishapi-rh-varnish6.so.1()(64bit) -
libvarnishapi-rh-varnish6.so.1(LIBVARNISHAPI_2.0)(64bit) -
rh-varnish6-runtime -
rh-varnish6-varnish -
rtld(GNU_HASH) -

Provides

Name Value
libvmod_bodyaccess.so()(64bit) -
libvmod_cookie.so()(64bit) -
libvmod_header.so()(64bit) -
libvmod_saintmode.so()(64bit) -
libvmod_tcp.so()(64bit) -
libvmod_var.so()(64bit) -
libvmod_vsthrottle.so()(64bit) -
libvmod_xkey.so()(64bit) -
rh-varnish6-varnish-modules = 0.15.0-4.el7
rh-varnish6-varnish-modules(x86-64) = 0.15.0-4.el7
scl-package(rh-varnish6) -
vmod-bodyaccess = 0.15.0-4.el7
vmod-cookie = 0.15.0-4.el7
vmod-header = 0.15.0-4.el7
vmod-saintmode = 0.15.0-4.el7
vmod-tcp = 0.15.0-4.el7
vmod-var = 0.15.0-4.el7
vmod-vsthrottle = 0.15.0-4.el7
vmod-xkey = 0.15.0-4.el7

Download

Type URL
Mirror buildlogs.centos.org
Binary Package rh-varnish6-varnish-modules-0.15.0-4.el7.x86_64.rpm
Source Package rh-varnish6-varnish-modules-0.15.0-4.el7.src.rpm

Install Howto

  1. Install CentOS SCLo RH Testing repository:
    yum install centos-release-scl-rh
  2. Install rh-varnish6-varnish-modules rpm package:
    # yum --enablerepo=centos-sclo-rh-testing install rh-varnish6-varnish-modules

Files

Path
/opt/rh/rh-varnish6/root/usr/lib64/varnish/vmods/libvmod_bodyaccess.so
/opt/rh/rh-varnish6/root/usr/lib64/varnish/vmods/libvmod_cookie.so
/opt/rh/rh-varnish6/root/usr/lib64/varnish/vmods/libvmod_header.so
/opt/rh/rh-varnish6/root/usr/lib64/varnish/vmods/libvmod_saintmode.so
/opt/rh/rh-varnish6/root/usr/lib64/varnish/vmods/libvmod_tcp.so
/opt/rh/rh-varnish6/root/usr/lib64/varnish/vmods/libvmod_var.so
/opt/rh/rh-varnish6/root/usr/lib64/varnish/vmods/libvmod_vsthrottle.so
/opt/rh/rh-varnish6/root/usr/lib64/varnish/vmods/libvmod_xkey.so
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/AUTHORS
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/CHANGES.rst
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/COPYING
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/LICENSE
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/README.rst
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/docs/vmod_cookie.rst
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/docs/vmod_header.rst
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/docs/vmod_saintmode.rst
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/docs/vmod_softpurge.rst
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/docs/vmod_tcp.rst
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/docs/vmod_var.rst
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/docs/vmod_vsthrottle.rst
/opt/rh/rh-varnish6/root/usr/share/doc/rh-varnish6-varnish-modules-0.15.0/docs/vmod_xkey.rst
/opt/rh/rh-varnish6/root/usr/share/licenses/rh-varnish6-varnish-modules-0.15.0/LICENSE
/opt/rh/rh-varnish6/root/usr/share/man/man3/vmod_bodyaccess.3.gz
/opt/rh/rh-varnish6/root/usr/share/man/man3/vmod_cookie.3.gz
/opt/rh/rh-varnish6/root/usr/share/man/man3/vmod_header.3.gz
/opt/rh/rh-varnish6/root/usr/share/man/man3/vmod_saintmode.3.gz
/opt/rh/rh-varnish6/root/usr/share/man/man3/vmod_tcp.3.gz
/opt/rh/rh-varnish6/root/usr/share/man/man3/vmod_var.3.gz
/opt/rh/rh-varnish6/root/usr/share/man/man3/vmod_vsthrottle.3.gz
/opt/rh/rh-varnish6/root/usr/share/man/man3/vmod_xkey.3.gz

Changelog

2018-12-03 - Lubos Uhliarik <luhliari@redhat.com> - 0.15.0-3
- Resolves: #1658671 - RFE: updated collection for Varnish 6
2018-08-05 - Lubos Uhliarik <luhliari@redhat.com> - 0.15.0-2
- Fixed i686 build failure
2018-08-05 - Lubos Uhliarik <luhliari@redhat.com> - 0.15.0-1
- updated to newer version (0.15.0)
- Drop EPEL and older Fedora releases support
- Drop broken manual ABI dependency to Varnish
- Drop commented out references to past patches
- Verbose test suite
- Simplified configure step
- Dependencies cleanup
2018-04-24 - LuboŇ° Uhliarik <luhliari@redhat.com> - 0.12.16
- use rst2man binary for both python2 and python3
2018-04-16 - Joe Orton <jorton@redhat.com> - 0.12.1-4.4
- fix abi requires (#1566046)
2018-03-29 - Joe Orton <jorton@redhat.com> - 0.12.1-4.2
- fix use of rst2man with python3-docutils
2018-03-28 - Joe Orton <jorton@redhat.com> - 0.12.1-4.1
- add Python build conditionals
2017-08-03 - Fedora Release Engineering <releng@fedoraproject.org> - 0.12.1-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
2017-07-27 - Fedora Release Engineering <releng@fedoraproject.org> - 0.12.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
2017-06-01 - Ingvar Hagelund <ingvar@redpill-linpro.com> 0.12.1-2
- Set correct varnishabi requirement for the different fedoras

See Also

Package Description
ror40-1.1-4.el7.x86_64.rpm Package that installs ror40
ror40-build-1.1-4.el7.x86_64.rpm Package shipping basic build configuration
ror40-rubygem-actionmailer-4.0.2-1.el7.noarch.rpm Service layer for easy email delivery and testing
ror40-rubygem-actionmailer-doc-4.0.2-1.el7.noarch.rpm Documentation for rubygem-actionmailer
ror40-rubygem-actionpack-4.0.2-8.el7.noarch.rpm Web-flow and rendering framework putting the VC in MVC
ror40-rubygem-actionpack-doc-4.0.2-8.el7.noarch.rpm Documentation for rubygem-actionpack
ror40-rubygem-activemodel-4.0.2-2.el7.noarch.rpm A toolkit for building modeling frameworks
ror40-rubygem-activemodel-doc-4.0.2-2.el7.noarch.rpm Documentation for rubygem-activemodel
ror40-rubygem-activerecord-4.0.2-6.el7.noarch.rpm Implements the ActiveRecord pattern for ORM
ror40-rubygem-activerecord-deprecated_finders-1.0.3-3.el7.noarch.rpm This gem contains deprecated finder APIs extracted from Active Record
ror40-rubygem-activerecord-deprecated_finders-doc-1.0.3-3.el7.noarch.rpm Documentation for rubygem-activerecord-deprecated_finders
ror40-rubygem-activerecord-doc-4.0.2-6.el7.noarch.rpm Documentation for rubygem-activerecord
ror40-rubygem-activeresource-4.0.0-3.el7.noarch.rpm Active Record for web resources
ror40-rubygem-activeresource-doc-4.0.0-3.el7.noarch.rpm Documentation for rubygem-activeresource
ror40-rubygem-activesupport-4.0.2-4.el7.noarch.rpm Support and utility classes used by the Rails framework
Advertisement
Advertisement