rh-nodejs8-nodejs-8.16.0-1.el7.x86_64.rpm


Advertisement

Description

rh-nodejs8-nodejs - JavaScript runtime

Property Value
Distribution CentOS 7
Repository CentOS SCLo RH Testing x86_64
Package filename rh-nodejs8-nodejs-8.16.0-1.el7.x86_64.rpm
Package name rh-nodejs8-nodejs
Package version 8.16.0
Package release 1.el7
Package architecture x86_64
Package type rpm
Category Development/Languages
Homepage http://nodejs.org/
License MIT and ASL 2.0 and ISC and BSD
Maintainer -
Download size 7.15 MB
Installed size 24.59 MB
Node.js is a platform built on Chrome's JavaScript runtime
for easily building fast, scalable network applications.
Node.js uses an event-driven, non-blocking I/O model that
makes it lightweight and efficient, perfect for data-intensive
real-time applications that run across distributed devices.

Alternatives

Package Version Architecture Repository
rh-nodejs8-nodejs-8.16.1-2.el7.x86_64.rpm 8.16.1 x86_64 CentOS SCLo RH Testing
rh-nodejs8-nodejs-8.16.1-2.el7.x86_64.rpm 8.16.1 x86_64 CentOS SCLo RH
rh-nodejs8-nodejs-8.16.0-1.el7.x86_64.rpm 8.16.0 x86_64 CentOS SCLo RH
rh-nodejs8-nodejs-8.11.4-1.el7.x86_64.rpm 8.11.4 x86_64 CentOS SCLo RH Testing
rh-nodejs8-nodejs-8.11.4-1.el7.x86_64.rpm 8.11.4 x86_64 CentOS SCLo RH
rh-nodejs8-nodejs-8.9.4-2.el7.x86_64.rpm 8.9.4 x86_64 CentOS SCLo RH Testing
rh-nodejs8-nodejs-8.9.4-2.el7.x86_64.rpm 8.9.4 x86_64 CentOS SCLo RH
rh-nodejs8-nodejs-8.6.0-1.el7.x86_64.rpm 8.6.0 x86_64 CentOS SCLo RH Testing
rh-nodejs8-nodejs-8.3.0-2.el7.x86_64.rpm 8.3.0 x86_64 CentOS SCLo RH Testing
rh-nodejs8-nodejs - - -

Requires

Name Value
ca-certificates -
libc.so.6(GLIBC_2.9)(64bit) -
libcrypto.so.10()(64bit) -
libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit) -
libcrypto.so.10(libcrypto.so.10)(64bit) -
libdl.so.2()(64bit) -
libdl.so.2(GLIBC_2.2.5)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_3.4)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libpthread.so.0(GLIBC_2.3.2)(64bit) -
libpthread.so.0(GLIBC_2.3.3)(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
libssl.so.10()(64bit) -
libssl.so.10(libssl.so.10)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.5)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.18)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -
libz.so.1()(64bit) -
rh-nodejs8-npm = 6.4.1-8.16.0.1.el7
rh-nodejs8-runtime -
rtld(GNU_HASH) -

Provides

Name Value
bundled(rh-nodejs8-c-ares) = 1.10.1
bundled(rh-nodejs8-http-parser) = 2.8.0
bundled(rh-nodejs8-libuv) = 1.23.2
bundled(rh-nodejs8-nghttp2) = 1.33.0
bundled(rh-nodejs8-v8) = 6.2.414.77
rh-nodejs8-nodejs = 8.16.0-1.el7
rh-nodejs8-nodejs(abi) = 8.16
rh-nodejs8-nodejs(abi8) = 8.16
rh-nodejs8-nodejs(engine) = 8.16.0
rh-nodejs8-nodejs(v8-abi) = 6.2
rh-nodejs8-nodejs(v8-abi6) = 6.2
rh-nodejs8-nodejs(x86-64) = 8.16.0-1.el7
rh-nodejs8-nodejs-punycode = 2.0.0
rh-nodejs8-npm(punycode) = 2.0.0
scl-package(rh-nodejs8) -

Conflicts

Name Value
node <= 0.3.2-12

Download

Type URL
Mirror buildlogs.centos.org
Binary Package rh-nodejs8-nodejs-8.16.0-1.el7.x86_64.rpm
Source Package rh-nodejs8-nodejs-8.16.0-1.el7.src.rpm

Install Howto

  1. Install CentOS SCLo RH Testing repository:
    yum install centos-release-scl-rh
  2. Install rh-nodejs8-nodejs rpm package:
    # yum --enablerepo=centos-sclo-rh-testing install rh-nodejs8-nodejs

Files

Path
/opt/rh/rh-nodejs8/root/usr/bin/node
/opt/rh/rh-nodejs8/root/usr/lib/dtrace/node.d
/opt/rh/rh-nodejs8/root/usr/lib/node_modules/
/opt/rh/rh-nodejs8/root/usr/share/doc/rh-nodejs8-nodejs-6.4.1/
/opt/rh/rh-nodejs8/root/usr/share/doc/rh-nodejs8-nodejs-8.16.0/AUTHORS
/opt/rh/rh-nodejs8/root/usr/share/doc/rh-nodejs8-nodejs-8.16.0/CHANGELOG.md
/opt/rh/rh-nodejs8/root/usr/share/doc/rh-nodejs8-nodejs-8.16.0/COLLABORATOR_GUIDE.md
/opt/rh/rh-nodejs8/root/usr/share/doc/rh-nodejs8-nodejs-8.16.0/GOVERNANCE.md
/opt/rh/rh-nodejs8/root/usr/share/doc/rh-nodejs8-nodejs-8.16.0/README.md
/opt/rh/rh-nodejs8/root/usr/share/licenses/rh-nodejs8-nodejs-8.16.0/LICENSE
/opt/rh/rh-nodejs8/root/usr/share/man/man1/node.1.gz
/opt/rh/rh-nodejs8/root/usr/share/node/
/opt/rh/rh-nodejs8/root/usr/share/systemtap/
/opt/rh/rh-nodejs8/root/usr/share/systemtap/tapset/node.stp
/usr/lib/rpm/nodejs_native.req
/usr/lib/rpm/fileattrs/nodejs_native.attr

Changelog

2019-06-18 - Zuzana Svetlikova <zsvetlik@redhat.com> - 8.16.0-1
- Resolves: RHBZ#1710734, #1711309, #1669443, #1668704, #1666338, #1665986
- Rebase to 8.16.0
2018-09-06 - Jan Staněk <jstanek@redhat.com> - 8.11.4-1
- Rebase to 8.11.4 LTS version for security reasons
- Resolves: RHBZ#1621761 RHBZ#161762
2018-02-06 - Zuzana Svetlikova <zsvtelik@redhat.com> - 8.9.4-2
- Resolves: RHBZ#1513560 #1542079
- fix outdated minizlib dependency in npm node_modules tree
- https://github.com/nodejs/node/pull/16509
2018-01-15 - Zuzana Svetlikova <zsvetlik@redhat.com> - 8.9.4-1
- Resolves: RHBZ#1513560
- rebase to LTS
2017-09-27 - Zuzana Svetlikova <zsvetlik@redhat.com> - 8.6.0-1
- Resolves: RHBZ#1490389
- Update, v8.5.0 contains a CVE
2017-09-21 - Zuzana Svetlikova <zsvetlik@redhat.com> - 8.5.0-1
- Resolves: RHBZ#1490389
- Update to latest version, bundle nghttp2
2017-08-10 - Zuzana Svetlikova <zsvetlik@redhat.com> - 8.3.0-2
- Handle failing test in better manner
- run more tests
2017-08-10 - Zuzana Svetlikova <zsvetlik@redhat.com> - 8.3.0-1
- Update to 8.3.0
- update V8 to 6.0
- update libuv to 1.13.1
- add bundled provides for npm modules
- enable aarch64 builds
2017-07-24 - Zuzana Svetlikova <zsvetlik@redhat.com> - 8.2.1-1
- Update to 8.2.1
- update npm to 5.3.0, add npx command
2017-07-12 - Zuzana Svetlikova <zsvetlik@redhat.com> - 8.1.4-1
- Security update (https://nodejs.org/en/blog/vulnerability/july-2017-security-releases/)
- Fixes RHBZ#1463132 and RHBZ#1469706

See Also

Package Description
rh-nodejs8-nodejs-abbrev-1.0.9-2.el7.noarch.rpm Abbreviation calculator for Node.js
rh-nodejs8-nodejs-ansi-green-0.1.1-5.el7.noarch.rpm The color green, in ansi
rh-nodejs8-nodejs-ansi-regex-2.0.0-6.el7.noarch.rpm Regular expression for matching ANSI escape codes
rh-nodejs8-nodejs-ansi-styles-2.2.1-2.el7.noarch.rpm ANSI escape codes for colorizing strings in the terminal
rh-nodejs8-nodejs-ansi-wrap-0.1.0-6.el7.noarch.rpm Create ansi colors by passing the open and close codes
rh-nodejs8-nodejs-anymatch-1.3.0-6.el7.noarch.rpm Matches strings against anything
rh-nodejs8-nodejs-arr-diff-2.0.0-6.el7.noarch.rpm Returns an array with only the unique values from the first array
rh-nodejs8-nodejs-arr-flatten-1.0.1-6.el7.noarch.rpm Recursively flatten an array or arrays
rh-nodejs8-nodejs-array-unique-0.2.1-6.el7.noarch.rpm Return an array free of duplicate values
rh-nodejs8-nodejs-arrify-1.0.0-10.el7.noarch.rpm Convert a value to an array
rh-nodejs8-nodejs-async-each-1.0.0-6.el7.noarch.rpm Ultra-simple async parallel forEach function for JavaScript
rh-nodejs8-nodejs-balanced-match-0.4.2-2.el7.noarch.rpm Match balanced character pairs, like "{" and "}"
rh-nodejs8-nodejs-binary-extensions-1.7.0-2.el7.noarch.rpm List of binary file extensions
rh-nodejs8-nodejs-brace-expansion-1.1.5-2.el7.noarch.rpm Brace expansion as known from sh/bash
rh-nodejs8-nodejs-braces-1.8.2-9.el7.noarch.rpm Fastest brace expansion for node.js
Advertisement
Advertisement