httpd24-mod_auth_mellon-0.14.0-3.el7.x86_64.rpm


Advertisement

Description

httpd24-mod_auth_mellon - A SAML 2.0 authentication module for the Apache Httpd Server

Property Value
Distribution CentOS 7
Repository CentOS SCLo RH Testing x86_64
Package filename httpd24-mod_auth_mellon-0.14.0-3.el7.x86_64.rpm
Package name httpd24-mod_auth_mellon
Package version 0.14.0
Package release 3.el7
Package architecture x86_64
Package type rpm
Category System Environment/Daemons
Homepage https://github.com/UNINETT/mod_auth_mellon
License GPLv2+
Maintainer -
Download size 1.28 MB
Installed size 2.44 MB
The mod_auth_mellon module is an authentication service that implements the
SAML 2.0 federation protocol. It grants access based on the attributes
received in assertions generated by a IdP server.

Alternatives

Package Version Architecture Repository
httpd24-mod_auth_mellon-0.14.0-3.el7.x86_64.rpm 0.14.0 x86_64 CentOS SCLo RH
httpd24-mod_auth_mellon-0.13.1-2.el7.1.x86_64.rpm 0.13.1 x86_64 CentOS SCLo RH
httpd24-mod_auth_mellon-0.13.1-2.el7.1.x86_64.rpm 0.13.1 x86_64 CentOS SCLo RH Testing
httpd24-mod_auth_mellon-0.13.1-2.el7.x86_64.rpm 0.13.1 x86_64 CentOS SCLo RH Testing
httpd24-mod_auth_mellon-0.13.1-2.el7.x86_64.rpm 0.13.1 x86_64 CentOS SCLo RH
httpd24-mod_auth_mellon - - -

Requires

Name Value
/usr/bin/env -
httpd24-httpd-mmn = 20120211x8664
httpd24-runtime -
lasso >= 2.5.1
libc.so.6(GLIBC_2.4)(64bit) -
libcrypto.so.10()(64bit) -
libcrypto.so.10(libcrypto.so.10)(64bit) -
libcurl.so.4()(64bit) -
libglib-2.0.so.0()(64bit) -
liblasso.so.3()(64bit) -
libssl.so.10()(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
config(httpd24-mod_auth_mellon) = 0.14.0-3.el7
httpd24-mod_auth_mellon = 0.14.0-3.el7
httpd24-mod_auth_mellon(x86-64) = 0.14.0-3.el7
scl-package(httpd24) -

Download

Type URL
Mirror buildlogs.centos.org
Binary Package httpd24-mod_auth_mellon-0.14.0-3.el7.x86_64.rpm
Source Package httpd24-mod_auth_mellon-0.14.0-3.el7.src.rpm

Install Howto

  1. Install CentOS SCLo RH Testing repository:
    yum install centos-release-scl-rh
  2. Install httpd24-mod_auth_mellon rpm package:
    # yum --enablerepo=centos-sclo-rh-testing install httpd24-mod_auth_mellon

Files

Path
/opt/rh/httpd24/root/etc/httpd/conf.d/auth_mellon.conf
/opt/rh/httpd24/root/etc/httpd/conf.modules.d/10-auth_mellon.conf
/opt/rh/httpd24/root/usr/lib64/httpd/modules/mod_auth_mellon.so
/opt/rh/httpd24/root/usr/libexec/mod_auth_mellon/mellon_create_metadata.sh
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/ECP.rst
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/NEWS
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/README.md
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/README.redhat.rst
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/user_guide/Guardfile
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/user_guide/README
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/user_guide/mellon_user_guide.adoc
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/user_guide/mellon_user_guide.html
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/user_guide/images/chrome_SAML_Chrome_Panel.png
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/user_guide/images/chrome_SAML_Chrome_Panel.svg
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/user_guide/images/saml-tracer.png
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/user_guide/images/saml-tracer.svg
/opt/rh/httpd24/root/usr/share/doc/httpd24-mod_auth_mellon-0.14.0/user_guide/images/saml-web-sso.svg
/opt/rh/httpd24/root/usr/share/licenses/httpd24-mod_auth_mellon-0.14.0/COPYING
/opt/rh/httpd24/root/var/run/httpd24-mod_auth_mellon/
/usr/lib/tmpfiles.d/httpd24-mod_auth_mellon.conf

Changelog

2019-04-03 - Lubos Uhliarik <luhliari@redhat.com> - 0.14.0-3
- Resolves: #1692459 - CVE-2019-3878 httpd24-mod_auth_mellon: mod_auth_mellon:
authentication bypass in ECP flow
2019-01-09 - Lubos Uhliarik <luhliari@redhat.com> - 0.14.0-2
- Resolves: #1568475 - mod_auth_mellon: tmpfiles.d drop-in wrong location
- Resolves: #1568837 - ownership test fail
2019-01-08 - Lubos Uhliarik <luhliari@redhat.com> - 0.14.0-1
- new version 0.14.0 (#1582039)
2018-01-05 - LuboŇ° Uhliarik <luhliari@redhat.com> - 0.13.1-2
- Resolves: #1514391 - [RFE] Include mod_auth_mellon for RHSCL httpd24
- Merged with RHEL-7.5 branch, SCLized spec
2017-10-20 - John Dennis <jdennis@redhat.com> - 0.13.1-1
- Resolves: rhbz#1481332 Upgrade to current upstream 0.13.1
- Adds the following upstream bug fixes on top of 0.13.1:
* ee97812 Add Mellon User Guide
* daa5d1e If no IdP's are defined explicitly log that fact
* c291232 Make MellonUser case-insensitive.
* 2c2e19d Fix incorrect error check for many `lasso_*`-functions.
* 5c5ed1d Fix segmentation fault with POST field without a value.
* 4c924d9 Fix some log message typos
* 93faba4 Update log msg for Invalid Destination and Invalid Audience to
show both the expected and received values.
- Add new mellon user guide to installed docdir
2017-01-30 - John Dennis <jdennis@redhat.com> - 0.11.0-4
- Resolves: rhbz#1414021 - Incorrect Content-Type header in ECP PAOS
Rebuilding due to missing comment in Changelog
2017-01-30 - John Dennis <jdennis@redhat.com> - 0.11.0-3
- Resolves: rhbz#1414021 - Incorrect Content-Type header in ECP PAOS
2016-04-08 - John Dennis <jdennis@redhat.com> - 0.11.0-2
- Resolves: bug #1296286
mod_auth_mellon emits CRITICAL warning message in Apache log when doing ECP
- Resolves: bug #1324536
Installing mod_auth_mellon causes working Kerberos authentication
to start failing
- Add ECP.rst documentation file that was erroneously omitted
2015-09-18 - John Dennis <jdennis@redhat.com> - 0.11.0-1
- Upgrade to upstream 0.11.0 release.
- Includes ECP support, see NEWS for all changes.
- Update mellon_create_metadata.sh to match internally generated metadata,
includes AssertionConsumerService for postResponse, artifactResponse &
paosResponse.
- Add lasso 2.5.0 version dependency
- Resolves: #1205345
2015-08-24 - John Dennis <jdennis@redhat.com> - 0.10.0-3
- Rebase to upstream 0.10.0 release
- Apply upstream commits post 0.10.0 release
- Apply revised ECP pending patches,
fix patch to pickup change in configure script that causes
HAVE_ECP to be defined
- Resolves: #1205345

See Also

Package Description
httpd24-mod_auth_mellon-diagnostics-0.14.0-3.el7.x86_64.rpm Build of mod_auth_mellon with diagnostic logging
httpd24-mod_ldap-2.4.12-7.el7.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.18-10.el7.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.18-11.el7.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.25-8.el7.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.25-9.el7.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.27-8.el7.1.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.27-8.el7.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.34-15.el7.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.34-7.el7.1.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.34-7.el7.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_ldap-2.4.34-8.el7.1.x86_64.rpm LDAP authentication modules for the Apache HTTP Server
httpd24-mod_md-2.4.34-15.el7.x86_64.rpm Certificate provisioning using ACME for the Apache HTTP Server
httpd24-mod_md-2.4.34-7.el7.1.x86_64.rpm Certificate provisioning using ACME for the Apache HTTP Server
httpd24-mod_md-2.4.34-7.el7.x86_64.rpm Certificate provisioning using ACME for the Apache HTTP Server
Advertisement
Advertisement