php-symfony3-class-loader-3.4.30-1.el6.remi.noarch.rpm


Advertisement

Description

php-symfony3-class-loader - Symfony ClassLoader Component (version 3)

Property Value
Distribution CentOS 6
Repository Les RPM de Remi i386
Package filename php-symfony3-class-loader-3.4.30-1.el6.remi.noarch.rpm
Package name php-symfony3-class-loader
Package version 3.4.30
Package release 1.el6.remi
Package architecture noarch
Package type rpm
Homepage http://symfony.com/doc/3.4/components/class_loader.html
License MIT and CC-BY-SA
Maintainer -
Download size 20.01 KB
Installed size 44.92 KB
The ClassLoader Component loads your project classes automatically if they
follow some standard PHP conventions.
Whenever you use an undefined class, PHP uses the autoloading mechanism
to delegate the loading of a file defining the class. Symfony provides
a "universal" autoloader, which is able to load classes from files that
implement one of the following conventions:
* The technical interoperability standards [1] for PHP 5.3 namespaces
and class names
* The PEAR naming convention [2] for classes
If your classes and the third-party libraries you use for your project follow
these standards, the Symfony autoloader is the only autoloader you will ever
need.
Autoloader: /usr/share/php/Symfony3/Component/ClassLoader/autoload.php
[1] http://symfony.com/PSR0
[2] http://pear.php.net/manual/en/standards.php

Alternatives

Package Version Architecture Repository
php-symfony3-class-loader-3.4.30-1.el6.remi.noarch.rpm 3.4.30 noarch Les RPM de Remi
php-symfony3-class-loader-3.4.29-1.el6.remi.noarch.rpm 3.4.29 noarch Les RPM de Remi
php-symfony3-class-loader-3.4.29-1.el6.remi.noarch.rpm 3.4.29 noarch Les RPM de Remi
php-symfony3-class-loader - - -

Requires

Name Value
php-hash -
php-pcre -
php-reflection -
php-spl -
php-symfony-class-loader -
php-symfony3-common = 3.4.30-1.el6.remi
php-tokenizer -

Provides

Name Value
php-composer(symfony/class-loader) = 3.4.30
php-symfony3-class-loader = 3.4.30-1.el6.remi

Download

Type URL
Mirror rpms.remirepo.net
Binary Package php-symfony3-class-loader-3.4.30-1.el6.remi.noarch.rpm
Source Package php-symfony3-3.4.30-1.el6.remi.src.rpm

Install Howto

  1. Download latest remi-release rpm from
    http://rpms.remirepo.net/enterprise/6/remi/i386/
  2. Install remi-release rpm:
    # rpm -Uvh remi-release*rpm
  3. Install php-symfony3-class-loader rpm package:
    # yum --enablerepo=remi install php-symfony3-class-loader

Files

Path
/usr/share/doc/php-symfony3-class-loader-3.4.30/CHANGELOG.md
/usr/share/doc/php-symfony3-class-loader-3.4.30/LICENSE
/usr/share/doc/php-symfony3-class-loader-3.4.30/README.md
/usr/share/doc/php-symfony3-class-loader-3.4.30/composer.json
/usr/share/php/Symfony3/Component/ClassLoader/ApcClassLoader.php
/usr/share/php/Symfony3/Component/ClassLoader/ClassCollectionLoader.php
/usr/share/php/Symfony3/Component/ClassLoader/ClassLoader.php
/usr/share/php/Symfony3/Component/ClassLoader/ClassMapGenerator.php
/usr/share/php/Symfony3/Component/ClassLoader/MapClassLoader.php
/usr/share/php/Symfony3/Component/ClassLoader/Psr4ClassLoader.php
/usr/share/php/Symfony3/Component/ClassLoader/WinCacheClassLoader.php
/usr/share/php/Symfony3/Component/ClassLoader/XcacheClassLoader.php
/usr/share/php/Symfony3/Component/ClassLoader/autoload.php

Changelog

2019-08-20 - Remi Collet <remi@remirepo.net> - 3.4.30-1
- update to 3.4.30
2019-06-27 - Remi Collet <remi@remirepo.net> - 3.4.29-1
- update to 3.4.29
2019-06-04 - Remi Collet <remi@remirepo.net> - 3.4.28-1
- update to 3.4.28

See Also

Package Description
php-symfony3-common-3.4.29-1.el6.remi.noarch.rpm Symfony common (version 3)
php-symfony3-common-3.4.30-1.el6.remi.noarch.rpm Symfony common (version 3)
php-symfony3-config-3.4.29-1.el6.remi.noarch.rpm Symfony Config Component (version 3)
php-symfony3-config-3.4.30-1.el6.remi.noarch.rpm Symfony Config Component (version 3)
php-symfony3-console-3.4.29-1.el6.remi.noarch.rpm Symfony Console Component (version 3)
php-symfony3-console-3.4.30-1.el6.remi.noarch.rpm Symfony Console Component (version 3)
php-symfony3-css-selector-3.4.29-1.el6.remi.noarch.rpm Symfony CssSelector Component (version 3)
php-symfony3-css-selector-3.4.30-1.el6.remi.noarch.rpm Symfony CssSelector Component (version 3)
php-symfony3-dependency-injection-3.4.29-1.el6.remi.noarch.rpm Symfony DependencyInjection Component (version 3)
php-symfony3-dependency-injection-3.4.30-1.el6.remi.noarch.rpm Symfony DependencyInjection Component (version 3)
php-symfony3-doctrine-bridge-3.4.29-1.el6.remi.noarch.rpm Symfony Doctrine Bridge (version 3)
php-symfony3-doctrine-bridge-3.4.30-1.el6.remi.noarch.rpm Symfony Doctrine Bridge (version 3)
php-symfony3-dom-crawler-3.4.29-1.el6.remi.noarch.rpm Symfony DomCrawler Component (version 3)
php-symfony3-dom-crawler-3.4.30-1.el6.remi.noarch.rpm Symfony DomCrawler Component (version 3)
php-symfony3-dotenv-3.4.29-1.el6.remi.noarch.rpm Registers environment variables from a .env file (version 3)
Advertisement
Advertisement