rubygem-puma-2.4.0-1.sdl6.x86_64.rpm


Advertisement

Description

rubygem-puma - Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack applications

Property Value
Distribution CentOS 6
Repository PUIAS Unsupported x86_64
Package filename rubygem-puma-2.4.0-1.sdl6.x86_64.rpm
Package name rubygem-puma
Package version 2.4.0
Package release 1.sdl6
Package architecture x86_64
Package type rpm
Category Development/Languages
Homepage http://puma.io
License BSD
Maintainer -
Download size 53.16 KB
Installed size 151.07 KB
Puma is a simple, fast, threaded, and highly concurrent HTTP 1.1 server for
Ruby/Rack applications. Puma is intended for use in both development and
production environments. In order to get the best throughput, it is highly
recommended that you use a  Ruby implementation with real threads like
Rubinius or JRuby.

Alternatives

Package Version Architecture Repository
rubygem-puma-2.4.0-1.sdl6.i686.rpm 2.4.0 i686 PUIAS Unsupported
rubygem-puma - - -

Requires

Name Value
/bin/bash -
/usr/bin/env -
/usr/bin/ruby -
libc.so.6(GLIBC_2.4)(64bit) -
libcrypt.so.1()(64bit) -
libcrypto.so.10()(64bit) -
libdl.so.2()(64bit) -
libm.so.6()(64bit) -
libpthread.so.0()(64bit) -
librt.so.1()(64bit) -
libruby.so.1.8()(64bit) -
libssl.so.10()(64bit) -
rtld(GNU_HASH) -
ruby(rubygems) -
rubygem(rack) >= 1.1
rubygem(rack) < 2.0

Provides

Name Value
puma_http11.so()(64bit) -
rubygem(puma) = 2.4.0
rubygem-puma = 2.4.0-1.sdl6
rubygem-puma(x86-64) = 2.4.0-1.sdl6

Download

Type URL
Mirror springdale.math.ias.edu
Binary Package rubygem-puma-2.4.0-1.sdl6.x86_64.rpm
Source Package rubygem-puma-2.4.0-1.sdl6.src.rpm

Install Howto

  1. Download latest puias-unsupported rpm from
    http://springdale.math.ias.edu/data/puias/unsupported/6/x86_64/
  2. Install puias-unsupported rpm:
    # rpm -Uvh puias-unsupported*rpm
  3. Install rubygem-puma rpm package:
    # yum install rubygem-puma

Files

Path
/usr/bin/puma
/usr/bin/pumactl
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/Gemfile
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/Rakefile
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/puma.gemspec
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/bin/puma
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/bin/pumactl
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/accept_nonblock.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/binder.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/capistrano.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/cli.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/client.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/cluster.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/compat.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/configuration.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/const.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/control_cli.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/daemon_ext.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/delegation.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/detect.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/events.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/io_buffer.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/java_io_buffer.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/jruby_restart.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/minissl.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/null_io.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/rack_default.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/rack_patch.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/reactor.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/runner.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/server.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/single.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/thread_pool.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/util.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/puma/app/status.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/rack/
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/lib/rack/handler/puma.rb
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/tools/
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/tools/jungle/
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/tools/jungle/init.d/puma
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/tools/jungle/init.d/run-puma
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/tools/jungle/upstart/puma-manager.conf
/usr/lib/ruby/gems/1.8/gems/puma-2.4.0/tools/jungle/upstart/puma.conf
/usr/lib/ruby/gems/1.8/specifications/puma-2.4.0.gemspec
/usr/lib64/ruby/site_ruby/1.8/x86_64-linux/puma/puma_http11.so

Changelog

2013-07-24 - Josko Plazonic - 2.4.0-1
- Initial package

See Also

Package Description
rubygem-puma-doc-2.4.0-1.sdl6.noarch.rpm Documentation for rubygem-puma
rubygem-rack-1.3.0-1.puias6.noarch.rpm Common API for connecting web frameworks, web servers and layers of software
rubygem-rack-protection-1.1.4-2.puias6.noarch.rpm You should use protection!
rubygem-rack-protection-doc-1.1.4-2.puias6.noarch.rpm Documentation for rubygem-rack-protection
rubygem-rack-test-0.5.4-1.puias6.noarch.rpm Simple testing API built on Rack
rubygem-rails-2.3.15-1.puias6.noarch.rpm Web-application framework
rubygem-rake-compiler-0.7.1-1.puias6.noarch.rpm Rake-based Ruby C Extension task generator
rubygem-rake-compiler-doc-0.7.1-1.puias6.noarch.rpm Documentation for rubygem-rake-compiler
rubygem-rdiscount-1.6.8-1.sdl6.x86_64.rpm Discount (For Ruby). A Fast Implementation of Gruber's Markdown in C
rubygem-redcarpet-2.1.1-5.puias6.x86_64.rpm A fast, safe and extensible Markdown to (X)HTML parser
rubygem-redcarpet-doc-2.1.1-5.puias6.x86_64.rpm Documentation for rubygem-redcarpet
rubygem-regin-0.3.8-3.puias6.noarch.rpm Ruby Regexp Introspection
rubygem-regin-doc-0.3.8-3.puias6.noarch.rpm Documentation for rubygem-regin
rubygem-rest-client-1.6.1-2.puias6.noarch.rpm Simple REST client for Ruby
rubygem-rgen-0.6.6-2.sdl6.noarch.rpm Ruby Modelling and Generator Framework
Advertisement
Advertisement