mpi-selector-1.0.2-1.puias6.noarch.rpm


Advertisement

Description

mpi-selector - Provides site-wide and per-user MPI implementation selection

Property Value
Distribution CentOS 6
Repository PUIAS Computational x86_64
Package name mpi-selector
Package version 1.0.2
Package release 1.puias6
Package architecture noarch
Package type rpm
Installed size 48.64 KB
Download size 25.21 KB
Official Mirror springdale.math.ias.edu
A simple tool that allows system administrators to set a site-wide
default for which MPI implementation is to be used, but also allow
users to set their own default MPI implementation, thereby overriding
the site-wide default.
The default can be changed easily via the mpi-selector command --
editing of shell startup files is not required.

Alternatives

Package Version Architecture Repository
mpi-selector-1.0.2-1.puias6.noarch.rpm 1.0.2 noarch PUIAS Computational
mpi-selector - - -

Requires

Name Value
/usr/bin/env -
perl(File::Copy) -
perl(Getopt::Long) -
perl(Text::Wrap) -
perl(strict) -

Provides

Name Value
mpi-selector = 1.0.2-1.puias6

Download

Type URL
Binary Package mpi-selector-1.0.2-1.puias6.noarch.rpm
Source Package mpi-selector-1.0.2-1.puias6.src.rpm

Install Howto

  1. Download latest puias-computational rpm from
    http://springdale.math.ias.edu/data/puias/computational/6/x86_64/
  2. Install puias-computational rpm:
    # rpm -Uvh puias-computational*rpm
  3. Install mpi-selector rpm package:
    # yum install mpi-selector

Files

Path
/etc/profile.d/mpi-selector.csh
/etc/profile.d/mpi-selector.sh
/usr/bin/mpi-selector
/usr/bin/mpi-selector-menu
/usr/share/doc/mpi-selector-1.0.2/LICENSE
/usr/share/doc/mpi-selector-1.0.2/README
/usr/share/man/man1/mpi-selector-menu.1.gz
/usr/share/man/man1/mpi-selector.1.gz
/var/lib/mpi-selector/

Changelog

2009-04-17 - Doug Ledford <dledford@redhat.com> - 1.0.2-1
- Update to ofed 1.4.1-rc3 version
- Related: bz459652
2008-09-17 - Doug Ledford <dledford@redhat.com> - 1.0.1-1
- Update to latest upstream version
- Resolves: bz462585
2008-04-02 - Doug Ledford <dledford@redhat.com> - 1.0.0-2
- Make the package a noarch package
2008-04-01 - Doug Ledford <dledford@redhat.com> - 1.0.0-1
- Initial import into Red Hat repo management
2007-02-14 - Jeff Squyres <jsquyres@cisco.com>
- First version

See Also

Package Description
mpi4py-common-1.3.1-2.sdl6.noarch.rpm Common files for mpi4py packages
mpi4py-docs-1.3.1-2.sdl6.noarch.rpm Documentation for mpi4py
mpi4py-mpt-gcc-1.3.1-2.sdl6.x86_64.rpm Python bindings of MPI, MPT gcc
mpi4py-openmpi010605-gcc-1.3.1-2.sdl6.x86_64.rpm Python bindings of MPI, Open MPI version 1.6.5 gcc
mpi4py27-common-1.3.1-3.sdl6.noarch.rpm Common files for mpi4py packages
mpi4py27-docs-1.3.1-3.sdl6.noarch.rpm Documentation for mpi4py27
mpi4py27-mpt-gcc-1.3.1-3.sdl6.x86_64.rpm Python bindings of MPI, MPT gcc
mpi4py27-openmpi010603-gcc-1.3.1-3.sdl6.x86_64.rpm Python bindings of MPI, Open MPI version 1.6.3 gcc
mpi4py27-openmpi010603-intel121-1.3.1-3.sdl6.x86_64.rpm Python bindings of MPI, Open MPI version 1.6.3 intel-12.1
mpi4py27-openmpi010603-intel130-1.3.1-3.sdl6.x86_64.rpm Python bindings of MPI, Open MPI version 1.6.3 intel-13.0
mpi4py27-openmpi010605-gcc-1.3.1-3.sdl6.x86_64.rpm Python bindings of MPI, Open MPI version 1.6.5 gcc
mpiexec-0.84-1.puias6.x86_64.rpm MPI job launcher that uses the PBS task interface directly
mpir-1.3.1-4.puias6.i686.rpm A library for arbitrary precision arithmetic
mpir-1.3.1-4.puias6.x86_64.rpm A library for arbitrary precision arithmetic
mpir-devel-1.3.1-4.puias6.i686.rpm Development files for mpir
Advertisement
Advertisement