babel27-0.9.6-2.sdl6.1.noarch.rpm


Advertisement

Description

babel27 - Tools for internationalizing Python applications

Property Value
Distribution CentOS 6
Repository PUIAS Computational x86_64
Package name babel27
Package version 0.9.6
Package release 2.sdl6.1
Package architecture noarch
Package type rpm
Installed size 17.03 KB
Download size 14.10 KB
Official Mirror springdale.math.ias.edu
Babel is composed of two major parts:
* tools to build and work with gettext message catalogs
* a Python interface to the CLDR (Common Locale Data Repository),
providing access to various locale display names, localized number
and date formatting, etc.

Alternatives

Package Version Architecture Repository
babel27-0.9.6-2.sdl6.1.noarch.rpm 0.9.6 noarch PUIAS Computational
babel27 - - -

Requires

Name Value
/usr/bin/python2.7 -
python27-babel -
python27-setuptools -

Provides

Name Value
babel27 = 0.9.6-2.sdl6.1

Download

Type URL
Binary Package babel27-0.9.6-2.sdl6.1.noarch.rpm
Source Package babel27-0.9.6-2.sdl6.1.src.rpm

Install Howto

  1. Download the latest puias-computational rpm from
    http://springdale.math.ias.edu/data/puias/computational/6/x86_64/
  2. Install puias-computational rpm:
    # rpm -Uvh puias-computational*rpm
  3. Install babel27 rpm package:
    # yum install babel27

Files

Path
/usr/bin/pybabel2.7
/usr/lib/python2.7/bin/pybabel
/usr/share/doc/babel27-0.9.6/COPYING
/usr/share/doc/babel27-0.9.6/ChangeLog
/usr/share/doc/babel27-0.9.6/README.txt
/usr/share/doc/babel27-0.9.6/cmdline.txt

Changelog

2012-01-12 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.6-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
2011-06-07 - Nils Philippsen <nils@redhat.com> - 0.9.6-1
- version 0.9.6:
* Backport r493-494: documentation typo fixes.
* Make the CLDR import script work with Python 2.7.
* Fix various typos.
* Fixed Python 2.3 compatibility (ticket #146, #233).
* Sort output of list-locales.
* Make the POT-Creation-Date of the catalog being updated equal to
POT-Creation-Date of the template used to update (ticket #148).
* Use a more explicit error message if no option or argument (command) is
passed to pybabel (ticket #81).
* Keep the PO-Revision-Date if it is not the default value (ticket #148).
* Make --no-wrap work by reworking --width's default and mimic xgettext's
behaviour of always wrapping comments (ticket #145).
* Fixed negative offset handling of Catalog._set_mime_headers (ticket #165).
* Add --project and --version options for commandline (ticket #173).
* Add a __ne__() method to the Local class.
* Explicitly sort instead of using sorted() and don't assume ordering
(Python 2.3 and Jython compatibility).
* Removed ValueError raising for string formatting message checkers if the
string does not contain any string formattings (ticket #150).
* Fix Serbian plural forms (ticket #213).
* Small speed improvement in format_date() (ticket #216).
* Fix number formatting for locales where CLDR specifies alt or draft
items (ticket #217)
* Fix bad check in format_time (ticket #257, reported with patch and tests by
jomae)
* Fix so frontend.CommandLineInterface.run does not accumulate logging
handlers (#227, reported with initial patch by dfraser)
* Fix exception if environment contains an invalid locale setting (#200)
- install python2 rather than python3 executable (#710880)
2011-02-07 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.5-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
2010-08-26 - Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.5-3
- Add python3 subpackage
2010-07-21 - David Malcolm <dmalcolm@redhat.com> - 0.9.5-2
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
2010-04-07 - Jeffrey C. Ollie <jeff@ocjtech.us> - 0.9.5-1
- This release contains a small number of bugfixes over the 0.9.4
- release.
-
- What's New:
- -----------
- * Fixed the case where messages containing square brackets would break
-  with an unpack error
- * Fuzzy matching regarding plurals should *NOT* be checked against
-  len(message.id) because this is always 2, instead, it's should be
-  checked against catalog.num_plurals (ticket #212).
2009-07-24 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-03-28 - Robert Scheck <robert@fedoraproject.org> - 0.9.4-4
- Added missing requires to python-setuptools for pkg_resources
2009-02-23 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.4-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
2008-11-29 - Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.9.4-2
- Rebuild for Python 2.6

See Also

Package Description
bazel-0.4.4-3.sdl6.x86_64.rpm Bazel is Google's own build tool
bbcp-15.02.03.01.1-1.sdl6.1.x86_64.rpm point-to-point network file copy application
bison3-3.0.2-3.sdl6.x86_64.rpm A GNU general-purpose parser generator
bison3-devel-3.0.2-3.sdl6.x86_64.rpm -ly library for development using Bison-generated parsers
bison3-runtime-3.0.2-3.sdl6.x86_64.rpm Runtime support files used by Bison-generated parsers
blacs-common-1.1-52.sdl6.x86_64.rpm Common files for blacs
blacs-mpich-1.1-52.sdl6.x86_64.rpm BLACS libraries compiled against mpich
blacs-mpich-devel-1.1-52.sdl6.x86_64.rpm Development libraries for blacs (mpich)
blacs-mpich-static-1.1-52.sdl6.x86_64.rpm Static libraries for blacs (mpich)
blacs-mpich2-1.1-39.puias6.1.x86_64.rpm BLACS libraries compiled against mpich2
blacs-mpich2-devel-1.1-39.puias6.1.x86_64.rpm Development libraries for blacs (mpich2)
blacs-mpich2-static-1.1-39.puias6.1.x86_64.rpm Static libraries for blacs (mpich2)
blacs-openmpi-1.1-52.sdl6.x86_64.rpm BLACS libraries compiled against openmpi
blacs-openmpi-devel-1.1-52.sdl6.x86_64.rpm Development libraries for blacs (openmpi)
blacs-openmpi-static-1.1-52.sdl6.x86_64.rpm Static libraries for blacs (openmpi)
Advertisement
Advertisement