sip27-4.9.3-1.1.sdl6.1.i686.rpm


Advertisement

Description

sip27 - SIP - Python/C++ Bindings Generator

Property Value
Distribution CentOS 6
Repository PUIAS Computational i386
Package name sip27
Package version 4.9.3
Package release 1.1.sdl6.1
Package architecture i686
Package type rpm
Installed size 459.62 KB
Download size 145.80 KB
Official Mirror springdale.math.ias.edu
SIP is a tool for generating bindings for C++ classes so that they can be
accessed as normal Python classes. SIP takes many of its ideas from SWIG but,
because it is specifically designed for C++ and Python, is able to generate
tighter bindings. SIP is so called because it is a small SWIG.
SIP was originally designed to generate Python bindings for KDE and so has
explicit support for the signal slot mechanism used by the Qt/KDE class
libraries. However, SIP can be used to generate Python bindings for any C++
class library.

Alternatives

Package Version Architecture Repository
sip27-4.9.3-1.1.sdl6.1.x86_64.rpm 4.9.3 x86_64 PUIAS Computational
sip27 - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libm.so.6 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
python(abi) = 2.7
rtld(GNU_HASH) -

Provides

Name Value
sip-api(6) = 6.0
sip.so -
sip27 = 4.9.3-1.1.sdl6.1
sip27(x86-32) = 4.9.3-1.1.sdl6.1

Download

Type URL
Binary Package sip27-4.9.3-1.1.sdl6.1.i686.rpm
Source Package sip27-4.9.3-1.1.sdl6.1.src.rpm

Install Howto

  1. Download latest puias-computational rpm from
    http://springdale.math.ias.edu/data/puias/computational/6/i386/
  2. Install puias-computational rpm:
    # rpm -Uvh puias-computational*rpm
  3. Install sip27 rpm package:
    # yum install sip27

Files

Path
/usr/lib/python2.7/site-packages/sip.so
/usr/lib/python2.7/site-packages/sipconfig.py
/usr/lib/python2.7/site-packages/sipconfig.pyc
/usr/lib/python2.7/site-packages/sipconfig.pyo
/usr/lib/python2.7/site-packages/sipdistutils.py
/usr/lib/python2.7/site-packages/sipdistutils.pyc
/usr/lib/python2.7/site-packages/sipdistutils.pyo
/usr/share/doc/sip27-4.9.3/ChangeLog
/usr/share/doc/sip27-4.9.3/LICENSE
/usr/share/doc/sip27-4.9.3/LICENSE-GPL2.txt
/usr/share/doc/sip27-4.9.3/LICENSE-GPL3.txt
/usr/share/doc/sip27-4.9.3/NEWS
/usr/share/doc/sip27-4.9.3/README

Changelog

2009-11-23 - Rex Dieter <rdieter@fedoraproject.org> - 4.9.3-1
- sip-4.9.3
2009-11-20 - Rex Dieter <rdieter@fedoraproject.org> - 4.9.2-1
- sip-4.9.2
2009-11-16 - Rex Dieter <rdieter@fedoraproject.org> - 4.9.1-3
- move sip binary to -devel
2009-11-16 - Rex Dieter <rdieter@fedoraproject.org> - 4.9.1-2
- Provides: sip-api(%_sip_api_major) = %_sip_api
- devel: /etc/rpm/macros.sip helper
2009-10-23 - Rex Dieter <rdieter@fedoraproject.org> - 4.9.1-1
- sip-4.9.1
2009-10-15 - Rex Dieter <rdieter@fedoraproject.org> - 4.9.1-0.1.20091014
- sip-4.9.1-snapshot-20091014
2009-10-15 - Rex Dieter <rdieter@fedoraproject.org> - 4.9-1
- sip-4.9
- License: GPLv2 or GPLv3
2009-08-10 - Ville Skyttä <ville.skytta@iki.fi> - 4.8.2-2
- Convert specfile to UTF-8.
2009-07-28 - Rex Dieter <rdieter@fedoraproject.org> - 4.8.2-1
- sip-4.8.2
2009-07-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

See Also

Package Description
sip27-devel-4.9.3-1.1.sdl6.1.i686.rpm Files needed to generate Python bindings for any C++ class library
slimdata-2.6.4-1.puias6.i686.rpm Tools and library for reading and writing slim compressed data
slimdata-devel-2.6.4-1.puias6.i686.rpm Headers required when building programs against getdata
slurm-17.02.11-5.sdl6.i686.rpm Slurm Workload Manager
slurm-contribs-17.02.11-5.sdl6.i686.rpm Perl tool to print Slurm job state information
slurm-devel-17.02.11-5.sdl6.i686.rpm Development package for Slurm
slurm-drmaa-1.0.7-1.sdl6.4.i686.rpm DRMAA for Slurm
slurm-drmaa-devel-1.0.7-1.sdl6.4.i686.rpm Files needed for developing apps that link to drmaa
slurm-lua-17.02.11-5.sdl6.i686.rpm Slurm lua bindings
slurm-munge-17.02.11-5.sdl6.i686.rpm Slurm authentication and crypto implementation using Munge
slurm-openlava-17.02.11-5.sdl6.i686.rpm openlava/LSF wrappers for transitition from OpenLava/LSF to Slurm
slurm-pam_slurm-17.02.11-5.sdl6.i686.rpm PAM module for restricting access to compute nodes via Slurm
slurm-perlapi-17.02.11-5.sdl6.i686.rpm Perl API to Slurm
slurm-plugins-17.02.11-5.sdl6.i686.rpm Slurm plugins (loadable shared objects)
slurm-showq-0.1-1.sdl6.5.i686.rpm A "showq" style job summary utility for SLURM
Advertisement
Advertisement