rubygem-mustache-0.99.4-4.sdl6.noarch.rpm


Advertisement

Description

rubygem-mustache - Framework-agnostic way to render logic-free views

Property Value
Distribution CentOS 6
Repository PUIAS Computational i386
Package name rubygem-mustache
Package version 0.99.4
Package release 4.sdl6
Package architecture noarch
Package type rpm
Installed size 115.94 KB
Download size 39.39 KB
Official Mirror springdale.math.ias.edu
Think of Mustache as a replacement for your views.
Instead of views consisting of ERB or HAML with random helpers
and arbitrary logic, your views are broken into two parts:
a Ruby class and an HTML template.

Alternatives

Package Version Architecture Repository
rubygem-mustache-0.99.4-4.sdl6.noarch.rpm 0.99.4 noarch PUIAS Computational
rubygem-mustache-0.99.4-4.sdl6.noarch.rpm 0.99.4 noarch PUIAS Unsupported
rubygem-mustache-0.99.4-4.sdl6.noarch.rpm 0.99.4 noarch PUIAS Unsupported
rubygem-mustache-0.99.4-4.el6.noarch.rpm 0.99.4 noarch EPEL
rubygem-mustache-0.99.4-4.el6.noarch.rpm 0.99.4 noarch EPEL
rubygem-mustache - - -

Requires

Name Value
/usr/bin/env -
/usr/bin/ruby -
ruby -
ruby(abi) = 1.8
ruby(rubygems) -

Provides

Name Value
rubygem(mustache) = 0.99.4
rubygem-mustache = 0.99.4-4.sdl6

Download

Type URL
Binary Package rubygem-mustache-0.99.4-4.sdl6.noarch.rpm
Source Package rubygem-mustache-0.99.4-4.sdl6.src.rpm

Install Howto

  1. Download the latest puias-computational rpm from
    http://springdale.math.ias.edu/data/puias/computational/6/i386/
  2. Install puias-computational rpm:
    # rpm -Uvh puias-computational*rpm
  3. Install rubygem-mustache rpm package:
    # yum install rubygem-mustache

Files

Path
/usr/bin/mustache
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/LICENSE
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/README.md
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/bin/mustache
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/mustache.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/mustache/context.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/mustache/generator.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/mustache/parser.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/mustache/settings.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/mustache/sinatra.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/mustache/template.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/mustache/version.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/rack/
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/rack/bug/
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/rack/bug/panels/mustache_panel.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/rack/bug/panels/mustache_panel/mustache_extension.rb
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/lib/rack/bug/panels/mustache_panel/view.mustache
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/man/mustache.1
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/man/mustache.1.html
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/man/mustache.1.ron
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/man/mustache.5
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/man/mustache.5.html
/usr/lib/ruby/gems/1.8/gems/mustache-0.99.4/man/mustache.5.ron
/usr/lib/ruby/gems/1.8/specifications/mustache-0.99.4.gemspec
/usr/share/doc/rubygem-mustache-0.99.4/mustache.1.html
/usr/share/doc/rubygem-mustache-0.99.4/mustache.5.html
/usr/share/man/man1/mustache.1.gz
/usr/share/man/man5/mustache.5.gz

Changelog

2012-04-17 - Vít Ondruch <vondruch@redhat.com> - 0.99.4-4
- Compatibility fixes with older Fedoras and RHELs.
- Add missing .gemspec.
2012-01-20 - Vít Ondruch <vondruch@redhat.com> - 0.99.4-3
- Rebuilt for Ruby 1.9.3.
2012-01-14 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.99.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
2011-07-27 - Vít Ondruch <vondruch@redhat.com> - 0.99.4-1
- Update to Mustache 0.99.4
- Dropped optional Sinatra dependency.
- Removed deprecated %clean section.
- Added man pages.
2011-02-09 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.2-5
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
2010-11-10 - Jozef Zigmund <jzigmund@redhat.com> - 0.11.2-4
- Corrected ruby(abi) require
2010-11-08 - Jozef Zigmund <jzigmund@redhat.com> - 0.11.2-3
- Added README.md, LICENSE with macro doc
- Replaced macro {gemdir}/gems/{gemname}-{version}/ by macro dir {geminstdir}
- Added lib, bin to macro {geminstdir}
- Added subpackage doc with folders: man, test and doc
2010-10-18 - Jozef Zigmund <jzigmund@redhat.com> - 0.11.2-2
- Repair URL Source0
- Remove "Mustache is a" from Summary
- Add Require: rubygem(sinatra)
2010-10-18 - Jozef Zigmund <jzigmund@redhat.com> - 0.11.2-1
- Initial package

See Also

Package Description
rubygem-mustache-doc-0.99.4-4.sdl6.noarch.rpm Documentation for rubygem-mustache
rubygem-rdiscount-1.6.8-1.sdl6.i686.rpm Discount (For Ruby). A Fast Implementation of Gruber's Markdown in C
rubygem-ronn-0.7.3-1.sdl6.noarch.rpm Builds manuals
samtools-0.1.9-4.sdl6.i686.rpm Tools for nucleotide sequence alignments in the SAM format
samtools-devel-0.1.9-4.sdl6.i686.rpm Header files and libraries for compiling against samtools
samtools-libs-0.1.9-4.sdl6.i686.rpm Libraries for applications using samtools
samtools0118-0.1.18-2.3.sdl6.i686.rpm Tools for nucleotide sequence alignments in the SAM format
samtools0118-devel-0.1.18-2.3.sdl6.i686.rpm Header files and libraries for compiling against samtools0118
samtools0118-libs-0.1.18-2.3.sdl6.i686.rpm Libraries for applications using samtools0118
samtools0119-0.1.19-2.3.sdl6.i686.rpm Tools for nucleotide sequence alignments in the SAM format
samtools0119-devel-0.1.19-2.3.sdl6.i686.rpm Header files and libraries for compiling against samtools0119
samtools0119-libs-0.1.19-2.3.sdl6.i686.rpm Libraries for applications using samtools0119
samtools0119-pysam27_075-0.7.5-2.1.sdl6.i686.rpm Python interface for the SAM/BAM sequence alignment and mapping format
scalapack-common-1.7.5-18.sdl6.i686.rpm Common files for scalapack
scalapack-mpich-1.7.5-18.sdl6.i686.rpm ScaLAPACK libraries compiled against mpich
Advertisement
Advertisement