perl-Module-CPANTS-Analyse-0.85-5.puias6.noarch.rpm


Advertisement

Description

perl-Module-CPANTS-Analyse - Generate Kwalitee ratings for a distribution

Property Value
Distribution CentOS 6
Repository PUIAS Computational i386
Package name perl-Module-CPANTS-Analyse
Package version 0.85
Package release 5.puias6
Package architecture noarch
Package type rpm
Installed size 152.50 KB
Download size 80.41 KB
Official Mirror springdale.math.ias.edu
CPANTS is an acronym for CPAN Testing Service. The goals
of the CPANTS project are to provide some sort of quality
measure (called "Kwalitee") and lots of metadata for all
distributions on CPAN.

Alternatives

Package Version Architecture Repository
perl-Module-CPANTS-Analyse-0.85-11.el6.noarch.rpm 0.85 noarch EPEL
perl-Module-CPANTS-Analyse-0.85-11.el6.noarch.rpm 0.85 noarch EPEL
perl-Module-CPANTS-Analyse-0.85-5.puias6.noarch.rpm 0.85 noarch PUIAS Computational
perl-Module-CPANTS-Analyse-0.85-5.puias6.noarch.rpm 0.85 noarch PUIAS Unsupported
perl-Module-CPANTS-Analyse-0.85-5.puias6.noarch.rpm 0.85 noarch PUIAS Unsupported
perl-Module-CPANTS-Analyse - - -

Requires

Name Value
/usr/bin/perl -
perl >= 5.006
perl(:MODULE_COMPAT_5.10.1) -
perl(Archive::Any) -
perl(Archive::Any) >= 0.06
perl(Archive::Tar) >= 1.30
perl(Array::Diff) -
perl(Array::Diff) >= 0.04
perl(CPAN::DistnameInfo) -
perl(CPAN::DistnameInfo) >= 0.06
perl(Carp) -
perl(Class::Accessor) >= 0.19
perl(Cwd) -
perl(Data::Dumper) -
perl(File::Basename) -
perl(File::Copy) -
perl(File::Find) -
perl(File::Find::Rule) -
perl(File::Slurp) -
perl(File::Spec::Functions) -
perl(File::Temp) -
perl(File::stat) -
perl(Getopt::Long) -
perl(IO::Capture) >= 0.05
perl(IO::Capture::Stderr) -
perl(IO::Capture::Stdout) -
perl(LWP::Simple) -
perl(List::MoreUtils) -
perl(Module::ExtractUse) -
perl(Module::ExtractUse) >= 0.18
perl(Module::Pluggable) >= 2.96
perl(Module::Pluggable) -
perl(Pod::Simple::Checker) -
perl(Pod::Simple::Checker) >= 2.02
perl(Pod::Simple::TextContent) -
perl(Pod::Usage) -
perl(Readonly) -
perl(Software::LicenseUtils) -
perl(Test::YAML::Meta::Version) -
perl(Test::YAML::Meta::Version) >= 0.11
perl(Text::CSV_XS) >= 0.45
perl(YAML::Syck) -
perl(YAML::Syck) >= 0.95
perl(base) -
perl(strict) -
perl(version) -
perl(version) >= 0.73
perl(warnings) -

Provides

Name Value
perl(Module::CPANTS::Analyse) -
perl(Module::CPANTS::Kwalitee) -
perl(Module::CPANTS::Kwalitee::BrokenInstaller) -
perl(Module::CPANTS::Kwalitee::CpantsErrors) -
perl(Module::CPANTS::Kwalitee::Distname) -
perl(Module::CPANTS::Kwalitee::Distros) -
perl(Module::CPANTS::Kwalitee::Files) -
perl(Module::CPANTS::Kwalitee::FindModules) -
perl(Module::CPANTS::Kwalitee::License) -
perl(Module::CPANTS::Kwalitee::Manifest) -
perl(Module::CPANTS::Kwalitee::MetaYML) -
perl(Module::CPANTS::Kwalitee::NeedsCompiler) -
perl(Module::CPANTS::Kwalitee::Pod) -
perl(Module::CPANTS::Kwalitee::Prereq) -
perl(Module::CPANTS::Kwalitee::Repackageable) -
perl(Module::CPANTS::Kwalitee::Uses) -
perl(Module::CPANTS::Kwalitee::Version) -
perl-Module-CPANTS-Analyse = 0.85-5.puias6

Download

Type URL
Binary Package perl-Module-CPANTS-Analyse-0.85-5.puias6.noarch.rpm
Source Package perl-Module-CPANTS-Analyse-0.85-5.puias6.src.rpm

Install Howto

  1. Download the latest puias-computational rpm from
    http://springdale.math.ias.edu/data/puias/computational/6/i386/
  2. Install puias-computational rpm:
    # rpm -Uvh puias-computational*rpm
  3. Install perl-Module-CPANTS-Analyse rpm package:
    # yum install perl-Module-CPANTS-Analyse

Files

Path
/usr/bin/cpants_lint.pl
/usr/share/doc/perl-Module-CPANTS-Analyse-0.85/Changes
/usr/share/doc/perl-Module-CPANTS-Analyse-0.85/README
/usr/share/doc/perl-Module-CPANTS-Analyse-0.85/TODO
/usr/share/man/man1/cpants_lint.pl.1.gz
/usr/share/man/man3/Module::CPANTS::Analyse.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::BrokenInstaller.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::CpantsErrors.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Distname.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Distros.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Files.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::FindModules.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::License.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Manifest.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::MetaYML.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::NeedsCompiler.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Pod.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Prereq.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Repackageable.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Uses.3pm.gz
/usr/share/man/man3/Module::CPANTS::Kwalitee::Version.3pm.gz
/usr/share/perl5/vendor_perl/Module/
/usr/share/perl5/vendor_perl/Module/CPANTS/Analyse.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/BrokenInstaller.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/CpantsErrors.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/Distname.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/Distros.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/Files.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/FindModules.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/License.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/Manifest.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/MetaYML.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/NeedsCompiler.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/Pod.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/Prereq.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/Repackageable.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/Uses.pm
/usr/share/perl5/vendor_perl/Module/CPANTS/Kwalitee/Version.pm

Changelog

2010-05-03 - Marcela Maslanova <mmaslano@redhat.com> - 0.85-5
- Mass rebuild with perl-5.12.0
2010-01-12 - Daniel P. Berrange <berrange@redhat.com> - 0.85-4
- Fix source URL
2009-12-07 - Stepan Kasal <skasal@redhat.com> - 0.85-3
- rebuild against perl 5.10.1
2009-07-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.85-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-07-22 - Daniel P. Berrange <berrange@redhat.com> - 0.85-1
- Update to 0.85 release
2009-02-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.82-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
2008-10-03 - Daniel P. Berrange <berrange@redhat.com> - 0.82-2
- Added more new & missing BRs
2008-09-05 - Daniel P. Berrange <berrange@redhat.com> - 0.82-1
- Update to 0.82 release
2008-02-08 - Tom "spot" Callaway <tcallawa@redhat.com> 0.75-3
- rebuild for new perl
2007-12-26 - Daniel P. Berrange <berrange@redhat.com> 0.75-2.fc9
- Added Test::Deep, Test::Pod, Test::Pod::Coverage build requires

See Also

Package Description
perl-Module-ExtractUse-0.23-3.puias6.noarch.rpm Find out what modules are used
perl-Pod-Strip-1.02-5.puias6.noarch.rpm Remove POD from Perl code
perl-SQL-Statement-1.27-1.puias6.noarch.rpm SQL parsing and processing engine
perl-Software-License-0.103002-1.puias6.noarch.rpm Package that provides templated software licenses
perl-Statistics-Descriptive-3.0200-1.sdl6.noarch.rpm Perl module of basic descriptive statistical functions
perl-Statistics-Distributions-1.02-1.2.sdl6.noarch.rpm Calculate critical values and upper probabilities of statistics
perl-Sub-Name-0.04-4.puias6.i686.rpm Name -- or rename -- a sub
perl-Term-ReadLine-Gnu-1.20-1.puias6.i686.rpm Perl extension for the GNU Readline/History Library
perl-Test-Kwalitee-1.01-3.puias6.noarch.rpm Test the Kwalitee of a distribution before you release it
perl-Test-YAML-Meta-0.16-1.puias6.noarch.rpm Validation of the META.yml file in a distribution
perl-Test-YAML-Valid-0.04-2.puias6.noarch.rpm Lets you test the validity of YAML files in unit tests
perl-Text-CSV_XS-0.85-1.puias6.i686.rpm Comma-separated values manipulation routines
perl-Text-Template-1.45-3.puias6.noarch.rpm Expand template text with embedded Perl
perl-UNIVERSAL-require-0.13-1.puias6.noarch.rpm Require() modules from a variable
perl-YAML-LibYAML-0.33-1.puias6.i686.rpm YAML::LibYAML Perl module
Advertisement
Advertisement