libxc-2.1.2-3.sdl6.i686.rpm


Advertisement

Description

libxc - Library of exchange and correlation functionals to be used in DFT codes

Property Value
Distribution CentOS 6
Repository PUIAS Computational i386
Package name libxc
Package version 2.1.2
Package release 3.sdl6
Package architecture i686
Package type rpm
Installed size 1.52 MB
Download size 386.21 KB
Official Mirror springdale.math.ias.edu
libxc is a library of exchange and correlation functionals. Its purpose is to
be used in codes that implement density-functional theory. For the moment, the
library includes most of the local density approximations (LDAs), generalized
density approximation (GGAs), and meta-GGAs. The library provides values for
the energy density and its 1st, 2nd, and (for the LDAs) 3rd derivatives.

Alternatives

Package Version Architecture Repository
libxc-2.1.2-3.sdl6.x86_64.rpm 2.1.2 x86_64 PUIAS Computational
libxc-2.1.2-3.el6.i686.rpm 2.1.2 i686 EPEL
libxc-2.1.2-3.el6.i686.rpm 2.1.2 i686 EPEL
libxc-2.1.2-3.el6.x86_64.rpm 2.1.2 x86_64 EPEL
libxc - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.7) -
libgcc_s.so.1 -
libgfortran.so.3 -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
rtld(GNU_HASH) -

Provides

Name Value
libxc = 2.1.2-3.sdl6
libxc(x86-32) = 2.1.2-3.sdl6
libxc.so.1 -

Download

Type URL
Binary Package libxc-2.1.2-3.sdl6.i686.rpm
Source Package libxc-2.1.2-3.sdl6.src.rpm

Install Howto

  1. Download the latest puias-computational rpm from
    http://springdale.math.ias.edu/data/puias/computational/6/i386/
  2. Install puias-computational rpm:
    # rpm -Uvh puias-computational*rpm
  3. Install libxc rpm package:
    # yum install libxc

Files

Path
/usr/bin/xc-info
/usr/lib/libxc.so.1
/usr/lib/libxc.so.1.1.2
/usr/share/doc/libxc-2.1.2/AUTHORS
/usr/share/doc/libxc-2.1.2/COPYING
/usr/share/doc/libxc-2.1.2/ChangeLog
/usr/share/doc/libxc-2.1.2/NEWS
/usr/share/doc/libxc-2.1.2/README
/usr/share/doc/libxc-2.1.2/TODO

Changelog

2015-04-24 - Susi Lehtola <jussilehtola@fedoraproject.org> - 2.1.2-3
- Patch some hybrids.
2015-04-24 - Susi Lehtola <jussilehtola@fedoraproject.org> - 2.1.2-2
- Patch broken makefiles.
2015-02-19 - Susi Lehtola <jussilehtola@fedoraproject.org> - 2.1.2-1
- Update to 2.1.2.
2014-08-17 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
2014-06-07 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
2014-03-24 - Susi Lehtola <jussilehtola@fedoraproject.org> - 2.1.0-2
- Re-enable builds on ppc and ppc64 on EPEL.
2014-03-21 - Susi Lehtola <jussilehtola@fedoraproject.org> - 2.1.0-1
- Enable single precision routines as well.
- Update to 2.1.0.
2014-02-18 - Susi Lehtola <jussilehtola@fedoraproject.org> - 2.0.3-1
- Update to 2.0.3.
2014-02-17 - Susi Lehtola <jussilehtola@fedoraproject.org> - 2.0.2-3
- Fix bug with some mgga correlation functionals.
2013-08-03 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

See Also

Package Description
libxc-devel-2.1.2-3.sdl6.i686.rpm Development library and headers for libxc
llvm-3.4-9.sdl6.i686.rpm The Low Level Virtual Machine
llvm-devel-3.4-9.sdl6.i686.rpm Libraries and header files for LLVM
llvm-doc-3.4-9.sdl6.noarch.rpm Documentation for LLVM
llvm-libs-3.4-9.sdl6.i686.rpm LLVM shared libraries
llvm-ocaml-3.4-9.sdl6.i686.rpm OCaml binding for LLVM
llvm-ocaml-devel-3.4-9.sdl6.i686.rpm Development files for llvm-ocaml
llvm-ocaml-doc-3.4-9.sdl6.noarch.rpm Documentation for LLVM's OCaml binding
llvm-static-3.4-9.sdl6.i686.rpm LLVM static libraries
luajit-2.0.4-3.sdl6.i686.rpm Just-In-Time Compiler for Lua
luajit-devel-2.0.4-3.sdl6.i686.rpm Development files for luajit
luarocks-2.1.2-1.sdl6.noarch.rpm A deployment and management system for Lua modules
lustre-client-1.8.9-1.wc1.1.i686.rpm Lustre File System
lustre-client-source-1.8.9-1.wc1.1.i686.rpm Object-Based Disk storage driver source
lustre-client-tests-1.8.9-1.wc1.1.i686.rpm Lustre testing framework
Advertisement
Advertisement