blacs-mpich2-devel-1.1-39.puias6.1.i686.rpm


Advertisement

Description

blacs-mpich2-devel - Development libraries for blacs (mpich2)

Distribution: CentOS 6
Repository: PUIAS Computational i386
Package name: blacs-mpich2-devel
Package version: 1.1
Package release: 39.puias6.1
Package architecture: i686
Package type: rpm
Installed size: unknown
Download size: 8.19 KB
Official Mirror: springdale.math.ias.edu
This package contains development libraries for blacs, compiled against mpich2.

Alternatives

Provides

  • blacs-lam-devel = 1.1-39.puias6.1
  • blacs-mpich2-devel = 1.1-39.puias6.1
  • blacs-mpich2-devel(x86-32) = 1.1-39.puias6.1

Obsoletes

  • blacs-lam-devel < 1.1-34

    Install Howto

    1. Download the latest puias-computational rpm from
      http://springdale.math.ias.edu/data/puias/computational/6/i386/
    2. Install puias-computational rpm:
      # rpm -Uvh puias-computational*rpm
    3. Install blacs-mpich2-devel rpm package:
      # yum install blacs-mpich2-devel

    Files

    • /usr/include/mpich2-i386/
    • /usr/lib/mpich2/lib/libmpiblacs.so
    • /usr/lib/mpich2/lib/libmpiblacsCinit.so
    • /usr/lib/mpich2/lib/libmpiblacsF77init.so

    Changelog

    2010-04-17 - Tom "spot" Callaway <tcallawa@redhat.com> - 1.1-39.1 - f12 still needs provides/obsoletes for old lam ghosts

    2010-04-13 - Tom "spot" Callaway <tcallawa@redhat.com> - 1.1-39 - openmpi doesn't use TRANSCOMM = -DUseMpich - put libraries in $MPI_LIB, not $MPI_HOME

    2010-02-24 - Tom "spot" Callaway <tcallawa@redhat.com> - 1.1-38 - get rid of environment module files altogether (the openmpi/mpich2 env modules are sufficient)

    2010-02-19 - Tom "spot" Callaway <tcallawa@redhat.com> - 1.1-37 - fix environment module files

    2010-02-16 - Tom "spot" Callaway <tcallawa@redhat.com> - 1.1-36 - put libraries in appropriate locations - put include files in appropriate locations - put environment module files in appropriate location - use -p with every cp invocation - drop Provides/Obsoletes for blacs-lam-*

    2009-12-10 - Deji Akingunola <dakingun@gmail.com> - 1.1-35 - Buildrequire mpich2-devel-static - Adjust obsolete versioning

    2009-12-07 - Tom "spot" Callaway <tcallawa@redhat.com> - 1.1-34 - drop lam subpackages (fixes FTBFS, 539057) - blacs-mpich2-* now Provides/Obsoletes blacs-lam-*, this is a dirty lie, but we need something to do it - move static bits to -static subpackages (resolves 545142) - package up Bdef.h for other dependent packages to use (resolves 533929, thanks to Deji Akingunola)

    2009-08-06 - Tom "spot" Callaway <tcallawa@redhat.com> - 1.1-33 - rework package to handle all supported MPI environments in Fedora

    2009-07-24 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-32 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild

    2009-02-23 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1-31 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild

    Advertisement
    Advertisement