PyQwt-5.2.0-11.puias6.i686.rpm


Advertisement

Description

PyQwt - Python bindings for Qwt

Property Value
Distribution CentOS 6
Repository PUIAS Computational i386
Package name PyQwt
Package version 5.2.0
Package release 11.puias6
Package architecture i686
Package type rpm
Installed size 1.79 MB
Download size 301.45 KB
Official Mirror springdale.math.ias.edu
PyQwt is a set of Python bindings for the Qwt C++ class library which extends
the Qt framework with widgets for scientific and engineering applications. It
provides a widget to plot 2-dimensional data and various widgets to display and
control bounded or unbounded floating point values.

Alternatives

Package Version Architecture Repository
PyQwt-5.2.0-11.puias6.x86_64.rpm 5.2.0 x86_64 PUIAS Computational
PyQwt-5.2.0-11.el6.i686.rpm 5.2.0 i686 EPEL
PyQwt-5.2.0-11.el6.x86_64.rpm 5.2.0 x86_64 EPEL
PyQwt - - -

Requires

Name Value
/usr/bin/env -
PyQt4 -
libQtCore.so.4 -
libQtGui.so.4 -
libQtSvg.so.4 -
libX11.so.6 -
libXext.so.6 -
libc.so.6(GLIBC_2.3.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libpthread.so.0 -
libqwt.so.5 -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
numpy -
python(abi) = 2.6
rtld(GNU_HASH) -
sip-api(6) >= 6.0

Provides

Name Value
PyQwt = 5.2.0-11.puias6
PyQwt(x86-32) = 5.2.0-11.puias6

Download

Type URL
Binary Package PyQwt-5.2.0-11.puias6.i686.rpm
Source Package PyQwt-5.2.0-11.puias6.src.rpm

Install Howto

  1. Download latest puias-computational rpm from
    http://springdale.math.ias.edu/data/puias/computational/6/i386/
  2. Install puias-computational rpm:
    # rpm -Uvh puias-computational*rpm
  3. Install PyQwt rpm package:
    # yum install PyQwt

Files

Path
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/Qwt.so
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/__init__.py
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/__init__.pyc
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/__init__.pyo
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/_iqt.so
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/anynumpy.py
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/anynumpy.pyc
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/anynumpy.pyo
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/grace.py
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/grace.pyc
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/grace.pyo
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/ipy_user_conf.py
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/ipy_user_conf.pyc
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/ipy_user_conf.pyo
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/iqt.py
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/iqt.pyc
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/iqt.pyo
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/pythonrc.py
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/pythonrc.pyc
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/pythonrc.pyo
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/qplt.py
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/qplt.pyc
/usr/lib/python2.6/site-packages/PyQt4/Qwt5/qplt.pyo
/usr/share/doc/PyQwt-5.2.0/ANNOUNCEMENT-5.2.0
/usr/share/doc/PyQwt-5.2.0/COPYING
/usr/share/doc/PyQwt-5.2.0/COPYING.GSE
/usr/share/doc/PyQwt-5.2.0/COPYING.INTES
/usr/share/doc/PyQwt-5.2.0/COPYING.PyQwt
/usr/share/doc/PyQwt-5.2.0/README

Changelog

2011-01-03 - Tadej Janež <tadej.janez@tadej.hicsalta.si> - 5.2.0-11
- changes to the spec file that follow the latest Packaging Guidelines:
- removed BuildRoot tag
- removed %clean section
- removed private shared object provides that were reported by rpmlint
- removed the manual definition of the python_sitearch macro
- simplified the handling of devel documentation files
- minor cosmetic cleanups
2010-12-10 - Rex Dieter <rdieter@fedoraproject.org> -  5.2.0-10
- rebuild (sip, #662039))
2010-09-09 - Rex Dieter <rdieter@fedoraproject.org> - 5.2.0-9
- rebuild(sip)
2010-07-21 - David Malcolm <dmalcolm@redhat.com> - 5.2.0-8
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
2010-04-21 - Tadej Janež <tadej.janez@tadej.hicsalta.si> - 5.2.0-7
- another rebuild (for qwt-5.2.1, f11+)
2010-04-19 - Tadej Janež <tadej.janez@tadej.hicsalta.si> - 5.2.0-6
- rebuild (for qwt-5.2.1, f11+)
2010-04-12 - Tadej Janež <tadej.janez@tadej.hicsalta.si> - 5.2.0-5
- rebuild (for qwt-5.2.0, f11+)
2010-01-07 - Rex Dieter <rdieter@fedoraproject.org> - 5.2.0-4
- rebuild (sip)
2009-11-19 - Rex Dieter <rdieter@fedoraproject.org> - 5.2.0-3.1
- rebuild (for qt-4.6.0-rc1, f13+)
2009-11-16 - Rex Dieter <rdieter@fedoraproject.org> 5.2.0-3
- Requires: sip-api(%_sip_api_major) >= %_sip_api (#537894)

See Also

Package Description
PyQwt-devel-5.2.0-11.puias6.i686.rpm Files needed to build other bindings on PyQwt
PyYAML27-3.09-5.puias6.i686.rpm YAML parser and emitter for Python
Pyrex27-0.9.9-3.sdl6.noarch.rpm A compiler/language for writing Python extension modules
QSlim-2.1-3.puias6.i686.rpm QSlim and other applications from SlimKit collection of surface modelling tools
R-3.3.3-1.sdl6.i686.rpm A language for data analysis and graphics
R-3.4.0-2.sdl6.i686.rpm A language for data analysis and graphics
R-3.4.1-1.sdl6.i686.rpm A language for data analysis and graphics
R-HiddenMarkov-1.7.0-2.sdl6.i686.rpm Hidden Markov Models
R-R.methodsS3-1.5.2-1.sdl6.i686.rpm Utility function for defining S3 methods
R-R.oo-1.15.8-1.sdl6.i686.rpm R object-oriented programming with or without references
R-core-3.3.3-1.sdl6.i686.rpm The minimal R components necessary for a functional runtime
R-core-3.4.0-2.sdl6.i686.rpm The minimal R components necessary for a functional runtime
R-core-3.4.1-1.sdl6.i686.rpm The minimal R components necessary for a functional runtime
R-core-devel-3.3.3-1.sdl6.i686.rpm Core files for development of R packages (no Java)
R-core-devel-3.4.0-2.sdl6.i686.rpm Core files for development of R packages (no Java)
Advertisement
Advertisement