rubygem-rubypython-0.5.3-2.of.el6.noarch.rpm


Advertisement

Description

rubygem-rubypython - RubyPython is a bridge between the Ruby and Python interpreters

Property Value
Distribution CentOS 6
Repository Open Fusion x86_64
Package filename rubygem-rubypython-0.5.3-2.of.el6.noarch.rpm
Package name rubygem-rubypython
Package version 0.5.3
Package release 2.of.el6
Package architecture noarch
Package type rpm
Category Development/Languages
Homepage -
License GPLv2+ or Ruby
Maintainer -
Download size 93.97 KB
Installed size 276.85 KB
RubyPython is a bridge between the Ruby and Python interpreters. It embeds a
running Python interpreter in the Ruby application's process using FFI and
provides a means for wrapping, converting, and calling Python objects and
methods.
RubyPython uses FFI to marshal the data between the Ruby and Python VMs and
make Python calls. You can:
* Inherit from Python classes.
* Configure callbacks from Python.
* Run Python generators (on Ruby 1.9.2 or later).

Alternatives

Package Version Architecture Repository
rubygem-rubypython-0.5.3-2.of.el6.noarch.rpm 0.5.3 noarch Open Fusion
rubygem-rubypython-0.5.3-1.of.el6.noarch.rpm 0.5.3 noarch Open Fusion
rubygem-rubypython-0.5.3-1.of.el6.noarch.rpm 0.5.3 noarch Open Fusion
rubygem-rubypython - - -

Requires

Name Value
python -
python-devel -
ruby >= 0
ruby(abi) = 1.8
rubygem(blankslate) >= 2.1.2.3
rubygem(ffi) < 1.1
rubygem(ffi) >= 1.0.7
rubygems >= 0

Provides

Name Value
rubygem(rubypython) = 0.5.3
rubygem-rubypython = 0.5.3-2.of.el6

Download

Type URL
Mirror repo.openfusion.net
Binary Package rubygem-rubypython-0.5.3-2.of.el6.noarch.rpm
Source Package rubygem-rubypython-0.5.3-2.of.el6.src.rpm

Install Howto

  1. Download latest openfusion-release rpm from
    http://repo.openfusion.net/centos6-x86_64/
  2. Install openfusion-release rpm:
    # rpm -Uvh openfusion-release*rpm
  3. Install rubygem-rubypython rpm package:
    # yum install rubygem-rubypython

Files

Path
/usr/lib/ruby/gems/1.8/cache/rubypython-0.5.3.gem
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/.autotest
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/.gemtest
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/.gitignore
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/.hgignore
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/.hgtags
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/.rspec
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/Contributors.rdoc
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/History.rdoc
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/License.rdoc
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/Manifest.txt
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/PostInstall.txt
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/README.rdoc
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/Rakefile
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/.yardoc/checksums
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/.yardoc/proxy_types
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/.yardoc/objects/root.dat
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/autotest/discover.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/blankobject.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/conversion.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/legacy.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/macros.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/operators.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/options.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/pygenerator.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/pymainclass.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/pyobject.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/python.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/pythonerror.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/pythonexec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/rubypyproxy.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/lib/rubypython/type.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/basic_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/callback_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/conversion_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/legacy_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/pymainclass_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/pyobject_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/pythonerror_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/refcnt_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/rubypyclass_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/rubypyproxy_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/rubypython_spec.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/spec_helper.rb
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/python_helpers/basics.py
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/python_helpers/basics.pyc
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/python_helpers/basics.pyo
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/python_helpers/errors.py
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/python_helpers/errors.pyc
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/python_helpers/errors.pyo
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/python_helpers/objects.py
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/python_helpers/objects.pyc
/usr/lib/ruby/gems/1.8/gems/rubypython-0.5.3/spec/python_helpers/objects.pyo
/usr/lib/ruby/gems/1.8/specifications/rubypython-0.5.3.gemspec

Changelog

2012-08-02 - Gavin Carr <gavin@openfusion.com.au> - 0.5.3-1
- Initial package

See Also

Package Description
rubygem-rubywarrior-0.1.3-1.of.el6.noarch.rpm Game written in Ruby for learning Ruby and artificial intelligence
rubygem-rubyzip-0.9.7-1.of.el6.noarch.rpm rubyzip is a ruby module for reading and writing zip files
rubygem-rufus-scheduler-2.0.16-1.of.el6.noarch.rpm job scheduler for Ruby (at, cron, in and every jobs)
rubygem-sanitize-2.0.3-1.of.el6.noarch.rpm Whitelist-based HTML sanitizer
rubygem-sass-3.1.7-1.of.el6.noarch.rpm A powerful but elegant CSS compiler that makes CSS fun again
rubygem-sass-3.2.7-1.of.el6.noarch.rpm A powerful but elegant CSS compiler that makes CSS fun again
rubygem-sass-rails-3.1.0-1.of.el6.noarch.rpm Sass adapter for the Rails asset pipeline
rubygem-serialport-1.1.0-1.of.el6.x86_64.rpm Library for using RS-232 serial ports
rubygem-sheet-0.1.4-1.of.el6.noarch.rpm snippets for your command line
rubygem-shoulda-2.11.3-1.of.el6.noarch.rpm Making tests easy on the fingers and eyes
rubygem-showoff-0.7.0-1.of.el6.noarch.rpm The best damn presentation software a developer could ever love
rubygem-simple-graphite-1.1.1-1.of.el6.noarch.rpm Simple hook into graphite
rubygem-simple-rss-1.2.3-1.of.el6.noarch.rpm A simple, flexible, extensible, and liberal RSS and Atom reader for Ruby. It is designed to be backwards compatible with the standard RSS parser, but will never do RSS generation
rubygem-simple_oauth-0.1.5-1.of.el6.noarch.rpm Simply builds and verifies OAuth headers
rubygem-sinatra-1.2.6-1.of.el6.noarch.rpm Classy web-development dressed in a DSL
Advertisement
Advertisement