rubygem-rake-compiler-0.7.9-1.of.el6.noarch.rpm


Advertisement

Description

rubygem-rake-compiler - Rake-based Ruby Extension (C, Java) task generator

Property Value
Distribution CentOS 6
Repository Open Fusion x86_64
Package filename rubygem-rake-compiler-0.7.9-1.of.el6.noarch.rpm
Package name rubygem-rake-compiler
Package version 0.7.9
Package release 1.of.el6
Package architecture noarch
Package type rpm
Category Development/Languages
Homepage http://github.com/luislavena/rake-compiler
License GPLv2+ or Ruby
Maintainer -
Download size 73.10 KB
Installed size 183.24 KB
Provide a standard and simplified way to build and package
Ruby extensions (C, Java) using Rake as glue.

Alternatives

Package Version Architecture Repository
rubygem-rake-compiler-0.9.3-2.el6.noarch.rpm 0.9.3 noarch EPEL
rubygem-rake-compiler-0.9.3-2.el6.noarch.rpm 0.9.3 noarch EPEL
rubygem-rake-compiler-0.7.9-1.of.el6.noarch.rpm 0.7.9 noarch Open Fusion
rubygem-rake-compiler-0.7.6-1.el6.rf.noarch.rpm 0.7.6 noarch Repoforge (RPMforge)
rubygem-rake-compiler-0.7.6-1.el6.rf.noarch.rpm 0.7.6 noarch Repoforge (RPMforge)
rubygem-rake-compiler-0.7.1-1.puias6.noarch.rpm 0.7.1 noarch PUIAS Unsupported
rubygem-rake-compiler-0.7.1-1.puias6.noarch.rpm 0.7.1 noarch PUIAS Unsupported
rubygem-rake-compiler - - -

Requires

Name Value
/usr/bin/env -
/usr/bin/ruby -
rubygem(rake) >= 0
rubygem(rspec) > 1.2.9
rubygems -

Provides

Name Value
rubygem(rake-compiler) = 0.7.9
rubygem-rake-compiler = 0.7.9-1.of.el6

Download

Type URL
Mirror repo.openfusion.net
Binary Package rubygem-rake-compiler-0.7.9-1.of.el6.noarch.rpm
Source Package rubygem-rake-compiler-0.7.9-1.of.el6.src.rpm

Install Howto

  1. Download latest openfusion-release rpm from
    http://repo.openfusion.net/centos6-x86_64/
  2. Install openfusion-release rpm:
    # rpm -Uvh openfusion-release*rpm
  3. Install rubygem-rake-compiler rpm package:
    # yum install rubygem-rake-compiler

Files

Path
/usr/bin/rake-compiler
/usr/lib/ruby/gems/1.8/cache/rake-compiler-0.7.9.gem
/usr/lib/ruby/gems/1.8/doc/rake-compiler-0.7.9/
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/History.txt
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/Isolate
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/LICENSE.txt
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/README.rdoc
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/Rakefile
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/cucumber.yml
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/.yardoc/checksums
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/.yardoc/proxy_types
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/.yardoc/objects/root.dat
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/bin/rake-compiler
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/compile.feature
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/cross-compile.feature
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/cross-package-multi.feature
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/cross-package.feature
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/java-compile.feature
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/java-no-native-compile.feature
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/java-package.feature
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/package.feature
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/step_definitions/compilation.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/step_definitions/cross_compilation.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/step_definitions/execution.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/step_definitions/folders.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/step_definitions/gem.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/step_definitions/java_compilation.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/support/env.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/support/file_template_helpers.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/support/generator_helpers.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/features/support/platform_extension_helpers.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/lib/
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/lib/rake/baseextensiontask.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/lib/rake/extensioncompiler.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/lib/rake/extensiontask.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/lib/rake/javaextensiontask.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/spec/spec.opts
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/spec/spec_helper.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/spec/lib/
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/spec/lib/rake/extensiontask_spec.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/spec/lib/rake/javaextensiontask_spec.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/spec/support/capture_output_helper.rb
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/tasks/bootstrap.rake
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/tasks/common.rake
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/tasks/cucumber.rake
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/tasks/gem.rake
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/tasks/news.rake
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/tasks/release.rake
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/tasks/rspec.rake
/usr/lib/ruby/gems/1.8/gems/rake-compiler-0.7.9/tasks/bin/cross-ruby.rake
/usr/lib/ruby/gems/1.8/specifications/rake-compiler-0.7.9.gemspec

Changelog

2011-12-05 - Gavin Carr <gavin@openfusion.com.au> 0.7.9-1
- Update to version 0.7.9.
2011-02-02 - Gavin Carr <gavin@openfusion.com.au> - 0.7.5-1
- Initial package

See Also

Package Description
rubygem-rb-fchange-0.0.5-1.of.el6.noarch.rpm A Ruby wrapper for Windows Kernel functions for monitoring the specified directory or subtree
rubygem-rb-fsevent-0.9.1-1.of.el6.noarch.rpm Very simple & usable FSEvents API
rubygem-rb-inotify-0.8.8-1.of.el6.noarch.rpm A Ruby wrapper for Linux's inotify, using FFI
rubygem-rdiscount-1.6.8-1.of.el6.x86_64.rpm Fast Implementation of Gruber's Markdown in C
rubygem-rdoc-3.12-1.of.el6.noarch.rpm RDoc produces HTML and command-line documentation for Ruby projects
rubygem-rdoc-3.9.4-1.of.el6.noarch.rpm RDoc produces HTML and command-line documentation for Ruby projects
rubygem-redcarpet-1.17.2-1.of.el6.x86_64.rpm Ruby bindings for libupskirt
rubygem-redcarpet-2.2.2-1.of.el6.x86_64.rpm Ruby bindings for libupskirt
rubygem-redis-2.1.1-1.of.el6.noarch.rpm Ruby client library for redis key value storage server
rubygem-redis-2.2.0-1.of.el6.noarch.rpm Ruby client library for redis key value storage server
rubygem-redis-2.2.2-1.of.el6.noarch.rpm Ruby client library for redis key value storage server
rubygem-redis-namespace-1.0.3-1.of.el6.noarch.rpm Namespaces Redis commands
rubygem-resque-1.20.0-1.of.el6.noarch.rpm Resque is a Redis-backed queueing system
rubygem-rest-client-1.6.7-1.of.el6.noarch.rpm Simple HTTP and REST client for Ruby, inspired by microframework syntax for specifying actions
rubygem-rexical-1.0.5-1.of.el6.noarch.rpm Rexical is a lexical scanner generator
Advertisement
Advertisement