rubygem-rack-protection-1.5.0-1.of.el6.noarch.rpm


Advertisement

Description

rubygem-rack-protection - You should use protection!

Property Value
Distribution CentOS 6
Repository Open Fusion x86_64
Package filename rubygem-rack-protection-1.5.0-1.of.el6.noarch.rpm
Package name rubygem-rack-protection
Package version 1.5.0
Package release 1.of.el6
Package architecture noarch
Package type rpm
Category Development/Languages
Homepage http://github.com/rkh/rack-protection
License GPLv2+ or Ruby
Maintainer -
Download size 39.76 KB
Installed size 98.15 KB
You should use protection!

Alternatives

Package Version Architecture Repository
rubygem-rack-protection-1.5.0-1.of.el6.noarch.rpm 1.5.0 noarch Open Fusion
rubygem-rack-protection-1.3.2-1.of.el6.noarch.rpm 1.3.2 noarch Open Fusion
rubygem-rack-protection-1.3.2-1.of.el6.noarch.rpm 1.3.2 noarch Open Fusion
rubygem-rack-protection-1.1.4-2.puias6.noarch.rpm 1.1.4 noarch PUIAS Unsupported
rubygem-rack-protection-1.1.4-2.puias6.noarch.rpm 1.1.4 noarch PUIAS Unsupported
rubygem-rack-protection-1.1.4-1.of.el6.noarch.rpm 1.1.4 noarch Open Fusion
rubygem-rack-protection-1.1.4-1.of.el6.noarch.rpm 1.1.4 noarch Open Fusion
rubygem-rack-protection - - -

Requires

Name Value
ruby >= 0
ruby(abi) = 1.8
rubygem(rack) >= 0
rubygems >= 0

Provides

Name Value
rubygem(rack-protection) = 1.5.0
rubygem-rack-protection = 1.5.0-1.of.el6

Download

Type URL
Mirror repo.openfusion.net
Binary Package rubygem-rack-protection-1.5.0-1.of.el6.noarch.rpm
Source Package rubygem-rack-protection-1.5.0-1.of.el6.src.rpm

Install Howto

  1. Download latest openfusion-release rpm from
    http://repo.openfusion.net/centos6-x86_64/
  2. Install openfusion-release rpm:
    # rpm -Uvh openfusion-release*rpm
  3. Install rubygem-rack-protection rpm package:
    # yum install rubygem-rack-protection

Files

Path
/usr/lib/ruby/gems/1.8/cache/rack-protection-1.5.0.gem
/usr/lib/ruby/gems/1.8/doc/rack-protection-1.5.0/
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/License
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/README.md
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/Rakefile
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/rack-protection.gemspec
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/.yardoc/checksums
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/.yardoc/proxy_types
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/.yardoc/objects/root.dat
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack-protection.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/authenticity_token.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/base.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/escaped_params.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/form_token.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/frame_options.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/http_origin.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/ip_spoofing.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/json_csrf.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/path_traversal.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/remote_referrer.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/remote_token.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/session_hijacking.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/version.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/lib/rack/protection/xss_header.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/authenticity_token_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/escaped_params_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/form_token_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/frame_options_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/http_origin_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/ip_spoofing_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/json_csrf_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/path_traversal_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/protection_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/remote_referrer_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/remote_token_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/session_hijacking_spec.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/spec_helper.rb
/usr/lib/ruby/gems/1.8/gems/rack-protection-1.5.0/spec/xss_header_spec.rb
/usr/lib/ruby/gems/1.8/specifications/rack-protection-1.5.0.gemspec

Changelog

2013-03-20 - Gavin Carr <gavin@openfusion.com.au> 1.5.0-1
- Update to version 1.5.0.
2013-01-30 - Gavin Carr <gavin@openfusion.com.au> 1.3.2-1
- Update to version 1.3.2.
2011-12-05 - Gavin Carr <gavin@openfusion.com.au> 1.1.4-1
- Initial package

See Also

Package Description
rubygem-rack-ssl-1.3.2-1.of.el6.noarch.rpm Force SSL/TLS in your app
rubygem-rack-test-0.6.1-1.of.el6.noarch.rpm Simple testing API built on Rack
rubygem-rails-3.1.0-1.of.el6.noarch.rpm Full-stack web application framework
rubygem-rails-3.1.0-2.of.el6.noarch.rpm Full-stack web application framework
rubygem-rails-3.1.0-3.of.el6.noarch.rpm Full-stack web application framework
rubygem-railties-3.1.0-1.of.el6.noarch.rpm Tools for creating, working with, and running Rails applications
rubygem-railties-3.2.6-1.of.el6.noarch.rpm Tools for creating, working with, and running Rails applications
rubygem-rainbow-1.1.3-1.of.el6.noarch.rpm Rainbow extends ruby String class enabling coloring text on ANSI terminals
rubygem-raindrops-0.8.0-1.of.el6.x86_64.rpm real-time stats for preforking Rack servers
rubygem-rake-0.8.7-1.of.el6.noarch.rpm Ruby based make-like utility
rubygem-rake-compiler-0.7.9-1.of.el6.noarch.rpm Rake-based Ruby Extension (C, Java) task generator
rubygem-rb-fchange-0.0.5-1.of.el6.noarch.rpm A Ruby wrapper for Windows Kernel functions for monitoring the specified directory or subtree
rubygem-rb-fsevent-0.9.1-1.of.el6.noarch.rpm Very simple & usable FSEvents API
rubygem-rb-inotify-0.8.8-1.of.el6.noarch.rpm A Ruby wrapper for Linux's inotify, using FFI
rubygem-rdiscount-1.6.8-1.of.el6.x86_64.rpm Fast Implementation of Gruber's Markdown in C
Advertisement
Advertisement