rdtool-0.6.22-1.of.el6.noarch.rpm


Advertisement

Description

rdtool - RDtool translates Ruby RD into HTML, man or other types of format

Property Value
Distribution CentOS 6
Repository Open Fusion x86_64
Package filename rdtool-0.6.22-1.of.el6.noarch.rpm
Package name rdtool
Package version 0.6.22
Package release 1.of.el6
Package architecture noarch
Package type rpm
Category Applications/Ruby
Homepage http://rubyforge.org/projects/rdtool/
License Dual-licensed GPL/Artistic-like
Maintainer -
Download size 69.45 KB
Installed size 282.90 KB
RD is a multipurpose documentation format, created for documentating Ruby and
the output of the Ruby world.
You can embed RD into Ruby scripts and RD has a neat syntax that helps you to
read documentation in Ruby scripts. On the other hand, RD also has a feature
for class references.
But RD's neat, natural, easy writing syntax appeals to some Rubyists so much
that they use RD for other categories of documentation than its original
purpose. Some write Web pages in RD and translate it into HTML using the
formatter.
RDtool is a formatter which can translate RD into HTML, man or other formats.
Although RD is neat enough for you to read, translation into HTML is sometimes
useful.

Alternatives

Package Version Architecture Repository
rdtool-0.6.22-1.of.el6.noarch.rpm 0.6.22 noarch Open Fusion
rdtool - - -

Requires

Name Value
/usr/bin/ruby -
ruby >= 1.8.0

Provides

Name Value
rdtool = 0.6.22-1.of.el6

Download

Type URL
Mirror repo.openfusion.net
Binary Package rdtool-0.6.22-1.of.el6.noarch.rpm
Source Package rdtool-0.6.22-1.of.el6.src.rpm

Install Howto

  1. Download latest openfusion-release rpm from
    http://repo.openfusion.net/centos6-x86_64/
  2. Install openfusion-release rpm:
    # rpm -Uvh openfusion-release*rpm
  3. Install rdtool rpm package:
    # yum install rdtool

Files

Path
/usr/bin/rd2
/usr/bin/rdswap
/usr/lib/ruby/site_ruby/1.8/rd/block-element.rb
/usr/lib/ruby/site_ruby/1.8/rd/complex-list-item.rb
/usr/lib/ruby/site_ruby/1.8/rd/desclist.rb
/usr/lib/ruby/site_ruby/1.8/rd/document-struct.rb
/usr/lib/ruby/site_ruby/1.8/rd/dot.rd2rc
/usr/lib/ruby/site_ruby/1.8/rd/element.rb
/usr/lib/ruby/site_ruby/1.8/rd/filter.rb
/usr/lib/ruby/site_ruby/1.8/rd/inline-element.rb
/usr/lib/ruby/site_ruby/1.8/rd/labeled-element.rb
/usr/lib/ruby/site_ruby/1.8/rd/list.rb
/usr/lib/ruby/site_ruby/1.8/rd/loose-struct.rb
/usr/lib/ruby/site_ruby/1.8/rd/methodlist.rb
/usr/lib/ruby/site_ruby/1.8/rd/output-format-visitor.rb
/usr/lib/ruby/site_ruby/1.8/rd/package.rb
/usr/lib/ruby/site_ruby/1.8/rd/parser-util.rb
/usr/lib/ruby/site_ruby/1.8/rd/rbl-file.rb
/usr/lib/ruby/site_ruby/1.8/rd/rbl-suite.rb
/usr/lib/ruby/site_ruby/1.8/rd/rd-struct.rb
/usr/lib/ruby/site_ruby/1.8/rd/rd2html-lib.rb
/usr/lib/ruby/site_ruby/1.8/rd/rd2html-opt.rb
/usr/lib/ruby/site_ruby/1.8/rd/rd2man-lib.rb
/usr/lib/ruby/site_ruby/1.8/rd/rd2rdo-lib.rb
/usr/lib/ruby/site_ruby/1.8/rd/rd2rmi-lib.rb
/usr/lib/ruby/site_ruby/1.8/rd/rdblockparser.ry
/usr/lib/ruby/site_ruby/1.8/rd/rdblockparser.tab.rb
/usr/lib/ruby/site_ruby/1.8/rd/rdfmt.rb
/usr/lib/ruby/site_ruby/1.8/rd/rdinlineparser.ry
/usr/lib/ruby/site_ruby/1.8/rd/rdinlineparser.tab.rb
/usr/lib/ruby/site_ruby/1.8/rd/rdvisitor.rb
/usr/lib/ruby/site_ruby/1.8/rd/reference-resolver.rb
/usr/lib/ruby/site_ruby/1.8/rd/search-file.rb
/usr/lib/ruby/site_ruby/1.8/rd/tree.rb
/usr/lib/ruby/site_ruby/1.8/rd/version.rb
/usr/lib/ruby/site_ruby/1.8/rd/visitor.rb
/usr/share/doc/rdtool-0.6.22/HISTORY
/usr/share/doc/rdtool-0.6.22/README.html
/usr/share/doc/rdtool-0.6.22/README.ja.html
/usr/share/doc/rdtool-0.6.22/README.rd
/usr/share/doc/rdtool-0.6.22/README.rd.ja
/usr/share/doc/rdtool-0.6.22/rd-mode.el
/usr/share/doc/rdtool-0.6.22/doc/rd-draft.html
/usr/share/doc/rdtool-0.6.22/doc/rd-draft.ja.html
/usr/share/doc/rdtool-0.6.22/doc/rd-draft.rd
/usr/share/doc/rdtool-0.6.22/doc/rd-draft.rd.ja
/usr/share/man/man1/rd-draft.1.gz
/usr/share/man/man1/rdtool.1.gz

Changelog

2010-09-29 - Gavin Carr <gavin@openfusion.com.au> 0.6.22-1
- Updated to 0.6.22.
2003-06-25 - Ian Macdonald <ian@caliban.org> 0.6.13-1
- 0.6.13
2003-05-28 - Ian Macdonald <ian@caliban.org> 0.6.11-3
- don't require ruby-optparse when building for Ruby 1.8
2002-03-26 - Ian Macdonald <ian@caliban.org>
- 0.6.11

See Also

Package Description
redis-2.4.15-1.of.el6.x86_64.rpm A persistent key-value database with a network interface
redis-2.4.8-1.of.el6.x86_64.rpm A persistent key-value database with a network interface
rpm-find-changes-0.6.2-1.of.el6.noarch.rpm Report files not belonging to an rpm, or that have changed from their rpm versions
rpm-find-changes-0.6.3-1.of.el6.noarch.rpm Report files not belonging to an rpm, or that have changed from their rpm versions
rubygem-POpen4-0.1.4-1.of.el6.noarch.rpm Open4 cross-platform
rubygem-Platform-0.4.0-1.of.el6.noarch.rpm Hopefully robust platform sensing
rubygem-RedCloth-4.2.9-1.of.el6.x86_64.rpm RedCloth-4.2.9
rubygem-SystemTimer-1.2.1-1.of.el6.x86_64.rpm Set a timeout based on signals, which are more reliable than Timeout
rubygem-actionmailer-3.1.0-1.of.el6.noarch.rpm Email composition, delivery, and receiving framework (part of Rails)
rubygem-actionmailer-3.2.6-1.of.el6.noarch.rpm Email composition, delivery, and receiving framework (part of Rails)
rubygem-actionpack-3.1.0-1.of.el6.noarch.rpm Web-flow and rendering framework putting the VC in MVC (part of Rails)
rubygem-actionpack-3.2.6-1.of.el6.noarch.rpm Web-flow and rendering framework putting the VC in MVC (part of Rails)
rubygem-activemodel-3.1.0-1.of.el6.noarch.rpm A toolkit for building modeling frameworks (part of Rails)
rubygem-activemodel-3.2.3-1.of.el6.noarch.rpm A toolkit for building modeling frameworks (part of Rails)
rubygem-activemodel-3.2.6-1.of.el6.noarch.rpm A toolkit for building modeling frameworks (part of Rails)
Advertisement
Advertisement