rubygem-columnize-0.3.4-1.of.el6.noarch.rpm


Advertisement

Description

rubygem-columnize - Read file with caching

Property Value
Distribution CentOS 6
Repository Open Fusion i386
Package filename rubygem-columnize-0.3.4-1.of.el6.noarch.rpm
Package name rubygem-columnize
Package version 0.3.4
Package release 1.of.el6
Package architecture noarch
Package type rpm
Category Development/Languages
Homepage http://rubyforge.org/projects/rocky-hacks/columnize
License GPLv2+ or Ruby
Maintainer -
Download size 80.36 KB
Installed size 222.21 KB
Return a list of strings as a set of arranged in columns.
For example, for a line width of 4 characters (arranged vertically):
['1', '2,', '3', '4'] => '1  3
2  4
'
or arranged horizontally:
['1', '2,', '3', '4'] => '1  2
3  4
'
Each column is only as wide as necessary.  By default, columns are
separated by two spaces - one was not legible enough. Set "colsep"
to adjust the string separate columns. Set `displaywidth' to set
the line width.
Normally, consecutive items go down from the top to bottom from
the left-most column to the right-most. If +arrange_vertical+ is
set false, consecutive items will go across, left to right, top to
bottom.

Alternatives

Package Version Architecture Repository
rubygem-columnize-0.3.4-1.of.el6.noarch.rpm 0.3.4 noarch Open Fusion
rubygem-columnize - - -

Requires

Name Value
/usr/bin/env -
rubygems -

Provides

Name Value
rubygem(columnize) = 0.3.4
rubygem-columnize = 0.3.4-1.of.el6

Download

Type URL
Mirror repo.openfusion.net
Binary Package rubygem-columnize-0.3.4-1.of.el6.noarch.rpm
Source Package rubygem-columnize-0.3.4-1.of.el6.src.rpm

Install Howto

  1. Download latest openfusion-release rpm from
    http://repo.openfusion.net/centos6-i386/
  2. Install openfusion-release rpm:
    # rpm -Uvh openfusion-release*rpm
  3. Install rubygem-columnize rpm package:
    # yum install rubygem-columnize

Files

Path
/usr/lib/ruby/gems/1.8/cache/columnize-0.3.4.gem
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/COPYING.html
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/Columnize.html
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/Object.html
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/README.html
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/created.rid
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/index.html
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/rdoc.css
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/brick.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/brick_link.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/bug.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/bullet_black.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/bullet_toggle_minus.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/bullet_toggle_plus.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/date.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/find.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/loadingAnimation.gif
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/macFFBgHack.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/package.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/page_green.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/page_white_text.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/page_white_width.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/plugin.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/ruby.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/tag_green.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/wrench.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/wrench_orange.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/images/zoom.png
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/js/darkfish.js
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/js/jquery.js
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/js/quicksearch.js
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/js/thickbox-compressed.js
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/lib/Makefile.html
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/lib/columnize_rb.html
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/rdoc/lib/version_rb.html
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/ri/cache.ri
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/ri/created.rid
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/ri/Columnize/cdesc-Columnize.ri
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/ri/Columnize/cell_size-i.ri
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/ri/Columnize/columnize-i.ri
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/ri/Columnize/parse_columnize_options-i.ri
/usr/lib/ruby/gems/1.8/doc/columnize-0.3.4/ri/Object/cdesc-Object.ri
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/.gitignore
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/AUTHORS
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/COPYING
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/ChangeLog
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/Makefile
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/NEWS
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/README
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/Rakefile
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/columnize.gemspec
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/.yardoc/checksums
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/.yardoc/proxy_types
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/.yardoc/objects/root.dat
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/lib/Makefile
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/lib/columnize.rb
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/lib/version.rb
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/test/test-columnize.rb
/usr/lib/ruby/gems/1.8/gems/columnize-0.3.4/test/test-hashparm.rb
/usr/lib/ruby/gems/1.8/specifications/columnize-0.3.4.gemspec

Changelog

2011-09-06 - Gavin Carr <gavin@openfusion.com.au> 0.3.4-1
- Update to version 0.3.4.
2010-05-24 - Gavin Carr <gavin@openfusion.com.au> - 0.3.1-1
- Initial package

See Also

Package Description
rubygem-configliere-0.4.8-1.of.el6.noarch.rpm Wise, discreet configuration management
rubygem-configuration-1.2.0-1.of.el6.noarch.rpm configuration
rubygem-connection_pool-0.9.1-1.of.el6.noarch.rpm Generic connection pool for Ruby
rubygem-contest-0.1.2-1.of.el6.noarch.rpm Write more readable tests in Test::Unit with this tiny script
rubygem-crack-0.1.8-1.of.el6.noarch.rpm Really simple JSON and XML parsing, ripped from Merb and Rails
rubygem-crack-0.3.1-1.of.el6.noarch.rpm Really simple JSON and XML parsing, ripped from Merb and Rails
rubygem-creole-0.4.2-1.of.el6.noarch.rpm Lightweight markup language
rubygem-cri-2.3.0-1.of.el6.noarch.rpm a library for building easy-to-use commandline tools
rubygem-daemons-1.1.0-1.of.el6.noarch.rpm A toolkit to create and control daemons in different ways
rubygem-daemons-1.1.4-1.of.el6.noarch.rpm A toolkit to create and control daemons in different ways
rubygem-data_objects-0.10.9-1.of.el6.noarch.rpm DataObjects basic API and shared driver specifications
rubygem-descriptive_statistics-1.0.1-1.of.el6.noarch.rpm Descriptive Statistics
rubygem-diff-lcs-1.1.2-1.of.el6.noarch.rpm Provides a list of changes that represent the difference between two sequenced collections
rubygem-diff-lcs-1.1.3-1.of.el6.noarch.rpm Provides a list of changes that represent the difference between two sequenced collections
rubygem-directory_watcher-1.4.1-1.of.el6.noarch.rpm A class for watching files within a directory and generating events when those files change
Advertisement
Advertisement