perl-Perl-MinimumVersion-1.28-1.of.el6.noarch.rpm


Advertisement

Description

perl-Perl-MinimumVersion - Find a minimum required version of perl for Perl code

Property Value
Distribution CentOS 6
Repository Open Fusion i386
Package filename perl-Perl-MinimumVersion-1.28-1.of.el6.noarch.rpm
Package name perl-Perl-MinimumVersion
Package version 1.28
Package release 1.of.el6
Package architecture noarch
Package type rpm
Category Development/Libraries
Homepage http://search.cpan.org/dist/Perl-MinimumVersion/
License GPL+ or Artistic
Maintainer -
Download size 30.23 KB
Installed size 74.06 KB
Perl::MinimumVersion takes Perl source code and calculates the minimum
version of perl required to be able to run it. Because it is based on PPI,
it can do this without having to actually load the code.

Alternatives

Package Version Architecture Repository
perl-Perl-MinimumVersion-1.28-1.of.el6.noarch.rpm 1.28 noarch Open Fusion
perl-Perl-MinimumVersion-1.20-3.el6.noarch.rpm 1.20 noarch CentOS
perl-Perl-MinimumVersion-1.20-3.el6.noarch.rpm 1.20 noarch CentOS
perl-Perl-MinimumVersion - - -

Requires

Name Value
perl(:MODULE_COMPAT_5.10.1) -
perl(File::Find::Rule) >= 0.32
perl(File::Find::Rule::Perl) >= 1.04
perl(PPI) >= 1.215
perl(Params::Util) >= 0.25
perl(Perl::Critic::Utils) >= 1.104
perl(version) >= 0.76

Provides

Name Value
perl(Perl::MinimumVersion) = 1.28
perl(Perl::MinimumVersion::Reason) = 1.28
perl-Perl-MinimumVersion = 1.28-1.of.el6

Download

Type URL
Mirror repo.openfusion.net
Binary Package perl-Perl-MinimumVersion-1.28-1.of.el6.noarch.rpm
Source Package perl-Perl-MinimumVersion-1.28-1.of.el6.src.rpm

Install Howto

  1. Download latest openfusion-release rpm from
    http://repo.openfusion.net/centos6-i386/
  2. Install openfusion-release rpm:
    # rpm -Uvh openfusion-release*rpm
  3. Install perl-Perl-MinimumVersion rpm package:
    # yum install perl-Perl-MinimumVersion

Files

Path
/usr/bin/perlver
/usr/share/doc/perl-Perl-MinimumVersion-1.28/Changes
/usr/share/doc/perl-Perl-MinimumVersion-1.28/LICENSE
/usr/share/doc/perl-Perl-MinimumVersion-1.28/README
/usr/share/man/man1/perlver.1.gz
/usr/share/man/man3/Perl::MinimumVersion.3pm.gz
/usr/share/perl5/vendor_perl/Perl/MinimumVersion.pm
/usr/share/perl5/vendor_perl/Perl/MinimumVersion/Reason.pm

Changelog

2011-11-25 - Gavin Carr <gavin@openfusion.com.au> 1.28-1
- Specfile autogenerated by cpanspec 1.79.

See Also

Package Description
perl-Perl-OSType-1.002-1.of.el6.noarch.rpm Map Perl operating system names to generic types
perl-Perl-OSType-1.002-4.of.el6.noarch.rpm Map Perl operating system names to generic types
perl-Perl-PrereqScanner-1.014-1.of.el6.noarch.rpm Tool to scan your Perl code for its prerequisites
perl-Perl-PrereqScanner-1.020-1.of.el6.noarch.rpm Tool to scan your Perl code for its prerequisites
perl-Perl-Tidy-20101217-1.of.el6.noarch.rpm Parses and beautifies perl source
perl-Perl-Tidy-20121207-1.of.el6.noarch.rpm Parses and beautifies perl source
perl-Perl-Tidy-20140711-1.of.el6.noarch.rpm Parses and beautifies perl source
perl-Perl-Version-1.011-1.of.el6.noarch.rpm Parse and manipulate Perl version strings
perl-Perl-Version-1.013-1.of.el6.noarch.rpm Parse and manipulate Perl version strings
perl-Perl6-Caller-0.100-1.of.el6.noarch.rpm OO caller() interface
perl-Perl6-Export-Attrs-0.0.3-1.of.el6.noarch.rpm Perl 6 'is export(...)' trait as a Perl 5 attribute
perl-Perl6-Junction-1.40000-1.of.el6.noarch.rpm Perl6 style Junction operators in Perl5
perl-Perl6-Junction-1.60000-1.of.el6.noarch.rpm Perl6 style Junction operators in Perl5
perl-Perl6-Say-0.16-1.of.el6.noarch.rpm Print(), but no newline needed
perl-Perl6-Slurp-0.050000-1.of.el6.noarch.rpm Implements the Perl 6 'slurp' built-in
Advertisement
Advertisement