pam_mount-2.5-2.el6.nux.x86_64.rpm


Advertisement

Description

pam_mount - A PAM module that can mount volumes for a user session

Distribution: CentOS 6
Repository: Nux Dextop x86_64
Package name: pam_mount
Package version: 2.5
Package release: 2.el6.nux
Package architecture: x86_64
Package type: rpm
Installed size: 316.19 KB
Download size: 119.53 KB
Official Mirror: li.nux.ro
This module is aimed at environments with central file servers that a user wishes to mount on login and unmount on logout, such as (semi-)diskless stations where many users can logon. The module also supports mounting local filesystems of any kind the normal mount utility supports, with extra code to make sure certain volumes are set up properly because often they need more than just a mount call, such as encrypted volumes. This includes SMB/CIFS, NCP, davfs2, FUSE, losetup crypto, dm-crypt/cryptsetup and truecrypt. If you intend to use pam_mount to protect volumes on your computer using an encrypted filesystem system, please know that there are many other issues you need to consider in order to protect your data. For example, you probably want to disable or encrypt your swap partition. Don't assume a system is secure without carefully considering potential threats.

Alternatives

Provides

  • config(pam_mount) = 2.5-2.el6.nux
  • pam_mount = 2.5-2.el6.nux
  • pam_mount(x86-64) = 2.5-2.el6.nux
  • pam_mount.so()(64bit)

    Download

    Install Howto

    1. Download the latest nux-dextop-release rpm from
      http://li.nux.ro/download/nux/dextop/el6/x86_64/
    2. Install nux-dextop-release rpm:
      # rpm -Uvh nux-dextop-release*rpm
    3. Install pam_mount rpm package:
      # yum install pam_mount

    Files

    • /etc/security/pam_mount.conf.xml
    • /lib64/security/pam_mount.so
    • /sbin/mount.crypt
    • /sbin/mount.crypto_LUKS
    • /sbin/mount.encfs13
    • /sbin/umount.crypt
    • /sbin/umount.crypto_LUKS
    • /usr/bin/pmt-fd0ssh
    • /usr/bin/pmt-ofl
    • /usr/sbin/pmt-ehd
    • /usr/sbin/pmvarrun
    • /usr/share/doc/pam_mount-2.5/LICENSE.GPL2
    • /usr/share/doc/pam_mount-2.5/LICENSE.GPL3
    • /usr/share/doc/pam_mount-2.5/LICENSE.LGPL2
    • /usr/share/doc/pam_mount-2.5/LICENSE.LGPL3
    • /usr/share/doc/pam_mount-2.5/bugs.txt
    • /usr/share/doc/pam_mount-2.5/changelog.txt
    • /usr/share/doc/pam_mount-2.5/faq.txt
    • /usr/share/doc/pam_mount-2.5/options.txt
    • /usr/share/doc/pam_mount-2.5/pam_mount.conf.xml
    • /usr/share/doc/pam_mount-2.5/todo.txt
    • /usr/share/man/man1/pmt-fd0ssh.1.gz
    • /usr/share/man/man5/pam_mount.conf.5.gz
    • /usr/share/man/man8/mount.crypt.8.gz
    • /usr/share/man/man8/mount.crypto_LUKS.8.gz
    • /usr/share/man/man8/pam_mount.8.gz
    • /usr/share/man/man8/pmt-ehd.8.gz
    • /usr/share/man/man8/pmvarrun.8.gz
    • /usr/share/man/man8/umount.crypt.8.gz
    • /usr/share/man/man8/umount.crypto_LUKS.8.gz
    • /usr/share/xml/pam_mount/
    • /usr/share/xml/pam_mount/dtd/pam_mount.conf.xml.dtd
    • /var/run/pam_mount/

    Changelog

    2011-02-08 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-2 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild

    2010-08-16 - Till Maas <opensource@till.name> - 2.5-1 - Update to lastest release - Update libHX dependency - remove upstreamed patches - do not package pam_mount.txt (RH #615714)

    2010-07-03 - Till Maas <opensource@till.name> - 2.4-2 - Add cryptsetup-luks-libs Requires - list all manpages explicitly

    2010-07-02 - Till Maas <opensource@till.name> - 2.4-1 - Update to new release - add patch to keep cmtab at /etc - add patch to use mount -t crypt instead of mount.crypt for crypto volumes - BR cryptsetup-luks-devel >= 1.1.2 - add man-db BR for Fedora >= 14 for pam_mount.8 to pam_mount.txt conversion - add Patch to remove man-db BR for Fedora < 14

    2010-05-19 - Till Maas <opensource@till.name> - 2.3-1 - Update to new release

    2010-05-16 - Till Maas <opensource@till.name> - 2.2-1 - Update to new release

    2010-05-16 - Till Maas <opensource@till.name> - 2.1-1 - Update to new release - Add BuildRequires: cryptsetup-luks-devel - Cleanup BRs - Add Requires: /bin/readlink - Update libHX dependency

    2010-01-04 - Till Maas <opensource@till.name> - 1.32-2 - Do not package compatibility symlinks anymore

    2009-09-24 - Till Maas <opensource@till.name> - 1.32-1 - Update to new release - Update libHX dependency

    2009-08-28 - Till Maas <opensource@till.name> - 1.30-2 - rebuilt with new openssl

    Advertisement
    Advertisement