libosip2-devel-3.6.0-5.el6.nux.x86_64.rpm


Advertisement

Description

libosip2-devel - Development libraries for oSIP

Property Value
Distribution CentOS 6
Repository Nux Dextop x86_64
Package name libosip2-devel
Package version 3.6.0
Package release 5.el6.nux
Package architecture x86_64
Package type rpm
Installed size 281.13 KB
Download size 48.79 KB
Official Mirror li.nux.ro
The GNU oSIP library is written in C and get no dependencies except the
standard C library. oSIP is thread safe and will generally be used in a
multi-threaded application. Nevertheless, this is optional.
oSIP is little in size and code and thus could be use to implement IP
soft-phone as well as embedded SIP software. oSIP is not limited to endpoint
agents, and can also be used to implement "SIP proxy".
oSIP does not intend to provide a high layer API for controlling "SIP Session"
at this step. Instead, it currently provides an API for the SIP message parser,
SDP message parser, and library to handle "SIP transactions" as defined by the
SIP document.

Alternatives

Package Version Architecture Repository
libosip2-devel-3.6.0-5.el6.nux.i686.rpm 3.6.0 i686 Nux Dextop
libosip2-devel-3.5.0-1.el6.rf.i686.rpm 3.5.0 i686 Repoforge (RPMforge)
libosip2-devel-3.5.0-1.el6.rf.x86_64.rpm 3.5.0 x86_64 Repoforge (RPMforge)
libosip2-devel-2.2.0-1.2.el6.rf.i686.rpm 2.2.0 i686 Repoforge (RPMforge)
libosip2-devel-2.2.0-1.2.el6.rf.x86_64.rpm 2.2.0 x86_64 Repoforge (RPMforge)
libosip2-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
libosip2 = 3.6.0-5.el6.nux
libosip2.so.7()(64bit) -
libosipparser2.so.7()(64bit) -

Provides

Name Value
libosip2-devel = 3.6.0-5.el6.nux
libosip2-devel(x86-64) = 3.6.0-5.el6.nux
pkgconfig(libosip2) = 3.6.0

Download

Type URL
Binary Package libosip2-devel-3.6.0-5.el6.nux.x86_64.rpm
Source Package libosip2-3.6.0-5.el6.nux.src.rpm

Install Howto

  1. Download the latest nux-dextop-release rpm from
    http://li.nux.ro/download/nux/dextop/el6/x86_64/
  2. Install nux-dextop-release rpm:
    # rpm -Uvh nux-dextop-release*rpm
  3. Install libosip2-devel rpm package:
    # yum install libosip2-devel

Files

Path
/usr/include/osip2/osip.h
/usr/include/osip2/osip_condv.h
/usr/include/osip2/osip_dialog.h
/usr/include/osip2/osip_fifo.h
/usr/include/osip2/osip_mt.h
/usr/include/osip2/osip_time.h
/usr/include/osipparser2/osip_body.h
/usr/include/osipparser2/osip_const.h
/usr/include/osipparser2/osip_headers.h
/usr/include/osipparser2/osip_list.h
/usr/include/osipparser2/osip_md5.h
/usr/include/osipparser2/osip_message.h
/usr/include/osipparser2/osip_parser.h
/usr/include/osipparser2/osip_port.h
/usr/include/osipparser2/osip_uri.h
/usr/include/osipparser2/sdp_message.h
/usr/include/osipparser2/headers/osip_accept.h
/usr/include/osipparser2/headers/osip_accept_encoding.h
/usr/include/osipparser2/headers/osip_accept_language.h
/usr/include/osipparser2/headers/osip_alert_info.h
/usr/include/osipparser2/headers/osip_allow.h
/usr/include/osipparser2/headers/osip_authentication_info.h
/usr/include/osipparser2/headers/osip_authorization.h
/usr/include/osipparser2/headers/osip_call_id.h
/usr/include/osipparser2/headers/osip_call_info.h
/usr/include/osipparser2/headers/osip_contact.h
/usr/include/osipparser2/headers/osip_content_disposition.h
/usr/include/osipparser2/headers/osip_content_encoding.h
/usr/include/osipparser2/headers/osip_content_length.h
/usr/include/osipparser2/headers/osip_content_type.h
/usr/include/osipparser2/headers/osip_cseq.h
/usr/include/osipparser2/headers/osip_error_info.h
/usr/include/osipparser2/headers/osip_from.h
/usr/include/osipparser2/headers/osip_header.h
/usr/include/osipparser2/headers/osip_mime_version.h
/usr/include/osipparser2/headers/osip_proxy_authenticate.h
/usr/include/osipparser2/headers/osip_proxy_authentication_info.h
/usr/include/osipparser2/headers/osip_proxy_authorization.h
/usr/include/osipparser2/headers/osip_record_route.h
/usr/include/osipparser2/headers/osip_route.h
/usr/include/osipparser2/headers/osip_to.h
/usr/include/osipparser2/headers/osip_via.h
/usr/include/osipparser2/headers/osip_www_authenticate.h
/usr/lib64/libosip2.so
/usr/lib64/libosipparser2.so
/usr/lib64/pkgconfig/libosip2.pc
/usr/share/man/man1/osip2.1.gz

Changelog

See libosip2-3.6.0-5.el6.nux.x86_64.rpm changelog.

See Also

Package Description
libpano13-2.9.18-7.el6.nux.x86_64.rpm Library for manipulating panoramic images
libpano13-devel-2.9.18-7.el6.nux.x86_64.rpm Development tools for programs which will use the libpano13 library
libpano13-tools-2.9.18-7.el6.nux.x86_64.rpm Tools that use the libpano13 library
libprojectM-2.0.1-7.el6.nux.x86_64.rpm The libraries for the projectM music visualization plugin
libprojectM-devel-2.0.1-7.el6.nux.x86_64.rpm Development files for libprojectM
libprojectM-qt-2.0.1-2.el6.nux.x86_64.rpm The Qt frontend to the projectM visualization plugin
libprojectM-qt-devel-2.0.1-2.el6.nux.x86_64.rpm Development files for libprojectM-qt
libquicktime-1.2.2-2.el6.nux.x86_64.rpm Library for reading and writing Quicktime files
libquicktime-1.2.3-3.el6.nux.x86_64.rpm Library for reading and writing Quicktime files
libquicktime-1.2.4-1.el6.nux.x86_64.rpm Library for reading and writing Quicktime files
libquicktime-1.2.4-19.el6.nux.x86_64.rpm Library for reading and writing Quicktime files
libquicktime-1.2.4-2.el6.nux.x86_64.rpm Library for reading and writing Quicktime files
libquicktime-devel-1.2.2-2.el6.nux.x86_64.rpm Development files for libquicktime
libquicktime-devel-1.2.3-3.el6.nux.x86_64.rpm Development files for libquicktime
libquicktime-devel-1.2.4-1.el6.nux.x86_64.rpm Development files for libquicktime
Advertisement
Advertisement