chrome-deps-stable-3.11-1.x86_64.rpm


Advertisement

Description

chrome-deps-stable - Dependencies required for Google Chrome 28+ on RHEL/CentOS 6 derivatives

Property Value
Distribution CentOS 6
Repository Nux Dextop x86_64
Package name chrome-deps-stable
Package version 3.11
Package release 1
Package architecture x86_64
Package type rpm
Installed size 1.54 MB
Download size 367.32 KB
Official Mirror li.nux.ro
Includes an later libstdc++ Library, a shared library
(libgnome-keyring.so.0) and a soft-link to load in the original
libgnome-keyring.so.0 system library. Also modifies Google Chrome's
/opt/google/chrome/google-chrome wrapper script to allow
Google Chrome 28 or later to run on RHEL/CentOS 6 derivatives.
The URL for the script that downloaded and re-packaged the
later libstdc++ library in this RPM is
http://chrome.richardlloyd.org.uk/install_chrome.sh
and it is in the public domain.

Alternatives

Package Version Architecture Repository
chrome-deps-stable-3.11-1.i386.rpm 3.11 i386 Nux Dextop
chrome-deps-stable - - -

Requires

Name Value
/bin/bash -
ld-linux-x86-64.so.2()(64bit) -
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.2)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_3.3)(64bit) -
libgcc_s.so.1(GCC_4.2.0)(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
/opt/google/chrome/lib/link-to-libgnome-keyring.so.0()(64bit) -
chrome-deps-stable = 3.11-1
chrome-deps-stable(x86-64) = 3.11-1
libgnome-keyring.so.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.1)(64bit) -
libstdc++.so.6(CXXABI_1.3.2)(64bit) -
libstdc++.so.6(CXXABI_1.3.3)(64bit) -
libstdc++.so.6(CXXABI_1.3.4)(64bit) -
libstdc++.so.6(CXXABI_1.3.5)(64bit) -
libstdc++.so.6(CXXABI_1.3.6)(64bit) -
libstdc++.so.6(CXXABI_1.3.7)(64bit) -
libstdc++.so.6(CXXABI_1.3.8)(64bit) -
libstdc++.so.6(CXXABI_1.3.9)(64bit) -
libstdc++.so.6(CXXABI_FLOAT128)(64bit) -
libstdc++.so.6(CXXABI_TM_1)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.1)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.10)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.12)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.13)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.15)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.16)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.17)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.18)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.19)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.2)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.20)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.21)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.4)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.5)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.6)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.7)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.8)(64bit) -
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) -

Obsoletes

Name Value
chrome-deps -

Download

Type URL
Binary Package chrome-deps-stable-3.11-1.x86_64.rpm
Source Package chrome-deps-stable-3.11-1.src.rpm

Install Howto

  1. Download latest nux-dextop-release rpm from
    http://li.nux.ro/download/nux/dextop/el6/x86_64/
  2. Install nux-dextop-release rpm:
    # rpm -Uvh nux-dextop-release*rpm
  3. Install chrome-deps-stable rpm package:
    # yum install chrome-deps-stable

Files

Path
/opt/google/chrome/modify_wrapper
/opt/google/chrome/lib/libgnome-keyring.so.0
/opt/google/chrome/lib/libstdc++.so.6
/opt/google/chrome/lib/link-to-libgnome-keyring.so.0

Changelog

2015-02-23 - Richard K. Lloyd <rklloyd@gmail.com> - 3.11-1
- Added a Provides: line to avoid an RPM dependency issue.
2015-02-06 - Richard K. Lloyd <rklloyd@gmail.com> - 3.10-1
- LD_PRELOAD unset_var.so library finally removed.
- Created new single-function libgnome-keyring.so.0 library.
- Added link-to-libgnome-keyring.so.0 soft-link to bring in
functions from system-installed libgnome-keyring.so.0.
2015-02-02 - Richard K. Lloyd <rklloyd@gmail.com> - 3.00-1
- Removed all patched Fedora libraries.
- Added an unpatched libstdc++ library (from gcc or CentOS 7).
2014-08-29 - Richard K. Lloyd <rklloyd@gmail.com> - 2.10-1
- Added "Obsoletes: chrome-deps" to spec file.
- Redirected stdout/stderr to /dev/null in google-chrome script.
2014-07-27 - Richard K. Lloyd <rklloyd@gmail.com> - 2.00-1
- Scan for all three RPM types in /etc/defaults/chrome.
2014-05-17 - Richard K. Lloyd <rklloyd@gmail.com> - 1.21-1
- Unset LD_LIBRARY_PATH for self-calls to the google-chrome script
Fedora @KEYRINGVER@ RPM.
2014-04-12 - Richard K. Lloyd <rklloyd@gmail.com> - 1.20-1
- Added libgnome-keyring.so.0, extracted from the libgnome-keyring
Fedora @KEYRINGVER@ RPM.
2013-12-11 - Richard K. Lloyd <rklloyd@gmail.com> - 1.10-1
- Additionally saved/unset/restored the LD_PRELOAD environmental
variable in unset_var.c to stop exec'ed() processes using it.
2013-10-05 - Richard K. Lloyd <rklloyd@gmail.com> - 1.03-1
- Added libgdk_pixbuf-2.0.so.0, extracted from the gdk-pixbuf2
Fedora  RPM.
2013-10-04 - Richard K. Lloyd <rklloyd@gmail.com> - 1.02-1
- Added libgio-2.0 and libgobject-2.0 to the set of included
Fedora  libraries.

See Also

Package Description
cinepaint-0.25.0-0.1.el6.nux.x86_64.rpm CinePaint is a tool for manipulating images
cinepaint-devel-0.25.0-0.1.el6.nux.x86_64.rpm Development package for cinepaint
cinepaint-libs-0.25.0-0.1.el6.nux.x86_64.rpm Libraries for cinepaint
clementine-0.7.1-1.el6.nux.x86_64.rpm A music player and library organizer
clementine-1.0.1-5.el6.nux.x86_64.rpm A music player and library organizer
clementine-1.0.1-6.el6.nux.x86_64.rpm A music player and library organizer
clementine-1.0.1-7.el6.nux.x86_64.rpm A music player and library organizer
clipgrab-3.2.0.11-1.el6.nux.x86_64.rpm Video downloader
clipgrab-3.2.0.7-1.el6.nux.x86_64.rpm Video downloader
clipgrab-3.2.0.8-1.el6.nux.x86_64.rpm Video downloader
clipgrab-3.2.0.9-1.el6.nux.x86_64.rpm Video downloader
clipgrab-3.2.1.2-1.el6.nux.x86_64.rpm Video downloader
clive-2.3.3-4.el6.nux.noarch.rpm Video extraction tool for user-uploaded video hosts
color-filesystem-1-6.noarch.rpm Color filesystem layout
comedilib-0.8.1-7.el6.nux.x86_64.rpm Data Acquisition library for the Comedi driver
Advertisement
Advertisement