rubygem-cairo-1.10.0-3.el6.nux.i686.rpm


Advertisement

Description

rubygem-cairo - Ruby bindings for cairo

Property Value
Distribution CentOS 6
Repository Nux Dextop i386
Package name rubygem-cairo
Package version 1.10.0
Package release 3.el6.nux
Package architecture i686
Package type rpm
Installed size 301.78 KB
Download size 151.41 KB
Official Mirror li.nux.ro
Ruby bindings for cairo. Cairo is a 2D graphics library with support for
multiple output devices. Currently supported output targets include the
X Window System, win32, and image buffers.

Alternatives

Package Version Architecture Repository
rubygem-cairo-1.10.0-3.el6.nux.x86_64.rpm 1.10.0 x86_64 Nux Dextop
rubygem-cairo - - -

Requires

Name Value
libc.so.6(GLIBC_2.4) -
libcairo.so.2 -
libcrypt.so.1 -
libdl.so.2 -
libm.so.6 -
libpthread.so.0 -
librt.so.1 -
libruby.so.1.8 -
rtld(GNU_HASH) -
ruby(abi) = 1.8
ruby(rubygems) -

Provides

Name Value
cairo.so -
rubygem(cairo) = 1.10.0-3.el6.nux
rubygem-cairo = 1.10.0-3.el6.nux
rubygem-cairo(x86-32) = 1.10.0-3.el6.nux

Download

Type URL
Binary Package rubygem-cairo-1.10.0-3.el6.nux.i686.rpm
Source Package rubygem-cairo-1.10.0-3.el6.nux.src.rpm

Install Howto

  1. Download the latest nux-dextop-release rpm from
    http://li.nux.ro/download/nux/dextop/el6/i386/
  2. Install nux-dextop-release rpm:
    # rpm -Uvh nux-dextop-release*rpm
  3. Install rubygem-cairo rpm package:
    # yum install rubygem-cairo

Files

Path
/usr/lib/ruby/gems/1.8/cache/cairo-1.10.0.gem
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/AUTHORS
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/COPYING
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/GPL
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/NEWS
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/color.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/colors.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/constants.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/context.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/paper.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/papers.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/path.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/point.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/context/blur.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/context/circle.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/context/color.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/context/path.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/context/rectangle.rb
/usr/lib/ruby/gems/1.8/gems/cairo-1.10.0/lib/cairo/context/triangle.rb
/usr/lib/ruby/gems/1.8/specifications/cairo-1.10.0.gemspec
/usr/lib/ruby/site_ruby/1.8/i386-linux/cairo/cairo.so

Changelog

2010-10-31 - Mamoru Taska  <mtasaka@ioa.s.u-tokyo.ac.jp> 1.10.0-3
- Move C extension so that "require %gemname" works correctly
2010-10-05 - Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 1.10.0-2
- Install one font at BuildRequires for test
2010-09-19 - Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 1.10.0-1
- Update to 1.10.0
2010-09-03 - Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 1.8.5-2
- Switch to gem
- Fix license tag
2010-09-02 - Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> 1.8.5-1
- Update to 1.8.5
2009-12-16 - Allisson Azevedo <allisson@gmail.com> 1.8.1-1
- Update to 1.8.1
2009-07-26 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.0-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
2009-02-25 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.0-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
2009-01-23 - Allisson Azevedo <allisson@gmail.com> 1.8.0-2
- Rebuild
2008-10-05 - Allisson Azevedo <allisson@gmail.com> 1.8.0-1
- Update to 1.8.0

See Also

Package Description
rubygem-cairo-devel-1.10.0-3.el6.nux.i686.rpm Ruby-cairo development environment
rubygem-cairo-doc-1.10.0-3.el6.nux.i686.rpm Documentation for rubygem-cairo
rubygem-glib2-0.90.5-3.el6.nux.i686.rpm Ruby binding of GLib-2.x
rubygem-glib2-devel-0.90.5-3.el6.nux.i686.rpm Ruby/GLib development environment
rubygem-glib2-doc-0.90.5-3.el6.nux.i686.rpm Documentation for rubygem-glib2
rubygem-gtk2-0.90.5-3.el6.nux.i686.rpm Ruby binding of GTK+-2.x
rubygem-gtk2-devel-0.90.5-3.el6.nux.i686.rpm Ruby/GTK development environment
rubygem-gtk2-doc-0.90.5-3.el6.nux.i686.rpm Documentation for rubygem-gtk2
rubygem-hoe-2.9.1-1.el6.nux.noarch.rpm Hoe is a simple rake/rubygems helper for project Rakefiles
rubygem-hoe-doc-2.9.1-1.el6.nux.noarch.rpm Documentation for rubygem-hoe
rubygem-pango-0.90.5-2.el6.nux.i686.rpm Ruby binding of pango-1.x
rubygem-pango-devel-0.90.5-2.el6.nux.i686.rpm Ruby/pango development environment
rubygem-pango-doc-0.90.5-2.el6.nux.i686.rpm Documentation for rubygem-pango
rubygem-pkg-config-1.0.7-1.el6.nux.noarch.rpm A pkg-config implmenetation by Ruby
rubygem-pkg-config-doc-1.0.7-1.el6.nux.noarch.rpm Documentation for rubygem-pkg-config
Advertisement
Advertisement