phantomjs-1.6.0-4.el6.nux.i686.rpm


Advertisement

Description

phantomjs - PhantomJS is a headless WebKit with JavaScript API

Distribution: CentOS 6
Repository: Nux Dextop i386
Package name: phantomjs
Package version: 1.6.0
Package release: 4.el6.nux
Package architecture: i686
Package type: rpm
Installed size: 93.79 MB
Download size: 20.67 MB
Official Mirror: li.nux.ro
PhantomJS is a headless WebKit with JavaScript API. It has fast and native support for various web standards: DOM handling, CSS selector, JSON, Canvas, and SVG. PhantomJS is created by Ariya Hidayat.

Provides

  • libQtCore.so.4
  • libQtGui.so.4
  • libQtNetwork.so.4
  • libQtWebKit.so.4
  • libQtXml.so.4
  • phantomjs = 1.6.0-4.el6.nux
  • phantomjs(x86-32) = 1.6.0-4.el6.nux

    Install Howto

    1. Download the latest nux-dextop-release rpm from
      http://li.nux.ro/download/nux/dextop/el6/i386/
    2. Install nux-dextop-release rpm:
      # rpm -Uvh nux-dextop-release*rpm
    3. Install phantomjs rpm package:
      # yum install phantomjs

    Files

    • /usr/bin/phantomjs
    • /usr/bin/phantomjs.program
    • /usr/lib/phantomjs-qt/libQtCore.so
    • /usr/lib/phantomjs-qt/libQtCore.so.4
    • /usr/lib/phantomjs-qt/libQtCore.so.4.8
    • /usr/lib/phantomjs-qt/libQtCore.so.4.8.2
    • /usr/lib/phantomjs-qt/libQtGui.so
    • /usr/lib/phantomjs-qt/libQtGui.so.4
    • /usr/lib/phantomjs-qt/libQtGui.so.4.8
    • /usr/lib/phantomjs-qt/libQtGui.so.4.8.2
    • /usr/lib/phantomjs-qt/libQtNetwork.so
    • /usr/lib/phantomjs-qt/libQtNetwork.so.4
    • /usr/lib/phantomjs-qt/libQtNetwork.so.4.8
    • /usr/lib/phantomjs-qt/libQtNetwork.so.4.8.2
    • /usr/lib/phantomjs-qt/libQtWebKit.so
    • /usr/lib/phantomjs-qt/libQtWebKit.so.4
    • /usr/lib/phantomjs-qt/libQtWebKit.so.4.9
    • /usr/lib/phantomjs-qt/libQtWebKit.so.4.9.2
    • /usr/lib/phantomjs-qt/libQtXml.so
    • /usr/lib/phantomjs-qt/libQtXml.so.4
    • /usr/lib/phantomjs-qt/libQtXml.so.4.8
    • /usr/lib/phantomjs-qt/libQtXml.so.4.8.2
    • /usr/lib/phantomjs-qt/libjscore.a
    • /usr/lib/phantomjs-qt/libwebcore.a

    Changelog

    2012-08-05 - Nux <rpm@li.nux.ro> - 1.6.0-2 - 0-phantomjs-qt.conf in ld.so.conf.d breaks existing Qt apps; working around it via a wrapper and LD_LIBRARY_PATH

    2012-07-04 - Nux <rpm@li.nux.ro> - 1.6.0-1 - update to 1.6.0 - updated spec with proper Group, BuildRequires

    2012-04-18 - Simon Josi <me@yokto.net> - 1.5.0-1 - Package PhantomJS 1.5.0.

    Advertisement
    Advertisement