v8-3.14.5.10-25.el6.x86_64.rpm


Advertisement

Description

v8 - JavaScript Engine

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name v8
Package version 3.14.5.10
Package release 25.el6
Package architecture x86_64
Package type rpm
Installed size 10.32 MB
Download size 3.03 MB
Official Mirror dl.fedoraproject.org
V8 is Google's open source JavaScript engine. V8 is written in C++ and is used
in Google Chrome, the open source browser from Google. V8 implements ECMAScript
as specified in ECMA-262, 3rd edition.

Alternatives

Package Version Architecture Repository
v8-3.14.5.10-25.el6.i686.rpm 3.14.5.10 i686 EPEL
v8-3.14.5.10-25.el6.i686.rpm 3.14.5.10 i686 EPEL
v8-3.14.5.10-17.sdl6.i686.rpm 3.14.5.10 i686 PUIAS Unsupported
v8-3.14.5.10-17.sdl6.x86_64.rpm 3.14.5.10 x86_64 PUIAS Unsupported
v8-3.14.5.8-1.el6.art.i686.rpm 3.14.5.8 i686 Atomic
v8-3.14.5.8-1.el6.art.x86_64.rpm 3.14.5.8 x86_64 Atomic
v8-3.13.7.5-1.el6.art.i686.rpm 3.13.7.5 i686 Atomic
v8-3.13.7.5-1.el6.art.x86_64.rpm 3.13.7.5 x86_64 Atomic
v8-3.9.19.0-1.el6.R.i686.rpm 3.9.19.0 i686 Russian Fedora Free Updates
v8-3.9.19.0-1.el6.R.i686.rpm 3.9.19.0 i686 Russian Fedora Free Updates
v8-3.9.19.0-1.el6.R.x86_64.rpm 3.9.19.0 x86_64 Russian Fedora Free Updates
v8-3.9.1.0-1.el6.R.i686.rpm 3.9.1.0 i686 Russian Fedora Free
v8-3.9.1.0-1.el6.R.i686.rpm 3.9.1.0 i686 Russian Fedora Free
v8-3.9.1.0-1.el6.R.x86_64.rpm 3.9.1.0 x86_64 Russian Fedora Free
v8 - - -

Requires

Name Value
/sbin/ldconfig -
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libgcc_s.so.1(GCC_3.4)(64bit) -
libicudata.so.42()(64bit) -
libicui18n.so.42()(64bit) -
libicuuc.so.42()(64bit) -
libm.so.6()(64bit) -
libm.so.6(GLIBC_2.2.5)(64bit) -
libpthread.so.0()(64bit) -
libpthread.so.0(GLIBC_2.2.5)(64bit) -
libreadline.so.6()(64bit) -
librt.so.1()(64bit) -
librt.so.1(GLIBC_2.2.5)(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(CXXABI_1.3)(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
libv8.so.3()(64bit) -
libv8preparser.so.3()(64bit) -
v8 = 3.14.5.10-25.el6
v8(x86-64) = 3.14.5.10-25.el6
v8-314 = 3.14.5.10

Download

Type URL
Binary Package v8-3.14.5.10-25.el6.x86_64.rpm
Source Package v8-3.14.5.10-25.el6.src.rpm

Install Howto

  1. Download the latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install v8 rpm package:
    # yum install v8

Files

Path
/usr/bin/d8
/usr/lib64/libv8.so.3
/usr/lib64/libv8.so.3.14
/usr/lib64/libv8.so.3.14.5
/usr/lib64/libv8preparser.so.3
/usr/lib64/libv8preparser.so.3.14
/usr/lib64/libv8preparser.so.3.14.5
/usr/share/doc/v8-3.14.5.10/AUTHORS
/usr/share/doc/v8-3.14.5.10/ChangeLog
/usr/share/doc/v8-3.14.5.10/LICENSE

Changelog

2016-07-26 - Tom Callaway <spot@fedoraproject.org> 1:3.14.5.10-25
- provide v8-314 provides
- add fix for CVE-2016-1669
2016-06-06 - Vít Ondruch <vondruch@redhat.com> - 1:3.14.5.10-24
- Use "-fno-delete-null-pointer-checks" to workaround GCC 6.x compatibility
(rhbz#1331480, rhbz#1331458).
2016-02-05 - Fedora Release Engineering <releng@fedoraproject.org> - 1:3.14.5.10-23
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
2015-10-28 - David Tardon <dtardon@redhat.com> - 1:3.14.5.10-22
- rebuild for ICU 56.1
2015-09-21 - Tom Callaway <spot@fedoraproject.org> - 1:3.14.5.10-21
- add REPLACE_INVALID_UTF8 code needed for nodejs
2015-06-19 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:3.14.5.10-20
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
2015-06-08 - Tom Callaway <spot@fedoraproject.org> - 1:3.14.5.10-19
- split off python subpackage (bz 959145)
2015-04-23 - Tom Callaway <spot@fedoraproject.org> - 1:3.14.5.10-18
- backport security fix for ARM - CVE-2014-3152
2015-02-19 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1:3.14.5.10-17
- backports for nodejs 0.10.36
2015-01-26 - David Tardon <dtardon@redhat.com> - 1:3.14.5.10-16
- rebuild for ICU 54.1

See Also

Package Description
v8-devel-3.14.5.10-25.el6.i686.rpm Development headers and libraries for v8
v8-devel-3.14.5.10-25.el6.x86_64.rpm Development headers and libraries for v8
v8-python-3.14.5.10-25.el6.x86_64.rpm Python libraries from v8
vala-0.10.4-1.el6.i686.rpm A modern programming language for GNOME
vala-0.10.4-1.el6.x86_64.rpm A modern programming language for GNOME
vala-devel-0.10.4-1.el6.i686.rpm Development files for vala
vala-devel-0.10.4-1.el6.x86_64.rpm Development files for vala
vala-doc-0.10.4-1.el6.noarch.rpm Documentation for vala
vala-tools-0.10.4-1.el6.x86_64.rpm Tools for creating projects and bindings for vala
validns-0.8-1.el6.x86_64.rpm DNS and DNSSEC zone file validator
valkyrie-2.0.0-5.el6.x86_64.rpm Graphical User Interface for Valgrind Suite
vamp-plugin-sdk-2.1-1.el6.i686.rpm An API for audio analysis and feature extraction plugins
vamp-plugin-sdk-2.1-1.el6.x86_64.rpm An API for audio analysis and feature extraction plugins
vamp-plugin-sdk-devel-2.1-1.el6.i686.rpm Development files for vamp-plugin-sdk
vamp-plugin-sdk-devel-2.1-1.el6.x86_64.rpm Development files for vamp-plugin-sdk
Advertisement
Advertisement