pax-utils-1.2.3-1.el6.x86_64.rpm


Advertisement

Description

pax-utils - ELF utils that can check files for security relevant properties

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name pax-utils
Package version 1.2.3
Package release 1.el6
Package architecture x86_64
Package type rpm
Installed size 244.83 KB
Download size 90.28 KB
Official Mirror dl.fedoraproject.org
pax-utils is a small set of utilities for peforming Q/A (mostly security)
checks on systems (most notably, `scanelf`).  It is focused on the ELF
format, but does include a Mach-O helper too for OS X systems.
While heavily integrated into Gentoo's build system, it can be used on any
distro as it is a generic toolset.
Originally focused only on [PaX](https://pax.grsecurity.net/), it has been
expanded to be generally security focused.  It still has a good number of
PaX helpers for people interested in that.

Alternatives

Package Version Architecture Repository
pax-utils-1.2.3-1.el6.i686.rpm 1.2.3 i686 EPEL
pax-utils - - -

Requires

Name Value
/bin/bash -
libc.so.6(GLIBC_2.7)(64bit) -
libcap.so.2()(64bit) -
rtld(GNU_HASH) -

Provides

Name Value
pax-utils = 1.2.3-1.el6
pax-utils(x86-64) = 1.2.3-1.el6

Download

Type URL
Binary Package pax-utils-1.2.3-1.el6.x86_64.rpm
Source Package pax-utils-1.2.3-1.el6.src.rpm

Install Howto

  1. Download latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install pax-utils rpm package:
    # yum install pax-utils

Files

Path
/usr/bin/dumpelf
/usr/bin/lddtree
/usr/bin/pspax
/usr/bin/scanelf
/usr/bin/scanmacho
/usr/bin/symtree
/usr/share/doc/pax-utils-1.2.3/BUGS
/usr/share/doc/pax-utils-1.2.3/COPYING
/usr/share/doc/pax-utils-1.2.3/README.md
/usr/share/doc/pax-utils-1.2.3/TODO
/usr/share/man/man1/dumpelf.1.gz
/usr/share/man/man1/pspax.1.gz
/usr/share/man/man1/scanelf.1.gz
/usr/share/man/man1/scanmacho.1.gz

Changelog

2018-03-06 - Dominik Mierzejewski <rpm@greysector.net> - 1.2.3-1
- update to 1.2.3 (#1548693)
- switch to HTTPS URLs
- drop some obsolete workarounds
2017-04-08 - Dominik Mierzejewski <rpm@greysector.net> - 1.2.2-3
- add EPEL support
- update URL
2017-02-11 - Fedora Release Engineering <releng@fedoraproject.org> - 1.2.2-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
2017-01-25 - Dominik Mierzejewski <rpm@greysector.net> - 1.2.2-1
- update to 1.2.2
2016-11-13 - Dominik Mierzejewski <rpm@greysector.net> - 1.1.7-1
- update to 1.1.7 (#1394478)
- use license macro
- drop redundant defattr
- update summary and description
2016-03-06 - Dominik Mierzejewski <rpm@greysector.net> - 1.1.6-1
- update to 1.1.6 (#1314760)
2016-02-15 - Dominik Mierzejewski <rpm@greysector.net> - 1.1.5-1
- update to 1.1.5 (#1306483)
2016-02-04 - Fedora Release Engineering <releng@fedoraproject.org> - 1.1.4-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
2015-11-29 - Dominik Mierzejewski <rpm@greysector.net> - 1.1.4-1
- update to 1.1.4 (#1286232)
- drop no longer needed patch
2015-07-31 - Dominik Mierzejewski <rpm@greysector.net> - 1.0.5-1
- update to 1.0.5 (#1242478)

See Also

Package Description
pbstop-4.16-10.el6.x86_64.rpm Full-screen curses monitor for PBS
pbzip2-1.1.12-1.el6.x86_64.rpm Parallel implementation of bzip2
pcapy-0.10.5-6.el6.x86_64.rpm A Python interface to libpcap
pcc-1.1.0-1.1.20180504cvs.el6.x86_64.rpm The Portable C Compiler
pcl-1.7.1-8.el6.i686.rpm Library for point cloud processing
pcl-1.7.1-8.el6.x86_64.rpm Library for point cloud processing
pcl-devel-1.7.1-8.el6.i686.rpm Development files for pcl
pcl-devel-1.7.1-8.el6.x86_64.rpm Development files for pcl
pcl-doc-1.7.1-8.el6.noarch.rpm PCL API documentation
pcl-tools-1.7.1-8.el6.x86_64.rpm Point cloud tools and viewers
pcllib-1.12-1.el6.i686.rpm Portable Coroutine Library (PCL)
pcllib-1.12-1.el6.x86_64.rpm Portable Coroutine Library (PCL)
pcllib-devel-1.12-1.el6.i686.rpm Development headers and libraries for pcllib
pcllib-devel-1.12-1.el6.x86_64.rpm Development headers and libraries for pcllib
pcre2-10.21-22.el6.i686.rpm Perl-compatible regular expression library
Advertisement
Advertisement