nodejs-should-3.3.1-2.el6.noarch.rpm


Advertisement

Description

nodejs-should - A test framework agnostic BDD-style assertions for Node.js

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name nodejs-should
Package version 3.3.1
Package release 2.el6
Package architecture noarch
Package type rpm
Installed size 129.09 KB
Download size 32.01 KB
Official Mirror dl.fedoraproject.org
should is an expressive, readable, test framework agnostic, behavior-driven
development (BDD)-style assertion library for Node.js.
It extends the Object prototype with a single non-enumerable getter that
allows you to express how that object should behave.
should literally extends Node's assert module. For example,
should.equal(str, 'foo') will work, just as assert.equal(str, 'foo') would,
and should.AssertionError is assert.AssertionError, meaning any test framework
supporting this constructor will function properly with should.

Alternatives

Package Version Architecture Repository
nodejs-should-3.3.1-2.sdl6.noarch.rpm 3.3.1 noarch PUIAS Unsupported
nodejs-should-3.3.1-2.sdl6.noarch.rpm 3.3.1 noarch PUIAS Unsupported
nodejs-should-3.3.1-2.el6.noarch.rpm 3.3.1 noarch EPEL
nodejs-should - - -

Requires

Name Value
nodejs(engine) -

Provides

Name Value
nodejs-should = 3.3.1-2.el6
npm(should) = 3.3.1

Download

Type URL
Binary Package nodejs-should-3.3.1-2.el6.noarch.rpm
Source Package nodejs-should-3.3.1-2.el6.src.rpm

Install Howto

  1. Download the latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install nodejs-should rpm package:
    # yum install nodejs-should

Files

Path
/usr/lib/node_modules/should/index.js
/usr/lib/node_modules/should/package.json
/usr/lib/node_modules/should/should.js
/usr/lib/node_modules/should/lib/browser.js
/usr/lib/node_modules/should/lib/eql.js
/usr/lib/node_modules/should/lib/node.js
/usr/lib/node_modules/should/lib/should.js
/usr/lib/node_modules/should/lib/util.js
/usr/lib/node_modules/should/lib/ext/assert.js
/usr/lib/node_modules/should/lib/ext/bool.js
/usr/lib/node_modules/should/lib/ext/chain.js
/usr/lib/node_modules/should/lib/ext/deprecated.js
/usr/lib/node_modules/should/lib/ext/eql.js
/usr/lib/node_modules/should/lib/ext/error.js
/usr/lib/node_modules/should/lib/ext/http.js
/usr/lib/node_modules/should/lib/ext/match.js
/usr/lib/node_modules/should/lib/ext/number.js
/usr/lib/node_modules/should/lib/ext/property.js
/usr/lib/node_modules/should/lib/ext/string.js
/usr/lib/node_modules/should/lib/ext/type.js
/usr/lib/node_modules/should/lib/ext/browser/jquery.js
/usr/share/doc/nodejs-should-3.3.1/History.md
/usr/share/doc/nodejs-should-3.3.1/Readme.md
/usr/share/doc/nodejs-should-3.3.1/examples/runner.js

Changelog

2014-06-07 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.1-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
2014-04-20 - Jamie Nguyen <jamielinux@fedoraproject.org> - 3.3.1-1
- update to upstream release 3.3.1
2014-03-02 - Jamie Nguyen <jamielinux@fedoraproject.org> - 3.1.3-1
- update to upstream release 3.1.3
2013-07-28 - Jamie Nguyen <jamielinux@fedoraproject.org> - 1.2.2-3
- restrict to compatible arches
2013-06-19 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.2.2-2
- rebuild for missing npm(should) provides on EL6
2013-02-24 - Jamie Nguyen <jamielinux@fedoraproject.org> - 1.2.2-1
- update to upstream release 1.2.2
- fix typo in description
2013-02-14 - Jamie Nguyen <jamielinux@fedoraproject.org> - 1.2.1-1
- initial package

See Also

Package Description
nodejs-showdown-0.3.1-5.el6.noarch.rpm A JavaScript port of the original Perl version of Markdown
nodejs-sigmund-1.0.0-5.el6.noarch.rpm Quick and dirty signatures for Objects
nodejs-silent-npm-registry-client-0.0.1-2.el6.noarch.rpm Npm registry client that doesn't spam stdout/stderr
nodejs-slide-1.1.5-1.el6.noarch.rpm A flow control library that fits in a slideshow
nodejs-snockets-1.3.8-5.el6.noarch.rpm A JavaScript/CoffeeScript concatenation tool for Node.js inspired by Sprockets
nodejs-sntp-0.2.4-1.el6.noarch.rpm SNTP v4 client (RFC4330) for Node.js
nodejs-source-map-0.1.33-1.el6.noarch.rpm Node.js library that generates and consumes source maps
nodejs-split-0.3.3-1.el6.noarch.rpm Split a text stream into a line stream
nodejs-sprintf-0.1.5-1.el6.noarch.rpm JavaScript sprintf implementation
nodejs-stack-trace-0.0.9-1.el6.noarch.rpm Node.js module to get v8 stack traces as an array of CallSite objects
nodejs-static-favicon-1.0.2-2.el6.noarch.rpm Favicon serving middleware with caching for Node.js and Connect
nodejs-stream-combiner-0.2.1-1.el6.noarch.rpm Turn a pipeline into a single stream
nodejs-stream-counter-0.2.0-3.el6.noarch.rpm Keeps track of how many bytes have been written to a stream
nodejs-stream-reduce-1.0.3-1.el6.noarch.rpm Reduce stream data to a single value
nodejs-stream-spigot-3.0.5-2.el6.noarch.rpm Testing or converting simple functions into Readable streams
Advertisement
Advertisement