nodejs-read-package-json-1.1.3-1.el6.noarch.rpm


Advertisement

Description

nodejs-read-package-json - npm's package.json parser

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name nodejs-read-package-json
Package version 1.1.3
Package release 1.el6
Package architecture noarch
Package type rpm
Installed size 19.64 KB
Download size 11.21 KB
Official Mirror dl.fedoraproject.org
The thing npm uses to read package.json files, with semantics, defaults and
validation.

Alternatives

Package Version Architecture Repository
nodejs-read-package-json-1.1.3-1.sdl6.noarch.rpm 1.1.3 noarch PUIAS Unsupported
nodejs-read-package-json-1.1.3-1.sdl6.noarch.rpm 1.1.3 noarch PUIAS Unsupported
nodejs-read-package-json-1.1.3-1.el6.noarch.rpm 1.1.3 noarch EPEL
nodejs-read-package-json - - -

Requires

Name Value
nodejs(engine) -
npm(glob) >= 3.2.1
npm(glob) < 3.3
npm(lru-cache) >= 2
npm(lru-cache) < 3
npm(normalize-package-data) >= 0.2
npm(normalize-package-data) < 1

Provides

Name Value
nodejs-read-package-json = 1.1.3-1.el6
npm(read-package-json) = 1.1.3

Download

Type URL
Binary Package nodejs-read-package-json-1.1.3-1.el6.noarch.rpm
Source Package nodejs-read-package-json-1.1.3-1.el6.src.rpm

Install Howto

  1. Download the latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install nodejs-read-package-json rpm package:
    # yum install nodejs-read-package-json

Files

Path
/usr/lib/node_modules/read-package-json/package.json
/usr/lib/node_modules/read-package-json/read-json.js
/usr/lib/node_modules/read-package-json/node_modules/glob
/usr/lib/node_modules/read-package-json/node_modules/lru-cache
/usr/lib/node_modules/read-package-json/node_modules/normalize-package-data
/usr/share/doc/nodejs-read-package-json-1.1.3/LICENSE
/usr/share/doc/nodejs-read-package-json-1.1.3/README.md

Changelog

2013-09-07 - Jamie Nguyen <jamielinux@fedoraproject.org> - 1.1.3-1
- update to upstream release 1.1.3
- change License from BSD to ISC
- add ExclusiveArch logic
2013-07-30 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.1.1-1
- new upstream release 1.1.1
2013-06-24 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.1.0-2
- remove unneeded dependency fix on lru-cache
2013-06-23 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.1.0-1
- new upstream release 1.1.0
2013-06-22 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.3.0-5
- restrict to compatible arches
2013-04-15 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.3.0-4
- add macro for EPEL6 dependency generation
2013-04-15 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.3.0-3
- fix lru-cache dep
2013-04-05 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.3.0-2
- drop outdated dependency fix
2013-04-03 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.3.0-1
- new upstream release 0.3.0
2013-03-13 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.2.2-1
- new upstream release 0.2.2

See Also

Package Description
nodejs-readable-stream-1.1.9-1.el6.noarch.rpm Streams2, a user-land copy of the stream library from Node.js v0.10.x
nodejs-readdirp-0.4.0-1.el6.noarch.rpm Recursive version of Node's fs.readdir with a streaming API
nodejs-reduce-component-1.0.1-1.el6.noarch.rpm An array reduce component for Node.js
nodejs-registry-url-2.0.0-3.el6.noarch.rpm Get the set npm registry URL
nodejs-repl-0.1.3-3.el6.noarch.rpm A lightweight templating library for Node.js
nodejs-request-2.25.0-3.el6.noarch.rpm Simplified HTTP request client
nodejs-require-all-0.0.6-3.el6.noarch.rpm Require all files within a directory
nodejs-require-cs-0.4.4-1.el6.noarch.rpm An AMD loader plugin for CoffeeScript
nodejs-require-uncached-1.0.2-1.el6.noarch.rpm Require a module bypassing the cache
nodejs-requirejs-2.1.11-3.el6.noarch.rpm Node.js adapter for RequireJS, for loading AMD modules
nodejs-resolve-0.5.0-1.el6.noarch.rpm Resolve like require.resolve() on behalf of files asynchronously/synchronously
nodejs-resolve-from-1.0.0-1.el6.noarch.rpm Resolve the path of a module like require.resolve() but from a given path
nodejs-response-time-1.0.0-1.el6.noarch.rpm X-Response-Time header for Node.js and Connect
nodejs-retry-0.6.0-5.el6.noarch.rpm Retry strategies for failed operations
nodejs-revalidator-0.1.7-1.el6.noarch.rpm A cross-browser/Node.js validator used by resourceful
Advertisement
Advertisement