nodejs-rc-0.5.4-3.el6.noarch.rpm


Advertisement

Description

nodejs-rc - Hardwired configuration loader

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name nodejs-rc
Package version 0.5.4
Package release 3.el6
Package architecture noarch
Package type rpm
Installed size 10.80 KB
Download size 10.05 KB
Official Mirror dl.fedoraproject.org
The non-configurable configuration loader for lazy people.

Alternatives

Package Version Architecture Repository
nodejs-rc-0.5.4-3.el6.noarch.rpm 0.5.4 noarch EPEL
nodejs-rc - - -

Requires

Name Value
/usr/bin/env -
nodejs(engine) -
npm(deep-extend) < 1
npm(deep-extend) -
npm(ini) -
npm(ini) >= 1.1.0
npm(ini) < 1.2
npm(minimist) < 1
npm(minimist) -
npm(strip-json-comments) -

Provides

Name Value
nodejs-rc = 0.5.4-3.el6
npm(rc) = 0.5.4

Download

Type URL
Binary Package nodejs-rc-0.5.4-3.el6.noarch.rpm
Source Package nodejs-rc-0.5.4-3.el6.src.rpm

Install Howto

  1. Download the latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install nodejs-rc rpm package:
    # yum install nodejs-rc

Files

Path
/usr/lib/node_modules/rc/browser.js
/usr/lib/node_modules/rc/index.js
/usr/lib/node_modules/rc/package.json
/usr/lib/node_modules/rc/lib/utils.js
/usr/lib/node_modules/rc/node_modules/deep-extend
/usr/lib/node_modules/rc/node_modules/ini
/usr/lib/node_modules/rc/node_modules/minimist
/usr/lib/node_modules/rc/node_modules/strip-json-comments
/usr/share/doc/nodejs-rc-0.5.4/LICENSE.APACHE2
/usr/share/doc/nodejs-rc-0.5.4/LICENSE.BSD
/usr/share/doc/nodejs-rc-0.5.4/LICENSE.MIT
/usr/share/doc/nodejs-rc-0.5.4/README.md

Changelog

2016-01-13 - Parag Nemade <pnemade AT redhat DOT com> - 0.5.4-3
- Specify exclusively arch list as per nodejs packaging guidelines
2015-12-28 - Parag Nemade <pnemade AT redhat DOT com> - 0.5.4-2.1
- Fix npm(strip-json-comments)
2014-12-08 - Parag Nemade <pnemade AT redhat DOT com> - 0.5.4-2
- Add missing multilicense tag and its text
2014-12-04 - Parag Nemade <pnemade AT redhat DOT com> - 0.5.4-1
- Initial packaging

See Also

Package Description
nodejs-read-1.0.5-1.el6.noarch.rpm An implementation of read(1) for node programs
nodejs-read-all-stream-0.1.2-3.el6.noarch.rpm Read all stream content and pass it to callback
nodejs-read-installed-0.2.4-1.el6.noarch.rpm Returns a tree structure of all installed packages in a folder
nodejs-read-package-json-1.1.3-1.el6.noarch.rpm npm's package.json parser
nodejs-readable-stream-1.1.9-1.el6.noarch.rpm Streams2, a user-land copy of the stream library from Node.js v0.10.x
nodejs-readdirp-0.4.0-1.el6.noarch.rpm Recursive version of Node's fs.readdir with a streaming API
nodejs-reduce-component-1.0.1-1.el6.noarch.rpm An array reduce component for Node.js
nodejs-registry-url-2.0.0-3.el6.noarch.rpm Get the set npm registry URL
nodejs-repl-0.1.3-3.el6.noarch.rpm A lightweight templating library for Node.js
nodejs-request-2.25.0-3.el6.noarch.rpm Simplified HTTP request client
nodejs-require-all-0.0.6-3.el6.noarch.rpm Require all files within a directory
nodejs-require-cs-0.4.4-1.el6.noarch.rpm An AMD loader plugin for CoffeeScript
nodejs-require-uncached-1.0.2-1.el6.noarch.rpm Require a module bypassing the cache
nodejs-requirejs-2.1.11-3.el6.noarch.rpm Node.js adapter for RequireJS, for loading AMD modules
nodejs-resolve-0.5.0-1.el6.noarch.rpm Resolve like require.resolve() on behalf of files asynchronously/synchronously
Advertisement
Advertisement