nodejs-pg-0.12.3-2.el6.x86_64.rpm


Advertisement

Description

nodejs-pg - PostgreSQL client for Node.js - pure JavaScript and libpq with the same API

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name nodejs-pg
Package version 0.12.3
Package release 2.el6
Package architecture x86_64
Package type rpm
Installed size 110.09 KB
Download size 39.70 KB
Official Mirror dl.fedoraproject.org
PostgreSQL client for Node.js with pure JavaScript client and native
libpq bindings that share the same API.
Supported PostgreSQL features include:
- parameterized queries
- named statements with query plan caching
- asynchronous notifications with LISTEN/NOTIFY
- bulk import & export with COPY TO/COPY FROM
- extensible js<->postgresql data-type coercion

Alternatives

Package Version Architecture Repository
nodejs-pg-0.12.3-2.el6.i686.rpm 0.12.3 i686 EPEL
nodejs-pg - - -

Requires

Name Value
libc.so.6(GLIBC_2.4)(64bit) -
libgcc_s.so.1()(64bit) -
libgcc_s.so.1(GCC_3.0)(64bit) -
libm.so.6()(64bit) -
libpq.so.5()(64bit) -
libpthread.so.0()(64bit) -
libstdc++.so.6()(64bit) -
libstdc++.so.6(GLIBCXX_3.4)(64bit) -
nodejs(abi) = 0.10
nodejs(engine) >= 0.8.0
nodejs(v8-abi) = 3.14
npm(generic-pool) >= 2.0.2
npm(generic-pool) < 2.1

Provides

Name Value
nodejs-pg = 0.12.3-2.el6
nodejs-pg(x86-64) = 0.12.3-2.el6
npm(pg) = 0.12.3

Download

Type URL
Binary Package nodejs-pg-0.12.3-2.el6.x86_64.rpm
Source Package nodejs-pg-0.12.3-2.el6.src.rpm

Install Howto

  1. Download the latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install nodejs-pg rpm package:
    # yum install nodejs-pg

Files

Path
/usr/lib/node_modules/pg/package.json
/usr/lib/node_modules/pg/wscript
/usr/lib/node_modules/pg/build/binding.node
/usr/lib/node_modules/pg/lib/arrayParser.js
/usr/lib/node_modules/pg/lib/binaryParsers.js
/usr/lib/node_modules/pg/lib/client.js
/usr/lib/node_modules/pg/lib/connection-parameters.js
/usr/lib/node_modules/pg/lib/connection.js
/usr/lib/node_modules/pg/lib/copystream.js
/usr/lib/node_modules/pg/lib/defaults.js
/usr/lib/node_modules/pg/lib/index.js
/usr/lib/node_modules/pg/lib/query.js
/usr/lib/node_modules/pg/lib/result.js
/usr/lib/node_modules/pg/lib/textParsers.js
/usr/lib/node_modules/pg/lib/types.js
/usr/lib/node_modules/pg/lib/utils.js
/usr/lib/node_modules/pg/lib/writer.js
/usr/lib/node_modules/pg/lib/native/index.js
/usr/lib/node_modules/pg/lib/native/query.js
/usr/lib/node_modules/pg/node_modules/generic-pool
/usr/share/doc/nodejs-pg-0.12.3/README.md

Changelog

2013-07-07 - Jamie Nguyen <jamielinux@fedoraproject.org> - 0.12.3-2
- restrict to compatible arches
2013-02-13 - Jamie Nguyen <jamielinux@fedoraproject.org> - 0.12.3-1
- initial package

See Also

Package Description
nodejs-pkginfo-0.3.0-4.el6.noarch.rpm An easy way to expose properties on a module from a package.json
nodejs-posix-getopt-1.1.0-1.el6.noarch.rpm POSIX-style getopt() for Node.js
nodejs-pretty-bytes-0.1.0-1.el6.noarch.rpm Convert bytes to a human readable string
nodejs-promise-4.0.0-1.el6.noarch.rpm Bare bones Promises/A+ implementation for Node.js
nodejs-prompt-0.2.12-1.el6.noarch.rpm A beautiful command-line prompt for Node.js
nodejs-promzard-0.2.0-6.el6.noarch.rpm A prompting wizard for building files from specialized PromZard modules
nodejs-propagate-0.3.1-1.el6.noarch.rpm Propagate events
nodejs-proto-list-1.2.2-5.el6.noarch.rpm A list of objects bound by prototype chain
nodejs-pubcontrol-0.3.5-1.el6.noarch.rpm HTTP Extensible Pubsub Control Protocol (EPCP) library for Node.js
nodejs-q-0.9.6-2.el6.noarch.rpm A tool for making and composing asynchronous promises in JavaScript
nodejs-q-io-1.9.4-2.el6.noarch.rpm Interfaces for IO using Q promises in JavaScript on Node.js
nodejs-qs-0.6.6-3.el6.noarch.rpm Query string parser for Node.js
nodejs-range-parser-1.0.0-1.el6.noarch.rpm Range header field string parser for Node.js
nodejs-raw-body-1.1.4-2.el6.noarch.rpm Get and validate the raw body of a readable stream
nodejs-rc-0.5.4-3.el6.noarch.rpm Hardwired configuration loader
Advertisement
Advertisement