nodejs-normalize-package-data-0.2.1-1.el6.noarch.rpm


Advertisement

Description

nodejs-normalize-package-data - Normalizes npm/package.json metadata

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name nodejs-normalize-package-data
Package version 0.2.1
Package release 1.el6
Package architecture noarch
Package type rpm
Installed size 20.41 KB
Download size 12.35 KB
Official Mirror dl.fedoraproject.org
normalize-package-data exports a function that normalizes package metadata. This
data is typically found in a package.json file, but in principle could come from
any source - for example the npm registry.
normalize-package-data is used by read-package-json to normalize the data it
reads from a package.json file. In turn, read-package-json is used by npm and
various npm-related tools.

Alternatives

Package Version Architecture Repository
nodejs-normalize-package-data-0.2.1-1.sdl6.noarch.rpm 0.2.1 noarch PUIAS Unsupported
nodejs-normalize-package-data-0.2.1-1.sdl6.noarch.rpm 0.2.1 noarch PUIAS Unsupported
nodejs-normalize-package-data-0.2.1-1.el6.noarch.rpm 0.2.1 noarch EPEL
nodejs-normalize-package-data - - -

Requires

Name Value
nodejs(engine) -
npm(github-url-from-git) >= 1.1.1
npm(github-url-from-git) < 1.2
npm(semver) < 3
npm(semver) >= 2

Provides

Name Value
nodejs-normalize-package-data = 0.2.1-1.el6
npm(normalize-package-data) = 0.2.1

Download

Type URL
Binary Package nodejs-normalize-package-data-0.2.1-1.el6.noarch.rpm
Source Package nodejs-normalize-package-data-0.2.1-1.el6.src.rpm

Install Howto

  1. Download the latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install nodejs-normalize-package-data rpm package:
    # yum install nodejs-normalize-package-data

Files

Path
/usr/lib/node_modules/normalize-package-data/package.json
/usr/lib/node_modules/normalize-package-data/lib/extract_description.js
/usr/lib/node_modules/normalize-package-data/lib/fixer.js
/usr/lib/node_modules/normalize-package-data/lib/normalize.js
/usr/lib/node_modules/normalize-package-data/lib/typos.json
/usr/lib/node_modules/normalize-package-data/node_modules/github-url-from-git
/usr/lib/node_modules/normalize-package-data/node_modules/semver
/usr/share/doc/nodejs-normalize-package-data-0.2.1/AUTHORS
/usr/share/doc/nodejs-normalize-package-data-0.2.1/LICENSE
/usr/share/doc/nodejs-normalize-package-data-0.2.1/README.md

Changelog

2013-07-30 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.2.1-1
- new upstream release 0.2.1
2013-06-23 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.2.0-1
- new upstream release 0.2.0
- temporarily ignore test results to make semver update easier
2013-06-22 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.1.6-2
- restrict to compatible arches
2013-06-02 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.1.6-1
- initial package

See Also

Package Description
nodejs-npm-registry-client-0.2.28-3.el6.noarch.rpm Client for the npm registry
nodejs-npm-user-validate-0.0.3-1.el6.noarch.rpm Username, password, and e-mail validation for the npm registry
nodejs-npmconf-0.1.2-1.el6.noarch.rpm npm configuration module
nodejs-npmlog-0.0.4-1.el6.noarch.rpm Logger for npm
nodejs-nsp-api-1.0.0-2.3.el6.noarch.rpm Node.js module for NSP API
nodejs-nsp-audit-shrinkwrap-1.0.3-2.el6.noarch.rpm Audits a shrinkwrap file against the NSP module vulnerability database
nodejs-nth-check-1.0.1-3.el6.noarch.rpm Performant nth-check parser & compiler
nodejs-oauth-sign-0.3.0-1.el6.noarch.rpm OAuth1 signing for Node.js
nodejs-object-assign-2.0.0-2.el6.noarch.rpm ES6 Object.assign() ponyfill
nodejs-on-headers-1.0.1-2.el6.noarch.rpm Execute a listener when a response is about to write headers
nodejs-once-1.1.1-5.el6.noarch.rpm Run a function exactly one time
nodejs-opener-1.3.0-7.el6.noarch.rpm Opens stuff, like webpages and files and executables
nodejs-optimist-0.4.0-1.el6.noarch.rpm Light-weight option parsing for Node.js
nodejs-options-0.0.5-4.el6.noarch.rpm Light-weight in-code option parser for nodejs
nodejs-opts-1.2.2-5.el6.noarch.rpm Javascript Command Line Options for Node.js
Advertisement
Advertisement