nodejs-muffin-0.9.0-2.el6.noarch.rpm


Advertisement

Description

nodejs-muffin - Node.js module with handy helpers for building Cakefiles

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name nodejs-muffin
Package version 0.9.0
Package release 2.el6
Package architecture noarch
Package type rpm
Installed size 124.73 KB
Download size 34.14 KB
Official Mirror dl.fedoraproject.org
This Node.js module has handy helpers for building Cakefiles.
It has a set of generic high level file operations you don't want to implement
yourself, like copying files, CoffeeScript compilation and compile time
requiring, minification, and SLOC counting.

Alternatives

Package Version Architecture Repository
nodejs-muffin-0.9.0-2.el6.noarch.rpm 0.9.0 noarch EPEL
nodejs-muffin - - -

Requires

Name Value
cloc -
nodejs(engine) -
npm(coffee-script) >= 1.4
npm(coffee-script) < 2
npm(glob) >= 3.1
npm(glob) < 4
npm(prompt) < 1
npm(prompt) >= 0.2
npm(q) < 1
npm(q) >= 0.9
npm(q-io) >= 1.6
npm(q-io) < 2
npm(snockets) >= 1.3
npm(snockets) < 2
npm(temp) >= 0.5
npm(temp) < 1
npm(uglify-js) >= 2.2
npm(uglify-js) < 3

Provides

Name Value
nodejs-muffin = 0.9.0-2.el6
npm(muffin) = 0.9.0

Download

Type URL
Binary Package nodejs-muffin-0.9.0-2.el6.noarch.rpm
Source Package nodejs-muffin-0.9.0-2.el6.src.rpm

Install Howto

  1. Download latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install nodejs-muffin rpm package:
    # yum install nodejs-muffin

Files

Path
/usr/lib/node_modules/muffin/package.json
/usr/lib/node_modules/muffin/deps/cloc.pl
/usr/lib/node_modules/muffin/deps/cloc_lang_def.txt
/usr/lib/node_modules/muffin/lib/logo.png
/usr/lib/node_modules/muffin/lib/muffin.js
/usr/lib/node_modules/muffin/node_modules/coffee-script
/usr/lib/node_modules/muffin/node_modules/glob
/usr/lib/node_modules/muffin/node_modules/prompt
/usr/lib/node_modules/muffin/node_modules/q
/usr/lib/node_modules/muffin/node_modules/q-io
/usr/lib/node_modules/muffin/node_modules/snockets
/usr/lib/node_modules/muffin/node_modules/temp
/usr/lib/node_modules/muffin/node_modules/uglify-js
/usr/share/doc/nodejs-muffin-0.9.0/Readme.md
/usr/share/doc/nodejs-muffin-0.9.0/docs/docco.css
/usr/share/doc/nodejs-muffin-0.9.0/docs/muffin.html
/usr/share/doc/nodejs-muffin-0.9.0/docs/public/
/usr/share/doc/nodejs-muffin-0.9.0/docs/public/stylesheets/normalize.css

Changelog

2013-06-20 - Jamie Nguyen <jamielinux@fedoraproject.org> - 0.9.0-2
- make versioned dependencies less specific
2013-05-26 - Jamie Nguyen <jamielinux@fedoraproject.org> - 0.9.0-1
- update to upstream release 0.9.0
- now using uglify-js 2.x branch
- patches for new q API have now been upstreamed
- add symlink for cloc.pl
2013-02-13 - Jamie Nguyen <jamielinux@fedoraproject.org> - 0.7.0-1
- initial package

See Also

Package Description
nodejs-multimatch-0.1.0-1.el6.noarch.rpm Adds multiple patterns support to minimatch.match()
nodejs-multiparty-3.2.4-2.el6.noarch.rpm A multipart/form-data parser for Node.js which supports streaming
nodejs-mute-stream-0.0.4-1.el6.noarch.rpm Basic pass-through stream, but when muted, the bytes are dropped
nodejs-mysql-2.0.0-alpha9.2.el6.2.noarch.rpm A node.js driver for mysql
nodejs-nan-0.4.4-3.el6.noarch.rpm Native Abstractions for Node.js
nodejs-ncp-0.5.0-1.el6.noarch.rpm Asynchronous recursive file copy utility for Node.js
nodejs-negotiator-0.4.3-2.el6.noarch.rpm An HTTP content negotiator for Node.js
nodejs-next-tick-0.2.2-2.el6.noarch.rpm Environment agnostic nextTick polyfill
nodejs-node-expat-2.0.0-6.el6.x86_64.rpm Fast libexpat XML SAX parser binding for Node.js
nodejs-node-print-0.0.4-2.1.el6.noarch.rpm Printf in JavaScript Node.js module
nodejs-node-static-0.7.1-4.el6.noarch.rpm Simple, compliant file streaming module for node
nodejs-node-stringprep-0.1.8-1.el6.x86_64.rpm ICU StringPrep profiles for Node.js
nodejs-node-uuid-1.4.1-1.el6.noarch.rpm Simple and fast generation of RFC4122 (v1 and v4) UUIDs for Node.js
nodejs-nomnom-1.8.0-1.el6.noarch.rpm Nodejs option parser with generated usage and commands
nodejs-nopt-2.1.2-1.el6.noarch.rpm Node.js option parsing
Advertisement
Advertisement