nodejs-inherits1-1.0.0-11.el6.noarch.rpm


Advertisement

Description

nodejs-inherits1 - A tiny simple way to do classic inheritance in JS - legacy version

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name nodejs-inherits1
Package version 1.0.0
Package release 11.el6
Package architecture noarch
Package type rpm
Installed size 2.73 KB
Download size 6.31 KB
Official Mirror dl.fedoraproject.org
A tiny simple way to do classic inheritance in JavaScript.
This is the legacy version used by many Node.js modules for many years, and is
retained for backward compatibility.  New modules should use the inheritance
functionality available in core Node.js or use the new version of inherits if
they need browser support as well.

Alternatives

Package Version Architecture Repository
nodejs-inherits1-1.0.0-11.sdl6.noarch.rpm 1.0.0 noarch PUIAS Unsupported
nodejs-inherits1-1.0.0-11.sdl6.noarch.rpm 1.0.0 noarch PUIAS Unsupported
nodejs-inherits1-1.0.0-11.el6.noarch.rpm 1.0.0 noarch EPEL
nodejs-inherits1 - - -

Requires

Name Value
nodejs(engine) -

Provides

Name Value
nodejs-inherits1 = 1.0.0-11.el6
npm(inherits) = 1.0.0

Download

Type URL
Binary Package nodejs-inherits1-1.0.0-11.el6.noarch.rpm
Source Package nodejs-inherits1-1.0.0-11.el6.src.rpm

Install Howto

  1. Download the latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install nodejs-inherits1 rpm package:
    # yum install nodejs-inherits1

Files

Path
/usr/lib/node_modules/inherits@1/inherits.js
/usr/lib/node_modules/inherits@1/package.json
/usr/share/doc/nodejs-inherits1-1.0.0/LICENSE
/usr/share/doc/nodejs-inherits1-1.0.0/README.md

Changelog

2013-06-23 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.0.0-11
- restrict to compatible arches
2013-06-07 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.0.0-10
- include LICENSE file from upstream git
2013-06-04 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.0.0-9
- rename to nodejs-inherits1
2013-04-15 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.0.0-8
- add macro for EPEL6 dependency generation
2013-02-14 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
2013-01-08 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.0.0-6
- add missing build section
2013-01-03 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.0.0-5
- correct license tag (thanks to Robin Lee)
2012-12-31 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.0.0-4
- clean up for submission
2012-04-27 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.0.0-3
- guard Requires for F17 automatic depedency generation
2012-02-11 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 1.0.0-2
- switch to automatically generated provides/requires

See Also

Package Description
nodejs-ini-1.1.0-3.el6.noarch.rpm An INI parser/serializer for node.js
nodejs-init-package-json-0.0.10-1.el6.noarch.rpm A node module to get your node module started
nodejs-ip-0.3.2-1.el6.noarch.rpm IP address utilities for node.js
nodejs-is-builtin-module-1.0.0-1.el6.noarch.rpm Check if a string matches the name of a Node.js builtin module
nodejs-is-windows-0.1.0-1.el6.noarch.rpm Returns true if the platform is windows
nodejs-iso8601-1.1.1-5.el6.noarch.rpm Node.js module to parse and print ISO8601 dates
nodejs-isodate-0.1.4-3.el6.noarch.rpm JavaScript ISO 8601 date/time parser for Node.js
nodejs-jade-1.3.1-2.el6.noarch.rpm Jade template engine for Node.js
nodejs-jasmine-growl-reporter-0.2.0-1.el6.noarch.rpm Growl notifications when running Jasmine tests
nodejs-jasmine-reporters-0.4.1-1.el6.noarch.rpm Reporters for the Jasmine behavior-driven development (BDD) framework
nodejs-joose-3.50.0-2.el6.noarch.rpm Post modern self-hosting meta object system for JavaScript
nodejs-joosex-simplerequest-0.2.2-4.el6.noarch.rpm Simple XHR request abstraction for Node.js
nodejs-js-yaml-2.1.3-1.el6.noarch.rpm YAML 1.2 parser and serializer
nodejs-jscoverage-0.3.8-2.el6.noarch.rpm A JavaScript coverage tool for Node.js and browser development
nodejs-json-stringify-safe-5.0.0-1.el6.noarch.rpm JSON.stringify that handles circular references
Advertisement
Advertisement