node-gyp-0.10.6-2.el6.noarch.rpm


Advertisement

Description

node-gyp - Node.js native addon build tool

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name node-gyp
Package version 0.10.6
Package release 2.el6
Package architecture noarch
Package type rpm
Installed size 66.17 KB
Download size 24.85 KB
Official Mirror dl.fedoraproject.org
node-gyp is a cross-platform command-line tool written in Node.js for compiling
native addon modules for Node.js, which takes away the pain of dealing with the
various differences in build platforms. It is the replacement to the node-waf
program which is removed for node v0.8.

Alternatives

Package Version Architecture Repository
node-gyp-0.10.6-2.sdl6.noarch.rpm 0.10.6 noarch PUIAS Unsupported
node-gyp-0.10.6-2.sdl6.noarch.rpm 0.10.6 noarch PUIAS Unsupported
node-gyp-0.10.6-2.el6.noarch.rpm 0.10.6 noarch EPEL
node-gyp - - -

Requires

Name Value
/usr/bin/env -
gcc-c++ -
gyp -
http-parser-devel -
libuv-devel -
nodejs(engine) >= 0.8.0
nodejs-devel -
npm(fstream) < 1
npm(glob) >= 3
npm(glob) < 4
npm(graceful-fs) >= 2
npm(graceful-fs) < 3
npm(minimatch) < 1
npm(mkdirp) < 1
npm(nopt) >= 2
npm(nopt) < 3
npm(npmlog) < 1
npm(osenv) < 1
npm(request) >= 2
npm(request) < 3
npm(rimraf) >= 2
npm(rimraf) < 3
npm(semver) >= 2.1
npm(semver) < 2.2
npm(tar) < 1
npm(which) < 2
npm(which) >= 1
v8-devel -

Provides

Name Value
node-gyp = 0.10.6-2.el6
npm(node-gyp) = 0.10.6

Download

Type URL
Binary Package node-gyp-0.10.6-2.el6.noarch.rpm
Source Package node-gyp-0.10.6-2.el6.src.rpm

Install Howto

  1. Download the latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install node-gyp rpm package:
    # yum install node-gyp

Files

Path
/usr/bin/node-gyp
/usr/lib/node_modules/node-gyp/addon-rpm.gypi
/usr/lib/node_modules/node-gyp/addon.gypi
/usr/lib/node_modules/node-gyp/package.json
/usr/lib/node_modules/node-gyp/bin/node-gyp.js
/usr/lib/node_modules/node-gyp/lib/build.js
/usr/lib/node_modules/node-gyp/lib/clean.js
/usr/lib/node_modules/node-gyp/lib/configure.js
/usr/lib/node_modules/node-gyp/lib/configure.js.orig
/usr/lib/node_modules/node-gyp/lib/install.js
/usr/lib/node_modules/node-gyp/lib/list.js
/usr/lib/node_modules/node-gyp/lib/node-gyp.js
/usr/lib/node_modules/node-gyp/lib/rebuild.js
/usr/lib/node_modules/node-gyp/lib/remove.js
/usr/lib/node_modules/node-gyp/node_modules/fstream
/usr/lib/node_modules/node-gyp/node_modules/glob
/usr/lib/node_modules/node-gyp/node_modules/graceful-fs
/usr/lib/node_modules/node-gyp/node_modules/minimatch
/usr/lib/node_modules/node-gyp/node_modules/mkdirp
/usr/lib/node_modules/node-gyp/node_modules/nopt
/usr/lib/node_modules/node-gyp/node_modules/npmlog
/usr/lib/node_modules/node-gyp/node_modules/osenv
/usr/lib/node_modules/node-gyp/node_modules/request
/usr/lib/node_modules/node-gyp/node_modules/rimraf
/usr/lib/node_modules/node-gyp/node_modules/semver
/usr/lib/node_modules/node-gyp/node_modules/tar
/usr/lib/node_modules/node-gyp/node_modules/which
/usr/share/doc/node-gyp-0.10.6/LICENSE
/usr/share/doc/node-gyp-0.10.6/README.md

Changelog

2013-07-30 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.10.6-2
- fix semver dep
2013-07-12 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.10.6-1
- new upstream release 0.10.6
2013-06-22 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.10.1-1
- new upstream release 0.10.1
2013-06-22 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-3
- restrict to compatible arches
2013-04-15 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-2
- add macro for EPEL6 dependency generation
2013-04-03 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.5-1
- new upstream release 0.9.5
2013-03-13 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.1-2
- update addon-rpm.gypi
- split out addon-rpm.gypi so it's easier to maintain
2013-03-13 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.9.1-1
- new upstream release 0.9.1
2013-02-09 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.8.4-1
- new upstream release 0.8.4
2013-01-21 - T.C. Hollingsworth <tchollingsworth@gmail.com> - 0.8.3-1
- new upstream release 0.8.3
- add missing Requires on http-parser-devel

See Also

Package Description
nodejs-0.10.48-3.el6.i686.rpm JavaScript runtime
nodejs-0.10.48-3.el6.x86_64.rpm JavaScript runtime
nodejs-abbrev-1.0.4-6.el6.noarch.rpm Abbreviation calculator for Node.js
nodejs-ain2-1.3.2-1.el6.noarch.rpm A Node.js module for syslog logging (and a continuation of ain)
nodejs-amdefine-0.0.4-2.el6.noarch.rpm Provide AMD's define() API for declaring modules in the AMD format
nodejs-ansi-0.2.1-1.el6.noarch.rpm ANSI escape codes for Node.js
nodejs-ansi-font-0.0.2-1.el6.noarch.rpm ANSI font styling utils
nodejs-ansi-styles-1.0.0-1.el6.noarch.rpm ANSI escape codes for colorizing strings in the terminal
nodejs-archy-0.0.2-8.el6.noarch.rpm Renders nested hierarchies with unicode pipes
nodejs-argparse-0.1.15-8.el6.noarch.rpm A native port of Python's argparse, an options parsing library
nodejs-as-number-1.0.0-1.el6.noarch.rpm Tiny function that returns the given number, or a default value
nodejs-asap-1.0.0-1.el6.noarch.rpm High-priority task queue for Node.js and browser
nodejs-ascii-tree-0.1.1-2.el6.noarch.rpm A node module for generating a text tree in ASCII
nodejs-asn1-0.1.11-3.el6.noarch.rpm Contains parsers and serializers for ASN.1 (currently BER only)
nodejs-assert-plus-0.1.4-1.el6.noarch.rpm Extra assertions on top of node's assert module
Advertisement
Advertisement