nettle-devel-3.2-2.el6.x86_64.rpm


Advertisement

Description

nettle-devel - Development headers for a low-level cryptographic library

Property Value
Distribution CentOS 6
Repository EPEL x86_64
Package name nettle-devel
Package version 3.2
Package release 2.el6
Package architecture x86_64
Package type rpm
Installed size 1.16 MB
Download size 604.75 KB
Official Mirror dl.fedoraproject.org
Nettle is a cryptographic library that is designed to fit easily in more
or less any context: In crypto toolkits for object-oriented languages
(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
kernel space.  This package contains the files needed for developing
applications with nettle.

Alternatives

Package Version Architecture Repository
nettle-devel-3.2-2.el6.i686.rpm 3.2 i686 EPEL
nettle-devel-3.2-2.el6.i686.rpm 3.2 i686 EPEL
nettle-devel-2.7.1-3.el6.art.i686.rpm 2.7.1 i686 Atomic
nettle-devel-2.7.1-3.el6.art.x86_64.rpm 2.7.1 x86_64 Atomic
nettle-devel-2.2-1.el6.rf.i686.rpm 2.2 i686 Repoforge (RPMforge)
nettle-devel-2.2-1.el6.rf.x86_64.rpm 2.2 x86_64 Repoforge (RPMforge)
nettle-devel-2.1-1.el6.rf.i686.rpm 2.1 i686 Repoforge (RPMforge)
nettle-devel-2.1-1.el6.rf.x86_64.rpm 2.1 x86_64 Repoforge (RPMforge)
nettle-devel-1.15-1.el6.rf.i686.rpm 1.15 i686 Repoforge (RPMforge)
nettle-devel-1.15-1.el6.rf.x86_64.rpm 1.15 x86_64 Repoforge (RPMforge)
nettle-devel - - -

Requires

Name Value
/usr/bin/pkg-config -
gmp-devel(x86-64) -
libhogweed.so.4()(64bit) -
libnettle.so.6()(64bit) -
nettle = 3.2-2.el6

Provides

Name Value
nettle-devel = 3.2-2.el6
nettle-devel(x86-64) = 3.2-2.el6
pkgconfig(hogweed) = 3.2
pkgconfig(nettle) = 3.2

Download

Type URL
Binary Package nettle-devel-3.2-2.el6.x86_64.rpm
Source Package nettle-3.2-2.el6.src.rpm

Install Howto

  1. Download latest epel-release rpm from
    http://dl.fedoraproject.org/pub/epel/6/x86_64/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install nettle-devel rpm package:
    # yum install nettle-devel

Files

Path
/usr/include/nettle/aes.h
/usr/include/nettle/arcfour.h
/usr/include/nettle/arctwo.h
/usr/include/nettle/asn1.h
/usr/include/nettle/base16.h
/usr/include/nettle/base64.h
/usr/include/nettle/bignum.h
/usr/include/nettle/blowfish.h
/usr/include/nettle/buffer.h
/usr/include/nettle/camellia.h
/usr/include/nettle/cast128.h
/usr/include/nettle/cbc.h
/usr/include/nettle/ccm.h
/usr/include/nettle/chacha-poly1305.h
/usr/include/nettle/chacha.h
/usr/include/nettle/ctr.h
/usr/include/nettle/curve25519.h
/usr/include/nettle/des-compat.h
/usr/include/nettle/des.h
/usr/include/nettle/dsa-compat.h
/usr/include/nettle/dsa.h
/usr/include/nettle/eax.h
/usr/include/nettle/ecc-curve.h
/usr/include/nettle/ecc.h
/usr/include/nettle/ecdsa.h
/usr/include/nettle/eddsa.h
/usr/include/nettle/gcm.h
/usr/include/nettle/gosthash94.h
/usr/include/nettle/hmac.h
/usr/include/nettle/knuth-lfib.h
/usr/include/nettle/macros.h
/usr/include/nettle/md2.h
/usr/include/nettle/md4.h
/usr/include/nettle/md5-compat.h
/usr/include/nettle/md5.h
/usr/include/nettle/memxor.h
/usr/include/nettle/nettle-meta.h
/usr/include/nettle/nettle-stdint.h
/usr/include/nettle/nettle-types.h
/usr/include/nettle/pbkdf2.h
/usr/include/nettle/pgp.h
/usr/include/nettle/pkcs1.h
/usr/include/nettle/poly1305.h
/usr/include/nettle/realloc.h
/usr/include/nettle/ripemd160.h
/usr/include/nettle/rsa.h
/usr/include/nettle/salsa20.h
/usr/include/nettle/serpent.h
/usr/include/nettle/sexp.h
/usr/include/nettle/sha.h
/usr/include/nettle/sha1.h
/usr/include/nettle/sha2.h
/usr/include/nettle/sha3.h
/usr/include/nettle/twofish.h
/usr/include/nettle/umac.h
/usr/include/nettle/version.h
/usr/include/nettle/yarrow.h
/usr/lib64/libhogweed.so
/usr/lib64/libnettle.so
/usr/lib64/pkgconfig/hogweed.pc
/usr/lib64/pkgconfig/nettle.pc
/usr/share/doc/nettle-devel-3.2/descore.README
/usr/share/doc/nettle-devel-3.2/nettle.html
/usr/share/doc/nettle-devel-3.2/nettle.pdf

Changelog

See nettle-3.2-2.el6.x86_64.rpm changelog.

See Also

Package Description
nexcontrol-0.2-3.el6.noarch.rpm Software to control your Celestron NexStar Telescope
nexuiz-2.5.2-2.1.el6.x86_64.rpm Multiplayer, deathmatch oriented first person shooter
nexuiz-data-2.5.2-1.el6.noarch.rpm Game data for the Nexuiz first person shooter
nexuiz-server-2.5.2-2.1.el6.x86_64.rpm Dedicated server for the Nexuiz first person shooter
nfdump-1.6.11-1.el6.x86_64.rpm NetFlow collecting and processing tools
nfs-ganesha-2.3.2-1.el6.x86_64.rpm NFS Server running in user space
nfs-ganesha-mount-9P-2.3.2-1.el6.x86_64.rpm a 9p mount helper
nfs-ganesha-nullfs-2.3.2-1.el6.x86_64.rpm The NFS-GANESHA's NULLFS Stackable FSAL
nfs-ganesha-proxy-2.3.2-1.el6.x86_64.rpm The NFS-GANESHA's PROXY FSAL
nfs-ganesha-utils-2.3.2-1.el6.x86_64.rpm The NFS-GANESHA's util scripts
nfs-ganesha-vfs-2.3.2-1.el6.x86_64.rpm The NFS-GANESHA's VFS FSAL
nfsometer-1.6-1.el6.noarch.rpm NFS Performance Framework Tool
nghttp2-1.6.0-1.el6.1.x86_64.rpm Meta-package that only requires libnghttp2
nginx-1.10.2-1.el6.x86_64.rpm A high performance web server and reverse proxy server
nginx-all-modules-1.10.2-1.el6.noarch.rpm A meta package that installs all available Nginx modules
Advertisement
Advertisement