root-geom-5.34.38-3.el6.i686.rpm


Advertisement

Description

root-geom - Geometry library for ROOT

Property Value
Distribution CentOS 6
Repository EPEL i386
Package filename root-geom-5.34.38-3.el6.i686.rpm
Package name root-geom
Package version 5.34.38
Package release 3.el6
Package architecture i686
Package type rpm
Homepage https://root.cern/
License LGPLv2+
Maintainer -
Download size 1.28 MB
Installed size 6.59 MB
This package contains a library for defining geometries in ROOT.

Alternatives

Package Version Architecture Repository
root-geom-5.34.38-3.el6.x86_64.rpm 5.34.38 x86_64 EPEL
root-geom - - -

Requires

Name Value
/sbin/ldconfig -
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libCint.so.5.34 -
libCore.so.5.34 -
libGed.so.5.34 -
libGpad.so.5.34 -
libGraf3d.so.5.34 -
libGui.so.5.34 -
libHist.so.5.34 -
libMathCore.so.5.34 -
libRIO.so.5.34 -
libThread.so.5.34 -
libTree.so.5.34 -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libm.so.6(GLIBC_2.1) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.9) -
root-cint(x86-32) = 5.34.38-3.el6
root-core(x86-32) = 5.34.38-3.el6
root-graf-gpad(x86-32) = 5.34.38-3.el6
root-graf3d(x86-32) = 5.34.38-3.el6
root-gui(x86-32) = 5.34.38-3.el6
root-gui-ged(x86-32) = 5.34.38-3.el6
root-hist(x86-32) = 5.34.38-3.el6
root-io(x86-32) = 5.34.38-3.el6
root-mathcore(x86-32) = 5.34.38-3.el6
root-tree(x86-32) = 5.34.38-3.el6
rtld(GNU_HASH) -

Provides

Name Value
libGeom.so.5.34 -
libGeomBuilder.so.5.34 -
libGeomPainter.so.5.34 -
root-geom = 5.34.38-3.el6
root-geom(x86-32) = 5.34.38-3.el6

Download

Type URL
Mirror download-ib01.fedoraproject.org
Binary Package root-geom-5.34.38-3.el6.i686.rpm
Source Package root-5.34.38-3.el6.src.rpm

Install Howto

  1. Download latest epel-release rpm from
    http://download-ib01.fedoraproject.org/pub/epel/6/i386/
  2. Install epel-release rpm:
    # rpm -Uvh epel-release*rpm
  3. Install root-geom rpm package:
    # yum install root-geom

Files

Path
/usr/include/root/TGeoArb8.h
/usr/include/root/TGeoAtt.h
/usr/include/root/TGeoBBox.h
/usr/include/root/TGeoBBoxEditor.h
/usr/include/root/TGeoBoolNode.h
/usr/include/root/TGeoBranchArray.h
/usr/include/root/TGeoBuilder.h
/usr/include/root/TGeoCache.h
/usr/include/root/TGeoChecker.h
/usr/include/root/TGeoCompositeShape.h
/usr/include/root/TGeoCone.h
/usr/include/root/TGeoConeEditor.h
/usr/include/root/TGeoElement.h
/usr/include/root/TGeoEltu.h
/usr/include/root/TGeoEltuEditor.h
/usr/include/root/TGeoExtension.h
/usr/include/root/TGeoGedFrame.h
/usr/include/root/TGeoGlobalMagField.h
/usr/include/root/TGeoHalfSpace.h
/usr/include/root/TGeoHelix.h
/usr/include/root/TGeoHype.h
/usr/include/root/TGeoHypeEditor.h
/usr/include/root/TGeoManager.h
/usr/include/root/TGeoManagerEditor.h
/usr/include/root/TGeoMaterial.h
/usr/include/root/TGeoMaterialEditor.h
/usr/include/root/TGeoMatrix.h
/usr/include/root/TGeoMatrixEditor.h
/usr/include/root/TGeoMedium.h
/usr/include/root/TGeoMediumEditor.h
/usr/include/root/TGeoNavigator.h
/usr/include/root/TGeoNode.h
/usr/include/root/TGeoNodeEditor.h
/usr/include/root/TGeoOverlap.h
/usr/include/root/TGeoPainter.h
/usr/include/root/TGeoPara.h
/usr/include/root/TGeoParaEditor.h
/usr/include/root/TGeoParaboloid.h
/usr/include/root/TGeoParallelWorld.h
/usr/include/root/TGeoPatternFinder.h
/usr/include/root/TGeoPcon.h
/usr/include/root/TGeoPconEditor.h
/usr/include/root/TGeoPgon.h
/usr/include/root/TGeoPgonEditor.h
/usr/include/root/TGeoPhysicalNode.h
/usr/include/root/TGeoPolygon.h
/usr/include/root/TGeoRCPtr.h
/usr/include/root/TGeoScaledShape.h
/usr/include/root/TGeoShape.h
/usr/include/root/TGeoShapeAssembly.h
/usr/include/root/TGeoSphere.h
/usr/include/root/TGeoSphereEditor.h
/usr/include/root/TGeoStateInfo.h
/usr/include/root/TGeoTabManager.h
/usr/include/root/TGeoTorus.h
/usr/include/root/TGeoTorusEditor.h
/usr/include/root/TGeoTrack.h
/usr/include/root/TGeoTrapEditor.h
/usr/include/root/TGeoTrd1.h
/usr/include/root/TGeoTrd1Editor.h
/usr/include/root/TGeoTrd2.h
/usr/include/root/TGeoTrd2Editor.h
/usr/include/root/TGeoTube.h
/usr/include/root/TGeoTubeEditor.h
/usr/include/root/TGeoUniformMagField.h
/usr/include/root/TGeoVolume.h
/usr/include/root/TGeoVolumeEditor.h
/usr/include/root/TGeoVoxelFinder.h
/usr/include/root/TGeoXtru.h
/usr/include/root/TVirtualGeoPainter.h
/usr/include/root/TVirtualGeoTrack.h
/usr/include/root/TVirtualMagField.h
/usr/lib/root/libGeom.rootmap
/usr/lib/root/libGeom.so
/usr/lib/root/libGeom.so.5
/usr/lib/root/libGeom.so.5.34
/usr/lib/root/libGeomBuilder.rootmap
/usr/lib/root/libGeomBuilder.so
/usr/lib/root/libGeomBuilder.so.5
/usr/lib/root/libGeomBuilder.so.5.34
/usr/lib/root/libGeomPainter.rootmap
/usr/lib/root/libGeomPainter.so
/usr/lib/root/libGeomPainter.so.5
/usr/lib/root/libGeomPainter.so.5.34
/usr/share/root/RadioNuclides.txt
/usr/share/root/plugins/TGeoManagerEditor/P010_TGeoManagerEditor.C
/usr/share/root/plugins/TVirtualGeoPainter/P010_TGeoPainter.C

Changelog

2019-07-05 - Mattias Ellert <mattias.ellert@physics.uu.se> - 5.34.38-3
- Rebuild for pythia8 8.2.43
- Use correct library names in plugin definitions
- Fix build failure due to that newer libXrdCl requires c++11
2018-10-25 - Mattias Ellert <mattias.ellert@physics.uu.se> - 5.34.38-2
- Fix crash in TBrowser when root-gui-html is not installed
2018-07-09 - Mattias Ellert <mattias.ellert@physics.uu.se> - 5.34.38-1
- Update to 5.34.38
- Drop patch root-ftgl.patch (used only on EPEL 5)
- Drop patch root-gfal2.patch (accepted upstream)
- Remove compatibility with EPEL 5 (Group tags, BuildRoot tag, etc.)
- New subpackages due to package splits
- root-gui-html from root-gui
- root-gui-qtgsi from root-gui-qt
- root-io-xmlparser from root-io-xml
- root-proof-player from root-proof
- Rename root-guibuilder package to root-gui-builder
- Rename the python package to python2-root
- Add BuildRequires on lz4-devel and xxhash-devel
- Add the packages providing the libraries listed by "root-config --libs"
as dependencies to root-core
- Make root-vdt package noarch
2016-04-08 - Mattias Ellert <mattias.ellert@fysast.uu.se> - 5.34.36-1
- Update to 5.34.36
2016-02-04 - Fedora Release Engineering <releng@fedoraproject.org> - 5.34.32-9
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
2016-01-16 - Mamoru TASAKA <mtasaka@fedoraproject.org> - 5.34.32-8
- Rebuild again for https://fedoraproject.org/wiki/Changes/Ruby_2.3
2016-01-14 - Adam Jackson <ajax@redhat.com> - 5.34.32-7
- Rebuild for glew 1.13
2016-01-12 - Vít Ondruch <vondruch@redhat.com> - 5.34.32-6
- Rebuilt for https://fedoraproject.org/wiki/Changes/Ruby_2.3
2015-11-17 - Mattias Ellert <mattias.ellert@fysast.uu.se> - 5.34.32-5
- Adapt to gfal 2.10 - uses a different #define
- Exclude ppc64le - has the same issues with cint as ppc and ppc64
2015-11-10 - Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.34.32-4
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5

See Also

Package Description
root-graf-5.34.38-3.el6.i686.rpm 2D graphics library for ROOT
root-graf-asimage-5.34.38-3.el6.i686.rpm AfterImage graphics renderer for ROOT
root-graf-fitsio-5.34.38-3.el6.i686.rpm ROOT interface for the Flexible Image Transport System (FITS)
root-graf-gpad-5.34.38-3.el6.i686.rpm Canvas and pad library for ROOT
root-graf-gviz-5.34.38-3.el6.i686.rpm Graphviz 2D library for ROOT
root-graf-postscript-5.34.38-3.el6.i686.rpm Postscript/PDF renderer library for ROOT
root-graf-qt-5.34.38-3.el6.i686.rpm Qt renderer for ROOT
root-graf-x11-5.34.38-3.el6.i686.rpm X window system renderer for ROOT
root-graf3d-5.34.38-3.el6.i686.rpm Basic 3D shapes library for ROOT
root-graf3d-eve-5.34.38-3.el6.i686.rpm Event display library for ROOT
root-graf3d-gl-5.34.38-3.el6.i686.rpm GL renderer for ROOT
root-graf3d-gviz3d-5.34.38-3.el6.i686.rpm Graphviz 3D library for ROOT
root-graf3d-x3d-5.34.38-3.el6.i686.rpm X 3D renderer for ROOT
root-gui-5.34.38-3.el6.i686.rpm GUI library for ROOT
root-gui-builder-5.34.38-3.el6.i686.rpm GUI editor library for ROOT
Advertisement
Advertisement